×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

2901 with EHWIC-D-8ESG-P 8 port card, phones do not get to voice vlan

Unanswered Question
Jan 12th, 2012
User Badges:

I have a 2901 router with a EHWIC-D-8ESG-P card in it. I have configured a DHCP Pool for the voice vlan but the phones get an IP address from the data vlan. What am I doing wrong..,?


ip dhcp excluded-address 10.2.100.1 10.2.100.30

!

ip dhcp pool Phones

network 10.2.100.0 255.255.255.0

default-router 10.2.100.1

option 150 ip 10.0.100.10

!

interface GigabitEthernet0/3/0

switchport voice vlan 100

no ip address

!

interface GigabitEthernet0/3/1

switchport voice vlan 100

no ip address

!

interface GigabitEthernet0/3/2

switchport voice vlan 100

no ip address

!

interface GigabitEthernet0/3/3

switchport voice vlan 100

no ip address

!

interface GigabitEthernet0/3/4

switchport voice vlan 100

no ip address

!

interface GigabitEthernet0/3/5

switchport voice vlan 100

no ip address

!

interface GigabitEthernet0/3/6

switchport voice vlan 100

no ip address

!

interface GigabitEthernet0/3/7

switchport voice vlan 100

no ip address

!

interface Vlan1

ip address 10.2.0.1 255.255.255.0

ip helper-address 10.0.0.5

!

interface Vlan100

ip address 10.2.100.1 255.255.255.0

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
acampbell Thu, 01/12/2012 - 13:17
User Badges:
  • Green, 3000 points or more

Hi,

You have to configure these ports the old fashioned way.

If you want your phones to support both a VOICE VLAN ana
DATA VLAN try this

!
!
!
interface range giga 0/3/0 - 7
desc *** PORTS FOR PHONES & DATA ***
Switchport trunk encapsulation dot1q
Switchport mode trunk
Switchport trunk native vlan 1
Switchport voice vlan 100
Spanning-tree portfast trunk

no ip address

no shut

!


Give it a try


Regards
Alex

Please rate useful posts

paolo bevilacqua Thu, 01/12/2012 - 14:11
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

That is the same finding I had on a 28xx years ago, phones werent getting an address at all. It drove me crazy for hours.

acampbell Thu, 01/12/2012 - 14:23
User Badges:
  • Green, 3000 points or more

Hi Paolo


I have been thinking about this again

I am not sure if he has to create the

VLANS under the vlan.dat aswell.


!

vlan data

vtp trans

vlan 100 name VOICE

vlan 1 name DATA

exit

!


Just in case it is needed


Regards

Alex

getdan Thu, 01/12/2012 - 15:06
User Badges:

No Go... Still having the same issue, thanks for the help...

acampbell Thu, 01/12/2012 - 15:50
User Badges:
  • Green, 3000 points or more

Hi,


With a phone plugged in can

you post

show int vlan 100


Regards

Alex

getdan Thu, 01/12/2012 - 16:12
User Badges:

LeecoWI-Plant-2901#sh int vlan 100
Vlan100 is up, line protocol is up
  Hardware is EtherSVI, address is ccef.48c7.15db (bia ccef.48c7.15db)
  Internet address is 10.2.100.1/24
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not supported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:18, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     371 packets input, 43974 bytes, 0 no buffer
     Received 17 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     2229 packets output, 336242 bytes, 0 underruns
     0 output errors, 1 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
LeecoWI-Plant-2901#

acampbell Fri, 01/13/2012 - 02:52
User Badges:
  • Green, 3000 points or more

Hi


Sorry for the delay.


There always seemed to issues when using switch cards on routers


Can you issue the folowing commands


conf t

!

!

vtp mode trans

!

vlan 1

name DATA

!

vlan 100

name VOICE

!

end



Re check


Regards

Alex

getdan Fri, 01/13/2012 - 07:17
User Badges:

Ya these modules always have issues. I got the older modles to work by putting the in trunk mode but no luck here.

I tried this and no luck

conf t

!

!

vtp mode trans

!

vlan 1

name DATA

!

vlan 100

name VOICE

!

end

acampbell Fri, 01/13/2012 - 07:59
User Badges:
  • Green, 3000 points or more

Hi


When you boot a phone do you see it

configuring VLAN


What model of phon are you using.


Regards

Alex

Actions

This Discussion