Canno't delete a serverfarm

Answered Question
Jan 16th, 2012
User Badges:

Hi all.

I'm working on an ACE and I have to delete a server farm.

As soon I try to delet the server farm I get the following error message:


Error: serverfarm 'xxxxxx' is in use. Cannot delete!



The software version is Version A2(3.4).


Any idea??


Thanks for your support.


Reagrds, Fabio.

Correct Answer by Francesco Casotto about 5 years 4 months ago

Salve Fabio,


it means that the serverfarm is being currently used, so you should first remove the reference to it in the existing loadbalance policies and/or in sticky groups, then remove the serverfarm config.


Useful commands:


show run policy-map

show run sticky

show run | i


If after the cleanup still the error persists let us know.


Saluti,

Francesco

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Francesco Casotto Mon, 01/16/2012 - 03:15
User Badges:
  • Cisco Employee,

Salve Fabio,


it means that the serverfarm is being currently used, so you should first remove the reference to it in the existing loadbalance policies and/or in sticky groups, then remove the serverfarm config.


Useful commands:


show run policy-map

show run sticky

show run | i


If after the cleanup still the error persists let us know.


Saluti,

Francesco

fabio.marino Mon, 01/16/2012 - 04:43
User Badges:

Ciao Francesco,

you right I thought that loadbalance polices were already deleted. Now I fixed the problem.


Many thanks.


Ciao, Fabio.

Juraj Podhajecky Fri, 02/24/2012 - 01:02
User Badges:

Hi Francesco,

I have similar problem - I can not delete couple of serverfarms. Serverfarms are not used and there are no rservers in the serverfarms. Interesting is, that I can delete some other serverfarms. Thanks in advance.


Software

  loader:    Version 12.2[121]

  system:    Version A2(3.3) [build 3.0(0)A2(3.3)]    


Hardware

  Product Number: ACE20-MOD-K9



ACE/XXX# sh serverfarm Wxxx

serverfarm     : Wxxx, type: HOST

total rservers : 0


ACE/XXX# sh run | i Wxxx

Generating configuration....

serverfarm host Wxxx


ACE/XXX# sh conn serverfarm Wxxx

conn-id    np dir proto vlan source                destination           state

----------+--+---+-----+----+---------------------+---------------------+------+


ACE/XXX# sh sticky database | i Wxxx


ACE/XXX(config)# no serverfarm host Wxxx

Error: serverfarm 'Wxxx' is in use. Cannot delete!

Actions

This Discussion