ACE Licence installation failed with no space left on device

Unanswered Question
Jan 16th, 2012
User Badges:

Hi,


The installation of an ACE-4710 throughput upgrade license licence (ACE-AP-02-UP1) failed with an error message :


CH01AC03/Admin#  license install disk0:ACE20111213081741975.lic

Installing license... failed: No space left on device


What could be the cause of such a message ?


Here is the disk:0 usage :


CH01AC03/Admin# dir disk0:


   891 Jun 16 2009 08:38:41 ACE20090616063133861.lic

   252 Nov 10 2009 16:52:45 ACE20091110071123557.lic

   245 Dec 14 2011 15:44:53 ACE20111213081235229.lic

   245 Dec 14 2011 15:44:28 ACE20111213081741975.lic

62333 Jan 09 2012 23:17:48 CH01AC03_2012_01_09_23_17_47.tgz

  1024 Apr 12 2007 22:26:05 cv/

     0 Oct 28 2011 20:33:14 kernel_log_messages1.txt

156554 Oct 28 2011 20:33:09 sysmgr_info

grep: write error: No space left on device


           Usage for disk0: filesystem

                -1213274808 bytes total used

                  139518072 bytes free

                -1073756736 bytes total


I am surprised to observe negative values in the byte total used and byte total !


Here is the ACE software version :


CH01AC03/Admin# sh ver

Cisco Application Control Software (ACSW)

TAC support: http://www.cisco.com/tac

Copyright (c) 1985-2011 by Cisco Systems, Inc. All rights reserved.

The copyrights to certain works contained herein are owned by

other third parties and are used and distributed under license.

Some parts of this software are covered under the GNU Public

License. A copy of the license is available at

http://www.gnu.org/licenses/gpl.html.


Software

  loader:    Version 0.95.1

  system:    Version A4(2.0) [build 3.0(0)A4(2.0) adbuild_19:35:12-2011/02/16_/a

uto/adbure_nightly4/renumber/rel_a4_2_0_throttle/REL_3_0_0_A4_2_0]

  system image file: (hd0,1)/c4710ace-t1k9-mz.A4_2_0.bin

  Device Manager version 4.2 (0) 20110201:0929


  installed license: ACE-AP-01-LIC ACE-AP-VIRT-020 ACE-AP-C-500-LIC ACE-AP-OPT-5

0-K9 ACE-AP-SSL-05K-K9


Hardware

  cpu info:

    Motherboard:

        number of cpu(s): 2

    Daughtercard:

        number of cpu(s): 16

  memory info:

    total: 6226372 kB, free: 3784772 kB

    shared: 0 kB, buffers: 26832 kB, cached 0 kB

  cf info:

    filesystem: /dev/hdb2

    total: 861668 kB, used: 742636 kB, available: 75260 kB


last boot reason:  reload command by admin

configuration register:  0x1

CH01AC03 kernel uptime is 79 days 18 hours 52 minute(s) 50 second(s)


Current licence usage :


CH01AC03/Admin# sh license usage

License                      Ins   Lic    Status   Expiry Date   Comments

                                  Count

--------------------------------------------------------------------------------

ACE-AP-C-UP1                  No     -    Unused                 -

ACE-AP-C-UP2                  No     -    Unused                 -

ACE-AP-C-UP3                  No     -    Unused                 -

ACE-AP-01-LIC                 Yes    1    In use   never         -

ACE-AP-01-UP1                 No     -    Unused                 -

ACE-AP-02-LIC                 No     -    Unused                 -

ACE-AP-02-UP1                 No     -    Unused                 -

ACE-AP-04-LIC                 No     -    Unused                 -

ACE-AP-04-UP1                 No     -    Unused                 -

ACE-AP-04-UP2                 No     -    Unused                 -

ACE-AP-VIRT-5                 No     -    Unused                 -

ACE-AP-500M-LIC               No     -    Unused                 -

ACE-AP-VIRT-020               Yes    1    In use   never         -

ACE-AP-C-100-LIC              No     -    Unused                 -

ACE-AP-C-500-LIC              Yes    1    In use   never         -

ACE-AP-C-500-UP1              No     -    Unused                 -

ACE-AP-OPT-50-K9              Yes    1    In use   never         -

ACE-AP-C-1000-LIC             No     -    Unused                 -

ACE-AP-C-2000-LIC             No     -    Unused                 -

ACE-AP-OPT-LIC-K9             No     -    Unused                 -

ACE-AP-OPT-UP1-K9             No     -    Unused                 -

ACE-AP-SSL-05K-K9             Yes    1    In use   never         -

ACE-AP-SSL-07K-K9             No     -    Unused                 -

ACE-AP-SSL-100-K9             No     -    Unused                 -

ACE-AP-SSL-UP1-K9             No     -    Unused                 -

ACE-AP-SSLUP-5K-K9            No     -    Unused                 -

ACE-AP-VIRT-020-UP            No     -    Unused                 -



Thank you for any help


Yves

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Borys Berlog Mon, 01/16/2012 - 07:16
User Badges:
  • Cisco Employee,

Hi Yves

Can you please check if in your accounting log (show accounting) in Admin context you see a lot of messages from user: anm ? (like "anm:0:xml-show on")

I'd suggest to open a TAC case for this issue.

Antonio Knox Mon, 09/24/2012 - 10:09
User Badges:
  • Silver, 250 points or more

Had this issue a month ago.  Try installing the license via GUI.

Cesar Roque Mon, 09/24/2012 - 10:37
User Badges:
  • Bronze, 100 points or more

Hello Yves,


This is actually a bug: 

CSCtx03563


Open a TAC case to give you the script.  Dont save the running-config if you have to reboot the ACE


-----------------------------

Cesar R

Antonio Knox Mon, 09/24/2012 - 11:11
User Badges:
  • Silver, 250 points or more

I hit this bug a while back.  I tried loading the the CSCtx03563_workaround.bin file (after a reload) that Cisco provided, and it didn't work for me.  I was able to handle the task through the GUI, though.  Just trying to save Yves a little time .  Only difference was I was upgrading to 5(2.0), not installing a license.

Actions

This Discussion

Related Content