Switch Port config for DHCP server with 4 scopes

Unanswered Question
Jan 18th, 2012
User Badges:

Hi,


End user plans to configure a DHCP server (microsoft) with 4 scopes (users,sales, WLAN user, WLAN GUEST).

My doubt is regarding to switch's port configuration that will connect to DHCP server.

I show some part of the sh run.


For wireless network a cisco Wireless Lan Controller will be used.


interface GigabitEthernet2/43
description Cisco WLC Puerto 2 ( To handle traffic of WLAN GUEST)
switchport trunk native vlan 50
switchport mode trunk
!
interface GigabitEthernet2/44
description Cisco WLC Puerto 1 ( to handle traffic of ap-manager interface,managment interface, WLAN user)
switchport trunk native vlan 50
switchport mode trunk


interface GigabitEthernet3/39
description DHCP server  ------------>> DHCP SERVER
switchport access vlan 50
switchport mode access


interface GigabitEthernet3/40
switchport access vlan 50
switchport mode access
!
interface GigabitEthernet3/41
switchport access vlan 116
switchport mode access
!
interface GigabitEthernet3/42
switchport access vlan 117
switchport mode access
!
interface GigabitEthernet3/43
switchport access vlan 118
switchport mode access
!


interface Vlan50
description users
ip address 10.50.1.1 255.255.0.0
ip helper-address 10.50.128.10 -------> DHCP server
!
interface Vlan116
description SALES
ip address 10.116.1.1 255.255.255.0
ip helper-address 10.50.128.10 -------> DHCP server
!
!interface Vlan117
description WLAN User
ip address 10.117.1.1 255.255.255.0
ip helper-address 10.50.128.10 -------> DHCP server


interface Vlan118

description WLAN GUEST
ip address 10.116.3.1 255.255.255.0
ip helper-address 10.50.128.10   -------> DHCP server



regards

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sleepyshark Wed, 01/18/2012 - 06:44
User Badges:

You do not need a IP helper-address on VLAN50 , machines on that VLAN will broadcast on the subnet for a DHCP server (meaning no helper needed)...


*** IMPORTANT *** Your machines on VLAN50 will need to use the default gateway of 10.50.1.1 for inter-vlan routing (and the ability for the IP helper to communicate with the DHCP server)


Other than that, your configurations are correct and it will work.  If you've never used IP helpers and/or DHCP server on the switch before, please do a #service DHCP command to enable the DHCP service on the switch.


Other than that - all should work assuming there are not ACLs specifically blocking inter-vlan or DHCP traffic.


Thanks,

Sean Brown

http://www.sleepyshark.com


(please rate this post if useful)

Actions

This Discussion