VoIP QOS on 887VA (and also 861)

Unanswered Question
Jan 19th, 2012
User Badges:

Hi


I have a 887VA in a live environment that needs QOS for VoIP - choppy calls....


I'm a novice with QOS, so have been playing with my 861.


This is what I'm trying...


ip access-list extended VOIP
permit tcp any any range 6000 6049
permit tcp any any eq 5060


class-map match-any VoIP
match access-group name VOIP

policy-map VOIPQOS
class VoIP
priority percent 50
set dscp ef
class class-default
fair-queue


interface FastEthernet4

bandwidth 800

ip nbar protocol-discovery

service-policy output VOIPQOS


I a few questions....

1. - Is this correct generally - will this priortise VoIP traffic over everything else.

2. - Should this be on fa4 or dialer0 - it's PPPoE, or doesn't it matter since FA4's upstream is dialer0 anyway

3. - The router that really needs this is an 887, so which interface do I put this on - ATM0?

4. - I get an error on the set dscp ef command on the 861 - is this because I'm wrong, or the 861 doesn't do this, and what ramifications will this have?


Sorry for the probably dumb questions, but my Cisco knowlege is learnt in the field - so VPNs etc I'm happy with but QOS is a dark hole at the moment!


Thanks!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Neeraj Arora Tue, 01/24/2012 - 09:15
User Badges:
  • Silver, 250 points or more

1. Generally yes, this config is good enough for prioritizing voice traffic going out of Serial or Fast Ethernet interfaces. The only thing I would like to mention here is the ACL being used, generally I have seen the following ACL for Cisco Voice devices:


access-list 102 permit udp any any range 16384 32767

access-list 102 permit tcp any any eq 1720


(the above are actually the ports Cisco devices use.......1720 for call setup and range 16384 32767 for the RTP stream)


2. "Service-policy output" command should be on Dialer interface

3. For ATM interface, there is a difference in how QOS is applied. I am not an expert on ATM so I can only point you towards the document which explains it


Documents that should prove useful:

** Configuring CBWFQ and LLQ on MLPPP and Dialer Interfaces

http://www.cisco.com/en/US/tech/tk543/tk544/technologies_tech_note09186a0080094ad2.shtml


** QoS Solutions for PPPoE and DSL Environments

http://www.cisco.com/en/US/tech/tk543/tk545/technologies_tech_note09186a00800b2d29.shtml


** Understanding the VBR-nrt Service Category and Traffic Shaping for ATM VCs

http://www.cisco.com/en/US/tech/tk39/tk51/technologies_tech_note09186a0080102a42.shtml


Hope the above information helps


Neeraj

michaelba4 Sat, 04/26/2014 - 02:30
User Badges:

hello, my name is michael and i'm trying to configure the same oqs setting as grunger106                           i have cisco 887va.

I know this response was recorded a long time ago but still ask for your help. 

I set grunger106 script above  and i put Service-policy output" command  on Dialer 0 interface but its still don"t work. i still have jitter and delays.

i'm adding the configuration :


no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Mornex
!
boot-start-marker
boot-end-marker
!
!
enable password *****
!
no aaa new-model
!
!
ip cef
!
!
!
ip dhcp excluded-address 192.168.1.254
!
ip dhcp pool Local_DHCP_Pool
 import all
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.254
 lease 0 0 30
!
!
!
no ipv6 cef
!
!
license udi pid C887VA-W-E-K9 sn **********
!
!
username ****** password 0 ******
!
!
!
!
!
controller VDSL 0
!
!
class-map match-any VoIP
 match access-group name VOIP
!
policy-map VOIPQOS
 class VoIP
  priority percent 50
  set dscp ef
 class class-default
  fair-queue
!
!
!
!
!
!
!
!
!
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface Ethernet0
 description -WAN$
 no ip address
 pppoe enable group global
 pppoe-client dial-pool-number 2
 pppoe-client dial-pool-number 1
!
interface FastEthernet0
 switchport access vlan 20
 no ip address
!
interface FastEthernet1
 switchport access vlan 20
 no ip address
!
interface FastEthernet2
 switchport access vlan 20
 no ip address
!
interface FastEthernet3
 switchport access vlan 20
 no ip address
!
interface Wlan-GigabitEthernet0
 description Internal switch interface connecting to the embedded AP
 switchport mode trunk
 no ip address
!
interface wlan-ap0
 description Service module interface to manage the embedded AP
 ip address 192.168.168.2 255.255.255.0
!
interface Vlan1
 no ip address
!
interface Vlan20
 ip address 192.168.1.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 ip tcp adjust-mss 1412
!
interface Dialer0
 bandwidth 800
 ip address negotiated
 ip mtu 1452
 ip nbar protocol-discovery
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication pap callin
 ppp pap sent-username ******* password 0 ******
 ppp ipcp dns request
 ppp ipcp address accept
 service-policy output VOIPQOS
!
ip forward-protocol nd
ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip nat inside source list 1 interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip access-list extended VOIP
 permit udp any any range 10000 20000
 permit udp any any range 5060 5062
!
access-list 1 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit
!
snmp-server community highnet RO mgt
!
!
line con 0
 no modem enable
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 stopbits 1
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler max-task-time 5000
scheduler allocate 20000 1000
ntp server 172.23.3.241
!
end

 

 

Actions

This Discussion