Delay by taking a call

Unanswered Question
Jan 19th, 2012

Hi there,

this is my first post here and I´m sorry about my english is not so god.

First question I have here is a little problem with our SPA500 series. We use this phones with an 3CX PBX for serveral months now without problems, but for some weeks now there is the problem that for an incoming call you take up the handset and there is no audio for about 20 till 30 sec. After this everything works fine.

At the display there is from the first second a "connected" with a count, but as I said no audio. This problem only takes effect at the Cisco phones here and not at any other phone. Interesting is also that with every firmware I tryed the delay depends from 5 up to 40 second.

Can you give me some suggestions about that?

Thanks

Joe

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
Daniele Giordano Fri, 01/20/2012 - 01:24

Can you use Wireshark on your PBX to capture SIP and RTP flows and post the trace?

Regards.

Daniele Giordano Fri, 01/20/2012 - 03:31

To add a file:

- edit your post and use the upload button on the bottom of the page;

- use right mouse button to add an attachment in the answer;

- in a new answer, switch to "advanced editor" using the upper-right button;

Please, check if your trace contains SIP and RTP packets.

Regards.

Daniele Giordano Fri, 01/20/2012 - 04:48

You wrote:

"We use this phones with an 3CX PBX for serveral months now without problems".

Do you have upgrade your 3cx system? I think in a problem or in a compatibility issue of the queue system.

The call flow should be this:

- The 01797820386 calling calls 90580 3cx.   What is the answerer? 3cx queue?

- After about 0,5 sec  the 90580 calls 192 SPA525  and after about 3 sec there is an answer. In this message 3cx informs the SPA of a queue system:

"From: "01797820386"nf=q>;tag=9c6afc42"

"Alert-Info: <http://www.notused.com>;info=queue"

- After about 14 sec the 90580 send a new INVITE to the 192 SPA. In this case the 3cx informs the SPA of an external call:

"From: "01797820386"nf=e>;tag=2b513034"

"Alert-Info: <http://www.notused.com>;info=external"

See attached file named screen_1.

In this moment the audio of the first answerer stops.

-After other 12 sec the 3cx sends a new INVITE to the original caller and open the audio from the phone.

See attached file named screen_2.

Do you have enabled the queue system on 3cx?

Can you disable it?

Do you have upgraded the system?

Can you revert to previously version?

Let me know what do you think.

Regards.

Attachment: 
j.dormann Fri, 01/20/2012 - 04:58

Hi, thank you for the answers...

Yes we use a queue system with 3CX and I allready diabled it and made a new Wireshark capture witout the queue.

And also yes, we upgraded 3CX from V9 to V10 because of some major featuers we need in V10. So it´s nearly impossible to roll back to V9.

There is an option in 3CX called "3CX handels audio". I tried with and witout this option but both times the same issues...

Test is withdisabeled this option, Test 2 is this option enabled!

Attachment: 
Daniele Giordano Fri, 01/20/2012 - 05:27

Now the call flow is more simple to analyze.

There is no difference between traces.

How can you see from image below, the POINT A corresponding to the 200 OK message indicates that you answered the call from SPA phone.

I don't know why the 3cx sends the 200 OK to the original caller only after 20 seconds, POINT B.

This is the anomaly. The audio flow is opend only after the 200 OK - ACK phase.

I don't know 3cx system. Can you enable a syslog or a debug to investigate the problem?

Let me know.

Regards.

Daniele Giordano Fri, 01/20/2012 - 06:22

This is the interesting part of logs:

13:40:07.781  [CM503023]: Call(131): Call recording is stopped, audio file: \\192.168.0.199\3cx\2011\unknown

13:40:07.780  [CM503008]: Call(131): Call is terminated

13:39:47.668  [CM504001]: Ext.DialCode: new contact is registered. Contact(s): [sip:DialCode@127.0.0.1:5488/DialCode]

13:39:47.567  [CM504002]: Ext.DialCode: a contact is unregistered. Contact(s): []

13:39:47.536  [CM503007]: Call(131): Device joined: sip:192@192.168.0.51:5060

13:39:47.531  [CM503007]: Call(131): Device joined: sip:10000@192.168.0.10:5060;transport=udp

13:39:47.530  [CM503022]: Call(131): Call recording is started, audio file: \\192.168.0.199\3cx\2011\unknown

Do you trying to record a call in a file?

If yes, can you disable this feature and recall again?

Daniele Giordano Fri, 01/20/2012 - 07:22

Good.

What happens if you reactivated or restarted the service that handle recording call?

Can you reinstall the single module?

If the problem is not fixed at all, I suggest you to open a ticket in the 3CX support portal or 3CX support forum.

Regards.

j.dormann Fri, 01/20/2012 - 07:29

Thank you very much for your help,... I will try this tommorow when I´m back at the office.

Normaly this is not a problem to restart this service. It´s just one mouseclick, but not a seperated service I guess...

Anyway I believe the problem is not the recording service then the shared volume I used to save the recorded files!

I´m so happy that you solved this problem... Thank´s again

Joe

PS: Do you have also knowledge of provisioning and administration of the Cisco SPA 500 Series?

j.dormann Fri, 01/20/2012 - 07:42

It´s about the other thread in this forum.

Some of our SPA 502 are in public areas and the people love to play with the configuration menu. I would like to deactivate some specific points at the menu so nobody can play around.

Best practice is configuration only via wenfrontend...

I have read something about this topic at the administrators guide but I didn´t really understand that.

Joe

Daniele Giordano Fri, 01/20/2012 - 08:45

Typically I configure phone via provisioning using XML file. This should be the way used by 3cx also.

Try to edit an XML file and check these things:

- Set the admin password to protect the web admin menu and phone admin menu.

You must find something like this:

  your password

- Set attribute value to critical options. In this way changes will be ignored.

The ua attribute, if present, must have one of the following values:

- na—no access

- ro—read-only

- rw—read/write

The ua attribute is illustrated by the following example:

Regards.

j.dormann Fri, 01/20/2012 - 08:57

Ok I think I got it...

But when I open the provisoning file from 3CX I can´t find something like ua="ro"

It is possible to just add it where I need it?

Joe

Actions

Login or Register to take actions

This Discussion

Posted January 19, 2012 at 5:58 AM
Stats:
Replies:17 Avg. Rating:5
Views:1609 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard