×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

DHCP fails when QOS is configured on 6500 Switch

Unanswered Question
Jan 19th, 2012
User Badges:

So I have started working at this company that has mostly 3560 switches and nortel VOIP phones.  We recently expanded into a new Admin building and I requested we get a 6500 with a sup720.  Once I got everything installed, some VOIP phones get DHCP, some do not.  Some fail today, but if left alone over night, are connected to DHCP in the morning.  Very strange.  On the 3560s, the configuration for the qos is as follows:


Global:

mls qos map dscp-cos  40 to 3

mls qos


On each interface:

switchport access vlan 170

switchport mode access

switchport voice vlan 164

priority-queue out

mls qos trust dscp

spanning-tree portfast


On the 6500, I entered the same commands, the only command that was not accepted was the "priority-queue out", but the 6500 has additional commands that appear to be related:


Global:

no mls flow ip

no mls flow ipv6

mls qos map dscp-cos 40 to 3

mls qos

no mls acl tcam share-global

mls cef error action reset


On each interface:

switchport

switchport access vlan 170

switchport mode access

switchport voice vlan 164

no ip address

mls qos trust dscp

spanning-tree portfast


# (notice the "priority-queue out" command not here)


The PCs that are plugged into the data port on the VoIP phones, get DHCP no problem, no issue at all.  Some phones do get DHCP, some phones do not, those that are working, if I reboot them, it at times takes a long period of time to get a DHCP address.  On the router, if I debug DHCP, I can see the broadcast request, and the unicast reply from the DHCP server, but no accept from the phone.  The same mac address broadcasts multiple times, with the DHCP server assigning it the same address each time.


Has anyone seen this issue, I have searched all over the internet and I have been unable to find a solution.  I did find this page here:

http://www.cisco.com/en/US/products/hw/switches/ps4324/products_configuration_example09186a0080722cdb.shtml

At the end it has a paragraph dedicated to "IP Phones Do Not Get IP Address From DHCP Server"


Then it talks about DAI is configured or if an arp access list is configured, which neither is configured.  Any assistance would be greatly appreciated here.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
amikat Fri, 01/20/2012 - 01:45
User Badges:
  • Silver, 250 points or more

Hi,


Will you please make sure you have the IP address and "ip-helper address" configured under interface vlan164 at your 6500 box.


Best regards,

Antonin

Natalie Ramirez Fri, 01/20/2012 - 06:26
User Badges:

The "Interface vlan 164" is on one of the 3560s.  I removed the interface vlan 164 IP address from the 3560 and put it on the 6500, however, then all phones on the 3560s as well as on the 6500 were having connectivity issues.  So I moved it back to the 3560.  On the 3560 that has the helper address, if I debug dhcp, I can see the broadcast from the voip phones, and the unicast reply from the DHCP server, but never an accept from the voip phones, just the DHCP server continuously offering the same address.

amikat Sat, 01/21/2012 - 08:12
User Badges:
  • Silver, 250 points or more

Hi,


I understand that your DHCP server is on a different VLAN than 164 (as you have configured the ip helper address). If so you should not see broadcast requests from your phones at your DHCP server. Will you please post the switch port configuration connecting your DHCP server and advise its VLAN number and possibly other relevant information.


Thanks & Regards,

Antonin

Natalie Ramirez Mon, 01/23/2012 - 08:00
User Badges:

On the switch that has the IP helper address, i can debug DHCP and see (on this 3560 that has no issues, which has interfaces on both VLANs) the DHCP broadcast request from the client, the forward to the DHCP server, and the unicast offer from the DHCP server.  The only thing I do not see is an accept from the VoIP phone.  There is nothing special or restrictive on my VLAN interfaces, if I plug a phone that does not work on the 6500 into any 3560, it works fine, when I bring it back to the 6500, it fails.  Here is the VLAN interface config from the 3560.


interface Vlan1

ip address 192.168.160.30 255.255.255.0

!

interface Vlan164

ip address 192.168.164.1 255.255.255.0

ip helper-address 192.168.160.10

!


I did try deleting these VLAN interfaces from the 3560 and put them directly on the 6500.  When I did that, a large number of VoIP phones that were previously working, stopped working showing the same symptom of not being able to get an IP address, even though they were connected to a 3560 switch elswhere.  So I put it back onto the 3560 and have resigned to the fact that this issue is localized to the 6500.


I have also tried connecting the phones to the switch as a trunk port instead of using the voice vlan command.  I have also tried updating the firmware on the phones.  This issue is only effecting about 50% of the phones, and of those phones effected 80% will eventually get a DHCP address, if you leave them connected over night (eventually they accept the offer from the DCHP server).  If I assign a static IP address on the phones, they work fine.


If I reboot the 6500, 50% of the phones come up and work immediatly, 40% take an extra extra long time to get a DHCP address, and 10% fail completely, so I am assigning static addresses so users can use their phones.

amikat Mon, 01/23/2012 - 12:33
User Badges:
  • Silver, 250 points or more

Hi,


Thanks for the information supplied. In my view this problem is not directly QoS related but rather connectivity/routing issue.

Can you please confirm that there is only one Interface Vlan164 configured with the IP address and ip-helper address (currently at the Cat3560 switch). Is there Interface Vlan 1 configured at the Cat6500 switch? If yes can you please post the configuration. Can you please advise where your DHCP server is connected and post the port configuration. Can you please advise how is Cat3560 connected with the Cat6500.


Thanks & Regards,

Antonin

Alexander Maroukian Sat, 01/21/2012 - 15:18
User Badges:
  • Cisco Employee,

Hi,


Which models are the nortel phones? What options do you use in the DHCP? What is the configuration of the DCHP server?

You can try using LLDP to get the phones to correct vlan.


Best regards,

Alex


*Please rate helpful posts.

Natalie Ramirez Mon, 01/23/2012 - 08:27
User Badges:

Nortel 1120e


DHCP options:

003 Router - 192.168.164.1

128 Nortel Phone Options - Nortel-i2004-A,192.168.164.2:4100,1,255;192.168.164.2:4100,1,255.

006 DNS servers - server addresses

015 DNS domain name - domain name

044 WINS/NBNS Server - wins server addresses

046 Wins/NBT Node type - 0x8


The phones are configured to use Voice Vlan 164, and on the switch, I can see the MAC address of the phone on the 164 VLAN on the interface that it is connected to.  I know the phones are on the correct VLAN.

Alexander Maroukian Mon, 01/23/2012 - 14:18
User Badges:
  • Cisco Employee,

Hi,


Add option 191 to your data vlan dhcp configuration.


Best regards,

Alex


*Please rate posts if helpful

Actions

This Discussion