SPA525G proxy authorization

Unanswered Question
Jan 21st, 2012


The problem is when we try to register Cisco SPA525G2 softswitch TSIP, we get the message: "407 Proxy Authentication Required"

Sombody could advise how to configure 525G2 to send proxy auth.?

Thank you very much.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Alexander Maroukian Sat, 01/21/2012 - 16:52


Please check the credentials you have entered.

You can see the proxy settings uder the extension tab on web interface of the phone.

Best regards,


*Please rate helpful posts

kcgsupport Sat, 01/21/2012 - 17:37

I'll have tried different one :-( nothing help. This is the last.
Alexander Maroukian Sun, 01/22/2012 - 02:50


You are already sending the proxy authentication. Check  the settings on the server and if the proxy is correct, also the  username and the password.

Best regards,


kcgsupport Sun, 01/22/2012 - 03:18


I saw the traffic by wireshark. No proxy-authorization/authentification sentence in SIP header. See screenshort one from 525G2 other from Softphone. With softphone registration is ok.

kcgsupport Sun, 01/22/2012 - 03:19

the difference is obvious. 525G2 does not sent proxy-auth. clause.

Alexander Maroukian Wed, 01/25/2012 - 14:11

Are you using the same network settings on the PC and the phone? Could you post some debugs from the phone?

Best regards,


kcgsupport Thu, 01/26/2012 - 14:21

Sorry, I have not debug from phone. Network config - the same absolutly. Both placed on the same network.


ADAM CRISP Thu, 01/26/2012 - 15:08

The line is disabled in your screen shot - was this intentional ?

kcgsupport Fri, 02/03/2012 - 00:54

not, is not a case. Line was down before I have made screenshort but ofcaurse up when have been testing.


This Discussion