×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Auto QOS on etherchannel

Unanswered Question
Jan 22nd, 2012
User Badges:
Hi,


How do I enable QOS on an Etherchaneel between A Cisco 3560 and A Cisco3750G


Configuring Auto QOS clearly not allowed after putting the interface in a port-channel

The Port-channel interface has no auto or mls options


Configuring auto QOS on the interface before putting the into a port-channel seems to

work just fine.


Is this the way to go ?

Is QOS actually working on the etherchannel ?

How can I tell.


Thanks.

Wijnand


Auto QOS command on interface after joining a Channel-Group


Switch03(config-if-range)#int range gi0/1-2

Switch03(config-if-range)#description Etherchannel uplink to Core

Switch03(config-if-range)#channel-group 1 mode active

Switch03(config-if-range)#auto qos voip trust

Creating a port-channel interface Port-channel 1

AutoQoS Error: AutoQoS can not be configured on member port(s) of a port-channel



Auto QOS command on interface before joinina channel-Group

The QOS config is showing up in the Gi0/1 interface even after joining the Channel group


Switch03(config)#interface range gi0/1-2

Switch03(config-if-range)#description Etherchannel uplink to Core with QOS

Switch03(config-if-range)#auto qos voip trust

Switch03(config-if-range)#channel-group 1 mode active

Creating a port-channel interface Port-channel 1


Switch03(config)#int port-channel 1

Switch03(config-if)#switchport trunk encapsulation dot1q

Switch03(config-if)#switchport mode trunk

Switch03(config-if)#switchport trunk native vlan 2


Switch03#sh etherchannel summary


Group  Port-channel  Protocol    Ports

------+-------------+-----------+-----------------------------------------------

1      Po1(SU)         LACP      Gi0/1(P)    Gi0/2(P)   


witch03#sh run int gi0/1

Building configuration...


Current configuration : 322 bytes

!

interface GigabitEthernet0/1

description Etherchannel uplink to Core with QOS

switchport trunk encapsulation dot1q

switchport trunk native vlan 2

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

queue-set 2

priority-queue out

mls qos trust cos

auto qos voip trust

channel-group 1 mode active

end


Switch03#sh run interface port-channel 1

Building configuration...


Current configuration : 124 bytes

!

interface Port-channel1

switchport trunk encapsulation dot1q

switchport trunk native vlan 2

switchport mode trunk

end

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
acampbell Sun, 01/22/2012 - 07:29
User Badges:
  • Green, 3000 points or more


Looking your HHH configuration this isd the correct way to configure
Interfaces on an etherchannel (port channel).

You configure the auto qos on the physical ports not the port-channel

Look at this link (IOS 12.2.55)
http://www.cisco.com/en/US/partner/docs/switches/lan/catalyst3560/software/release/12.2_55_se/configuration/guide/swqos.html#wp1689696

Policing Guidelines

!
! SNIP
!
•If you have EtherChannel ports configured on your switch, you must configure QoS classification, policing, mapping, and queueing on the individual physical ports that comprise the EtherChannel. You must decide whether the QoS configuration should match on all ports in the EtherChannel.

!
!SNIP
!



HTH
Regards
Alex

wwestra2763 Mon, 01/23/2012 - 05:31
User Badges:

Thanks for the answer,

I'm gonna read the chaper you mentioned and put it in production in a couple of weeks.


Kind regards,


Wijnand

acampbell Mon, 01/23/2012 - 05:55
User Badges:
  • Green, 3000 points or more

Hi Wijnand


Might be a good idea to look at the configuration guide for your exact IOS


I just picked 12.2.55 at random.


I cant see there being much variation is QOS/AUTO-QOS for ether-channels.

You always QOS the physical interface not the Port-channel


HTH

Regards

Alex


Please rate useful posts

Actions

This Discussion