×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Marking on Skinny packets changed to default value after issue Auto QOS

Answered Question
Jan 22nd, 2012
User Badges:

Hi all


A quick question: after issuing "auto qos voip cisco-phone" in an interface fa0/5 which is connected to a cisco phone, the DSCP value on Skinny packet from phone has been changed to the default value 0. when I stop the MLS QOS on switch, DSCP value on Skinny parcket back to default value CS3, same happened to the port connect to CUCM.


I know that by default the Cisco swith will not remark any packet, when packet go thought the it. Once QOS enabled, switch will remove all the existing mark on incoming parket and remark it with DSCP 0,  theoretically on the port with "auto qos voip trust" command, it should trust the marking made by phone or cucm. but in my test with Wireshark, the value has been set to default.   try on switch 3550 and 2960 same result,  have I missed something here? 

Correct Answer by Aaron Harrison about 5 years 6 months ago

Have you tried a simple 'mls qos trust dscp' on the phone port?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Aaron Harrison Sun, 01/22/2012 - 23:23
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015

Hi


Where are you running wireshark?


Can you post up your config and note which ports your source traffic is coming from, and which port you are monitoring?


For example, if you are monitoring on fa 0/1, and have turned on QoS and set 'auto qos voip trust' on fa 0/1, then you will see traffic marked as 0, as the source port (any other port on the switch, or a downstream/upstream switch) doesn't have qos trust enabled. Traffic is remarked on ingress...


Aaron

ciscoroyzhang Mon, 01/23/2012 - 00:02
User Badges:

Hi Aaron


thanks for your reply.


this is ports detaisl on the switch:

                                                            FA0/3 --> link to IP Phone 7941

                                                            FA0/4 --> link to my PC port


this is command I did on the switchon Switch:


                                                            )#  monitor session 1 sour  inter fa0/3

                                                            )# monitor session 1 desti     int fa0/4


I also tried on the port link to the CUCM server, I can see the traffics from both way, MGCP from gateway to CUCM and vice versa. disable MLS QOS on switch,  DSCP value all there and one enable the MLS QOS, DSCP set to 0....  thanks in advance. Roy

acampbell Mon, 01/23/2012 - 06:06
User Badges:
  • Green, 3000 points or more

Hi,


Is it all packets that are being bleached to "DSCP 0" .?


If so make sure that CDP protocol is running as this is a MUST for Cisco AutoQos


Regards

Alex

ciscoroyzhang Mon, 01/23/2012 - 14:19
User Badges:

Hi Alex,


Thanks for reply.  Yes  the dscp value on all packets have been reset to 0, CDP by default is enabled and I checked it again it is on.   I thought this is very simple QOS test on a switch, but seem to me is not that simple, I run out of idea, any suggestion are welcomed. 


thanks in advance.

Roy

Aaron Harrison Mon, 01/23/2012 - 15:22
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015

Hi


So - it is normal for all packets to get marked to 0 if you simply 'turn on' qos by entering the mls qos command.


As packets enter the switch, they are marked to 0, unless that port is trusting the traffic (or remarking it, but that's another topic). This applies to all ports, edge or trunk. So:


  • If you monitor MGCP traffic from the on the CUCM port, traffic from CUCM will only be non-0 if the CUCM switch port is set to trust.
  • Traffic from MGCP gateway to CUCM will be marked 0 unless the MGCP gateway switch port is set to trust.
  • If there are multiple switches, EVERY inter-switch link must be set to trust on both ends, or traffic will be remarked to 0 as it passes the trunk.


Aaron

ciscoroyzhang Mon, 01/23/2012 - 19:19
User Badges:

Hi Aaron


Thanks for your reply.  Sorry I didn't explain it very clear at orignal post. Actually I did have all those port trusted with command "auto qos viop trust" on port to CUCM or trunk and "auto qos voip cisco-phone" for the phone. I know the theory well, but when I try to test it, seem to me it not work.


OK!  to make it simple, let me put it this way. I have switch 2960 with gi0/1 to CUCM and Gi0/3 to phone and Gi0/4 to my PC.


1, I have enabled the Auto qos on the switch by issue the following command on the port gi0/3 "auto qos voip cisco-phone", with this command, it will enable AUTO QOS which means it will add MLS QOS and other lines such cos-dscp mapping, srr-queue.... to the running-config.


2, now let's leave the gi0/1 alone, just focus on the gi0/3. I issue the following command to monitor the traffic to setup the Gi04 as destination and Gi0/3 as source port. on my Wireshark, I can see the Skinny/RTP traffic going to the CUCM but the DSCP has been set 0, if stop the MLS QOS, then the marking on Skinny/RTP parcket is back.


3, I also try to manually configure the QOS on the switch same result, signalling traffic set to 0.


This is someting bother me...

Correct Answer
Aaron Harrison Mon, 01/23/2012 - 23:34
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015

Have you tried a simple 'mls qos trust dscp' on the phone port?

ciscoroyzhang Tue, 01/24/2012 - 15:47
User Badges:

Hi Aaron,   tred to add the 'mls qos trust dscp' on the interface, it worked. I can see all packet (boht direct) with the right dscp value. so seem to me that  'auto qos voip cisco-phone' is not enough.  Thanks...

Actions

This Discussion