×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

OSPF adjacency is not established.

Answered Question
Jan 22nd, 2012
User Badges:

OSPF adjacency is not established. HELP.



router1(X)async1/10----[modem1]------leased line------[modem2]----Serial0/2/2(X)router2



router1#sh ver

Cisco IOS Software, 2800 Software (C2800NM-IPBASE-M), Version 12.4(8a), RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2006 by Cisco Systems, Inc.

Compiled Wed 19-Jul-06 23:21 by prod_rel_team


ROM: System Bootstrap, Version 12.4(1r) [hqluong 1r], RELEASE SOFTWARE (fc1)


router1 uptime is 13 weeks, 4 days, 17 hours, 29 minutes

System returned to ROM by power-on

System image file is "flash:c2800nm-ipbase-mz.124-8a.bin"


Cisco 2811 (revision 53.51) with 251904K/10240K bytes of memory.

Processor board ID FCZ10407230

2 FastEthernet interfaces

5 Serial interfaces

16 terminal lines

5 Channelized E1/PRI ports

DRAM configuration is 64 bits wide with parity enabled.

239K bytes of non-volatile configuration memory.

62720K bytes of ATA CompactFlash (Read/Write)


Configuration register is 0x2102


router1#



router1#sh run

...

!

interface Async1/10

description Link to router2

bandwidth 20

ip address 10.5.253.117 255.255.255.252

encapsulation ppp

async mode dedicated

!

...

!

router ospf 200

log-adjacency-changes

network 10.5.253.116 0.0.0.3 area 200

!

...

line 1/10

modem InOut

stopbits 1

speed 57600

flowcontrol hardware

...


router1#

router1#sh ip ospf int as1/10

Async1/10 is up, line protocol is up

Internet Address 10.5.253.117/30, Area 200

Process ID 200, Router ID 10.105.254.194, Network Type POINT_TO_POINT, Cost: 5000

Transmit Delay is 1 sec, State POINT_TO_POINT,

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

oob-resync timeout 40


Hello due in 00:00:05

Supports Link-local Signaling (LLS)

Index 1/1, flood queue length 0

Next 0x0(0)/0x0(0)

Last flood scan length is 0, maximum is 0

Last flood scan time is 0 msec, maximum is 0 msec

Neighbor Count is 0, Adjacent neighbor count is 0

Suppress hello for 0 neighbor(s)


router1#sh int as1/10

Async1/10 is up, line protocol is up

Hardware is CD2430 in async mode

Description: Link to router2

Internet address is 10.5.253.117/30

MTU 1500 bytes, BW 20 Kbit, DLY 100000 usec,

reliability 255/255, txload 1/255, rxload 12/255

Encapsulation PPP, LCP Open

Open: IPCP, loopback not set

Keepalive not set

DTR is pulsed for 5 seconds on reset

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters 2d20h

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/2/16 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 15 kilobits/sec

5 minute input rate 1000 bits/sec, 3 packets/sec

5 minute output rate 0 bits/sec, 2 packets/sec

669 packets input, 47196 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

2525 packets output, 101721 bytes, 0 underruns

0 output errors, 0 collisions, 199 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

router1#

________________________________________________________________________________ ________


router2#sh run

...

!

interface Serial0/2/2

physical-layer async

bandwidth 20

ip address 10.5.253.118 255.255.255.252

ip load-sharing per-packet

encapsulation ppp

async mode dedicated

!

...

!

router ospf 200

log-adjacency-changes

network 10.5.253.116 0.0.0.3 area 200

!


router2#sh int s0/2/2

Serial0/2/2 is up, line protocol is up

Hardware is HWIC-Serial

Description: Link to router1

Internet address is 10.5.253.118/30

MTU 1500 bytes, BW 20 Kbit/sec, DLY 100000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, LCP Open

Open: IPCP, loopback not set

Keepalive not set

DTR is pulsed for 5 seconds on reset

Last input 00:02:32, output 00:02:32, output hang never

Last clearing of "show interface" counters 2d01h

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/3/16 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 15 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

244 packets input, 31242 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

303 packets output, 12711 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 unknown protocol drops

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=up DSR=up DTR=down RTS=down CTS=up


router2#sh ip ospf interface s0/2/2

Serial0/2/2 is up, line protocol is up

Internet Address 10.5.253.118/30, Area 200

Process ID 200, Router ID 10.5.253.118, Network Type POINT_TO_POINT, Cost: 5000

Transmit Delay is 1 sec, State POINT_TO_POINT

Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5

oob-resync timeout 40

No Hellos (Passive interface)

Supports Link-local Signaling (LLS)

Cisco NSF helper support enabled

IETF NSF helper support enabled

Index 1/1, flood queue length 0

Next 0x0(0)/0x0(0)

Last flood scan length is 0, maximum is 0

Last flood scan time is 0 msec, maximum is 0 msec

Neighbor Count is 0, Adjacent neighbor count is 0

Suppress hello for 0 neighbor(s)

router2#sh ver


Cisco IOS Software, 2800 Software (C2800NM-IPBASE-M), Version 12.4(15)T10, RELEASE SOFTWARE (fc3)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2009 by Cisco Systems, Inc.

Compiled Mon 14-Sep-09 14:01 by prod_rel_team


ROM: System Bootstrap, Version 12.4(13r)T11, RELEASE SOFTWARE (fc1)


router2 uptime is 2 days, 19 hours, 16 minutes

System returned to ROM by power-on

System image file is "flash:c2800nm-ipbase-mz.124-15.T10.bin"


Cisco 2811 (revision 53.50) with 249856K/12288K bytes of memory.

Processor board ID FHK1346F2R6

2 FastEthernet interfaces

4 Low-speed serial(sync/async) interfaces

DRAM configuration is 64 bits wide with parity enabled.

239K bytes of non-volatile configuration memory.

62720K bytes of ATA CompactFlash (Read/Write)


Configuration register is 0x2102


router2#

Correct Answer by nkarpysh about 5 years 6 months ago

Thanks Ryhor,


Did you try configuring command "async default routing" on both sides. I think that is needed on AS for OSPF to work.


Nik

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
nkarpysh Sun, 01/22/2012 - 22:59
User Badges:
  • Cisco Employee,

To Start with:


- can you ping successfully between those serial interfaces?

- Does your provider allow multicast on the leased line?

- you can "debug ip ospf" to see what is going on.


Nik

oldvoffka Sun, 01/22/2012 - 23:11
User Badges:

1)

router2#ping 10.5.253.117

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.5.253.117, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 176/206/227 ms
router2#

2)

leased line - it is only 4-wired leased line. Modems  conected at 19200 bits/s

router2#ping 224.0.0.5

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.0.0.5, timeout is 2 seconds:

Reply to request 0 from 10.5.253.117, 404 ms

router2#

Correct Answer
nkarpysh Sun, 01/22/2012 - 23:22
User Badges:
  • Cisco Employee,

Thanks Ryhor,


Did you try configuring command "async default routing" on both sides. I think that is needed on AS for OSPF to work.


Nik

oldvoffka Sun, 01/22/2012 - 23:39
User Badges:

oh i am sorry, there was a mistake! there is on on side (router1 async interface):Hello due in 00:00:05

but on other (router2  serial interface in async mode) No Hellos (Passive interface)

But on router1  on other async interface OSPF works.

oldvoffka Sun, 01/22/2012 - 23:46
User Badges:

Oh!!! It's great? after configuring command "async default routing" on both serial and async interfaces, OSPF adjacency  established



router2#sh ip ospf nei

Neighbor ID     Pri   State           Dead Time   Address         Interface

10.105.254.194         0   FULL/  -        00:00:32    10.5.253.117    Serial0/2/2

router2#



router1#sh ip ospf nei

Neighbor ID     Pri   State           Dead Time   Address         Interface

10.5.2.174        0   FULL/  -        00:00:35    10.5.253.118    Async1/10

router1#

Thank You, Nikolay Karpyshev!

nkarpysh Mon, 01/23/2012 - 00:08
User Badges:
  • Cisco Employee,

Glad it is wo0rking now. You can mark my answer as a correct one to close this thread and make it usefull for others later.


Cheers,


Nik

Actions

This Discussion