SPA 5xx/3xx DNS and CFWD sync with Broadsoft

Unanswered Question
Jan 24th, 2012
User Badges:

When line is configured as "private", DND/CFWD sync works. But if the line shared on another device and is configured as "shared", the phone does not sync anymore. Is this expected behavior? 

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
adam.baird Tue, 01/24/2012 - 08:40
User Badges:

Hi Jonathan,


I believe that for versions prior to release 18, this is the way it is meant to work.  The intent is to not allow a single user of a shared line appearance to dictate how calls route for the other users sharing that line.  For release 18 there is a feature sync enhancement which appears to allow you to toggle this behavior (I say 'appears' because I do not run r18 and can't test it).


Take a look at this doc.  It might help.

http://xchange.broadsoft.com/php/xchange/system/files/Release_18/ReleaseDocs/FeatureDescriptions/DeviceFeatureSynchronizationEnhancementsFD-R180.pdf


-Adam

jlhbjnhh67 Wed, 01/25/2012 - 04:03
User Badges:

Thank you for the reply and information.  For a line registered as "shared" on a Polycom phone, my current Broadsoft version (R17) does provide subscribe message for DND / CFWD status.  But when SPA phone tries to do the same, there is  489 Bad Event error.


SUBSCRIBE sip:xxxxxxxxxxxx SIP/2.0

Via: SIP/2.0/UDP xxxxxxxxxxx:5060;branch=z9hG4bKkrpbgr1050dggnslv501.1

From: "Jonathan Lee" ;tag=c277a5a960b12de3

To: "Jonathan Lee"

Call-ID: [email protected]

CSeq: 1002 SUBSCRIBE

Max-Forwards: 69

Authorization: Digest username="11111111111111",realm="pingtone.com",nonce="BroadWorksXgxt15p7hTe0kzqxBW",uri="sip:xxxxxxxxxxx",algorithm=MD5,response="153956cdeb9413a523a995ee82cbeedb",qop=auth,nc=00000001,cnonce="191f9e5"

Contact:

Expires: 3600

Event: missed-call-summary

User-Agent: Cisco/SPA504G-7.4.9a

Content-Length: 0

Route:



SIP/2.0 489 Bad Event

Via:SIP/2.0/UDP xxxxxxxxxxx:5060;branch=z9hG4bKkrpbgr1050dggnslv501.1

From:"Jonathan Lee";tag=c277a5a960b12de3

To:"Jonathan Lee";tag=178711576-1327415907317

Call-ID:[email protected]

CSeq:1002 SUBSCRIBE

Allow-Events:call-info,line-seize,dialog,message-summary,as-feature-event,x-broadworks-hoteling,x-broadworks-call-center-status

Content-Length:0


** domain and IP masked **

adam.baird Wed, 01/25/2012 - 15:52
User Badges:

Hi Jonathan,


I can confirm that my Polycom does indeed feature sync with an SCA, and my Cisco SPA 5xx do not.  However unlike what you report I do not see my Cisco SPA attempt to send a subscription.


Looking at your SIP message above, I am not sure this is related to the feature sync.  The event type is not what you'd expect to see for a feature sync.  The packet you pasted above tries to subscribe to


Event: missed-call-summary


The subscription to sync features should say

Event: as-feature-event


Is it possible that your Cisco SPA is behaving like mine and NOT sending a subscribe and that you happened to be seeing a non-related subscription message?


-Adam

jlhbjnhh67 Thu, 01/26/2012 - 05:16
User Badges:

This trace is for Polycom at the same time..


SUBSCRIBE sip:[email protected]:5060 SIP/2.0

Via: SIP/2.0/UDP xxxxxxxxx:5060;branch=z9hG4bKmics6b30bo7gat00l1n1.1

From: "Jonathan Lee" [email protected]>;tag=3A9CBBD2-CB03460B

To: [email protected]:5060>

CSeq: 2 SUBSCRIBE

Call-ID: [email protected]

Contact:

Allow: INVITE, ACK, BYE, CANCEL, OPTIONS, INFO, MESSAGE, SUBSCRIBE, NOTIFY, PRACK, UPDATE, REFER

Event: as-feature-event

User-Agent: PolycomSoundPointIP-SPIP_450-UA/3.3.3.0069

Accept-Language: en

Accept: application/x-as-feature-event+xml

Authorization: DIGEST username="22222222229", realm="domain.com", nonce="BroadWorksXgxt15h0wTk9pb9cBW", qop=auth, cnonce="+aBa++XsHV1DOkb", nc=00000001, uri="sip:[email protected]:5060", response="9133c94037ee3e241729633e35720e45", algorithm=MD5

Max-Forwards: 69

Expires: 3600

Content-Length: 0

Route:




SIP/2.0 200 OK

Via:SIP/2.0/UDP xxxxxxxxxxx:5060;branch=z9hG4bKmics6b30bo7gat00l1n1.1

From:"Jonathan Lee"[email protected]>;tag=3A9CBBD2-CB03460B

To:[email protected]:5060>;tag=1765652328-1327415896706

Call-ID:[email protected]

CSeq:2 SUBSCRIBE

Expires:3600

Contact:

Content-Length:0

adam.baird Thu, 01/26/2012 - 09:06
User Badges:

Hi,


So I see from the Polycom trace that it subscribes to the correct event:

Event: as-feature-event


But the Cisco SPA trace you attached subscribes to the wrong event:

Event: missed-call-summary


So one of two things is happening.

1) The Cisco SPA is attempting to subscribe to the wrong event so Broadsoft is rejecting it or

2) The Trace you included for the Cisco SPA is for another service and has nothing to do with the feature sync you are trying to do.


I have noticed on my system that when a shared line is configured on my SPA, the device does not attempt a subscription message so that tells me that #2 may be what is happening.


At this time I think we need one of the Cisco guys to tell us how the phone SHOULD behave when configured as a shared line.


-Adam

jlhbjnhh67 Thu, 01/26/2012 - 12:38
User Badges:

I see that trace for SPA was not for DND..


So here is the regitration portion of the line port registered on SPA..


REGISTER sip:domain.com SIP/2.0

Via: SIP/2.0/UDP xxxxxxxx:5060;branch=z9hG4bK44vodm20a8n14p44e6s0.1

From: "Jonathan Lee" <[email protected]>;tag=6251a90a996b8fc6o0

To: "Jonathan Lee" [email protected]>

Call-ID: [email protected]

CSeq: 15892 REGISTER

Max-Forwards: 69

Authorization: Digest username="7036216279x6279",realm="domain.com",nonce="BroadWorksXgxw0yig1TwglxdaBW",uri="sip:domain.com",algorithm=MD5,response="a781489e741e9f6d34a6707880fed460",qop=auth,nc=00000232,cnonce="525e7615"

Contact: "Jonathan Lee" ;expires=0

User-Agent: Cisco/SPA525G-7.4.9c

Content-Length: 0

Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, REFER, UPDATE

Allow-Events: hold,talk

Supported: replaces

Route:


SIP/2.0 200 OK

Via:SIP/2.0/UDP xxxxxxxxx:5060;branch=z9hG4bK44vodm20a8n14p44e6s0.1

From:"Jonathan Lee"[email protected]>;tag=6251a90a996b8fc6o0

To:"Jonathan Lee"[email protected]>;tag=271632575-1327609866728

Call-ID:[email protected]

CSeq:15892 REGISTER

Allow-Events:call-info,line-seize,dialog,message-summary,as-feature-event,x-broadworks-hoteling,x-broadworks-call-center-status

Content-Length:0


The different I see is onthe Route: section. Polycom actually includes the lineport info. But SPA only has IP address.

gilad.hinberger Thu, 02/02/2012 - 10:32
User Badges:

Any updates regarding this issue?


We have exactly the same problem - DND on the Cisco SPA504G doesn't sync with Broadsoft.

No problem with DND on Aastra phone...


Gilad

jlhbjnhh67 Thu, 02/02/2012 - 10:41
User Badges:

No further updates.. If you set the line registration to PRIVATE, then the sync works. But then if you have all lines as PRIVATE, you cannot do hold-retrieve from multiple phones. This is a very basic requirement and I would think that Cisco SPA developers would have figure this out and there is some special settings to apply for this to work.

gilad.hinberger Fri, 02/03/2012 - 08:03
User Badges:

Hi Jonathen, thanks for answering


Where exactly I can set the line registration to PRIVATE in the phone settings? Couldn't find it...


Thanks,

Gilad

gilad.hinberger Mon, 02/06/2012 - 02:32
User Badges:

Just checked - both options set to Private on my phone. Still, DND doesn't sync with Broadsoft...


Any ideas?


Thanks,

Gilad

joshua.andrzejewski Wed, 02/15/2012 - 07:38
User Badges:

Gilad, I found that the "CFWD_Notify" tag affects the type of message that is sent.


No


If this is set to "Yes", the feature updates go out as  "Event: missed-call-summary"

But if you set that tag to "No", the features go out as  "Event: as-feature-event"


I also confirmed that if the line is Shared, the events do not go out at all. When Shared, the DND mode will make the phone respond to Invites with 486/Busy, and with Call Forward the phone responds with 302/Moved



So my winnning combination for SPA 50x with Broadsoft was:

No

Yes

gilad.hinberger Tue, 02/28/2012 - 08:56
User Badges:

Thanks Joshua,


Now it's sometimes working, and sometimes not


What about this line:

No


Should it set to Yes or No?



(why so many settings for one small feature?)

gilad.hinberger Tue, 02/28/2012 - 09:04
User Badges:

Seems like the perfect combination (for me, and only for sync DND with Broadsoft) is:


Yes

Yes


1

gilad.hinberger Tue, 02/28/2012 - 09:43
User Badges:

Ok, I just did few tests...

(firmware version is 7.4.9c)


With these settings:


Yes

Yes


1


DND set to on (checked on the Broadsoft platform, just to make sure)


Restart the phone several times. Results:


After the phone finish the reboot process, DND is sometimes on and sometimes off, randomly


Any ideas?

Actions

This Discussion