Nexus 5548UP lacp with IBM AIX P740

Unanswered Question
Jan 24th, 2012
User Badges:

We are currently working in a lab to configure our first pair of 5548UP(with a 2232PP on each) with FCoE to an IBM p740 AIX server.  On the Nexus side I have confugured the physical port e100/1/1 (2232pp) to be in a channel-group that will be part of a vpc with the other 5548UP switch, I am trunking all vlans in the etherchannel with the IBM server.  Everything is working, i have the port-channel UP, the vfc and vpc when I use ''channel-group x mode ON'' on the physical ports and on the server side the 803.2ad is not active, it's configured ''roundRobin''. 


Suppose I want to use LACP for the connections with the server should I configure the Nexus switch port with ''channel-group x mode active'' or ''channel-group x mode passive''?  When the server is configured with ''802.3ad'' enabled and when I have ''channel-group x mode active'' or ''passive'' it doesn't work, the port-channel x does not come UP.



Does anyone have an explenation of how I should be configure?


Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
stanti Tue, 02/07/2012 - 10:52
User Badges:
  • Cisco Employee,

Hello,


Using LACP passive or active mode should not make much of a difference as long as one of the sides of the port-channel actively negotiates LACP.  In most cases, we just configure both sides to be LACP active.


  • When you say the port-channel is not working when using LACP, what are the symptoms?


  • Are the physical ports in "I" state?'

'show port-channel summary' will show this



  • What does the output of "show lacp counters interface port-channel X"  show?

This command will tell you if the Nexus 5K/2K is receiving LACPDUs from the IBM device (and if we are sending them).  I would suggest to collect the LACP counters to verify that we are receiving the LACP packets from IBM, otherwise Nexus will not bring up the port-channel.  Here is an example output from my lab switch:


5548-2019# show lacp counters interface port-channel 500

                    LACPDUs         Marker      Marker Response    LACPDUs

Port              Sent   Recv     Sent   Recv     Sent   Recv      Pkts Err

---------------------------------------------------------------------

port-channel500

Ethernet1/15       16401  16399    0      0        0      0        0

Ethernet1/16       16400  16399    0      0        0      0        0



Regards,


Steven

sergebelleau Fri, 06/07/2013 - 07:03
User Badges:

It' been a while since we that problem originaly if I remember correctly it was an issue with the version of the drivers on the NIC card of the IBM server, make sure you have the last version of drivers on the servers.

Actions

This Discussion

 

 

Trending Topics: Storage Networking