×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Redistribution eBGP/MPLS to EIGRP- Companies Migration

Unanswered Question
Jan 28th, 2012
User Badges:

I have a question about two companies migration Iusse, Attached scenario should give most of the information.

Company A got two router R1 and R2 running EIGRP100 with the service providers 1
Company B got R3 Running MPLS BGP with same service provider 1
Company A is migrating with Company B

After migration Company A and B should be takling internally 

With the Below Configuration, I can reach from company A to B, but Not from Company B router to Company A Not sure what I am missing in my configs  Or is there a better way to migrate two copmanies with out creating new EIGRP AS?


Company A Router 1


router eigrp 100 <----To ISP 1
redistribute connected
no auto-summary
eigrp router-id 10.10.10.1
network 10.0.0.0
network 172.17.10.0 0.0.0.3
!
!
router eigrp 200          <---- to Company B
redistribute connected
no auto-summary
eigrp router-id 192.168.200.5
network 172.16.10.0 0.0.0.3


Company A-R1#ping 192.168.200.1- This is in VRF on Router CompanyB

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.200.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Company B Router configuration


How can I redistribute the routes learned [through redistribute connected/static] into EIGRP 200


router eigrp 200( built new EIGRP 200 to get routes from Company A and keep them seperate)
redistribute connected

redistribute bgp 200 metric 10000 2000 255 1 1500

network 172.16.10.0 0.0.0.3
no auto-summary
eigrp router-id 192.168.200.1
!
router bgp 200          <-----eBGP to ISP 1
bgp router-id 172.15.10.1
bgp log-neighbor-changes
!
address-family ipv4
  no auto-summary
  no synchronization
exit-address-family
!
address-family ipv4 vrf test1
  redistribute connected
  redistribute eigrp 200
  neighbor 172.15.10.2 remote-as 54321
  neighbor 172.15.10.2 update-source Vlan555
  neighbor 172.15.10.2 activate
  neighbor 172.15.10.2 soft-reconfiguration inbound
  no synchronization
  network 10.50.60.0 mask 255.255.255.192
  network 172.15.10.0 mask 255.255.255.252
  network 192.168.200.0 mask 255.255.255.252
exit-address-family


company B#ping 192.168.200.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.200.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R4#ping 192.168.200.1


Can someone guide me what I am doing wrong?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Gautam Renjen Fri, 02/03/2012 - 16:43
User Badges:
  • Cisco Employee,

Hi Blanch,


1. I need a lot more information to tell you whats going on:

-- Complete configs of all 3 routers would be good (here even the inteface configs aren't there)

-- "show ip route" and "show ip cef "for the prefixes which you're pinging

-- traceroute to the prefixes as well


2. You say that when you're pinging 192.168.200.1 from Router 1 , that the IP resides on Router 2 in  a vrf. Fair enough.

However, when you do a reverse ping, I don't see "ping vrf [vrfname] 192.168.200.5"

Also, if that interface is in a vrf on Router 2, and eigrp 200 is running over it, then we should have the configs under the address-family for that vrf in eigrp, which i don't see here.


3. Also send outputs of show ip eigrp neigh

Kishore Chennupati Sat, 02/04/2012 - 04:48
User Badges:
  • Gold, 750 points or more

Blach,


I hope you remember me. I replied to this post when you posted this question sometime ago. I am sorry I couldnt get back to you on that again. got caught up with stuff.


https://supportforums.cisco.com/message/3546688#3546688


now, the solution is very simple. If you re-visit that thread again, varma gave you the answer. Below is what you need to configure on Company B R1 router.


router eigrp 200

no auto-summary

!

address-family ipv4 vrf "VRF_Name"

redistribute connected

redistribute bgp 200 metric 10000 2000 255 1 1500

network 172.16.10.0 0.0.0.3
no auto-summary
eigrp router-id 192.168.200.1

exit-address-family


Let me explain it to you. Your company B R1 router is acting like a  PE. and this case the Compan A R1 acts like a CE and they peer using the  eigrp 200 AS.

So you dont need to create any VRF's etc on company A R1. Just put the above config and it should work.


So, when you ping from the company B R1 to the company A R1 just use the ping vrf  VRF_Name" command.

The way around you dont need to use the vrf



HTH


Kishore

Actions

This Discussion