OSPF periodic flooding

Unanswered Question
Jan 29th, 2012
User Badges:

Studying Ospf, and periodic flooding i found that ospf refresh it's LSA every 30 minutes (1800 seconds) if no change occur, but the output of my show ip ospf database shown an age of more than 1800 seconds as in the output above from my router 1800 series…



Searching on Google or Cisco site i haven't found nothing about configurable timer, but about 1800 second is the default behavior for the standard, in my lab there is the exception who proves the rule?




Router_A#sh ip ospf database




            OSPF Router with ID (10.10.10.10) (Process ID 10)




                Router Link States (Area 0)




Link ID         ADV Router      Age         Seq#       Checksum Link count


9.9.9.9         9.9.9.9         1888        0x80000002 0x009AC3 2


10.10.10.10     10.10.10.10     1887        0x80000003 0x005C7A 2






And after a lot of time router b has reset the timer but router a is going up...




Router_A#sh ip ospf database




            OSPF Router with ID (10.10.10.10) (Process ID 10)




                Router Link States (Area 0)




Link ID         ADV Router      Age         Seq#       Checksum Link count


9.9.9.9         9.9.9.9         2017        0x80000002 0x009AC3 2


10.10.10.10     10.10.10.10     127          0x80000004 0x005A7B 2

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Mohamed Sobair Sun, 01/29/2012 - 09:13
User Badges:
  • Gold, 750 points or more

Hello,


LSA Refreshes every 30 minutes, but this is a Partial update (Updates with new changes).


the FULL OSPF updates are sent every 2 hours, this updates contains (full topology) info. So what you are seeing is normal.




Regards,

Mohamed

Beetlejuice01 Sun, 01/29/2012 - 09:30
User Badges:

Hi Mohamed, from the page 204 of Cisco book Offical Certification Guide CCNP of Wendell Odom:


If 30 minutes pass with no change to an lsa meaning no other reason existed in that 30 minutes to cause a reflooding of the lsa the owning router increments the sequence number,resets the timer to 0 and reflood lsa.


Because the owning router increments the sequence number and resets the LSAge every 1800 seconds (30 minutes) the output of various show ip ospf database command showld also show an age of less than 1800 seconds.


And continue... when a router realizes it needs to flush an lsa from lsdb for an area, it actually sets the age of the LSA to the MaxAge setting (3600)


If 1800 is 30 minutes 3600 is 1 hour... where have you found information about 2 hours?


The router B in my cases has reset timer at 1900 an more, the router A after 3600 seconds.

Mohamed Sobair Sun, 01/29/2012 - 09:58
User Badges:
  • Gold, 750 points or more

Fabio,


I apologize, its not 2 hours. You are correct, its 1 hour the Maxage LSA.


what I meant, is when the router needs to flood an LSA, it set the maxage to the LSA. Only those routers who originate the LSA can set the timer and flood to its ospf neighbors.


The Changes are immediately flooded to all routers and the LSA refreshes every 30 minutes if the network is Stable.


If a new LSA must be created, the router must first flush the OLd LSA from all OSPF database, and this is done by setting the Maxage to the existing LSA, the router then reflodds it to its adjacent OSPF neigbor before sending the New LSA.



Have you performed any configuration changes while examining this behaviour?




Apologize again, I was almost sleeping.




Regards,

Mohamed

Beetlejuice01 Sun, 01/29/2012 - 10:18
User Badges:

What i'm seeing in my test is only that with two router simply connected with a serial cable with no change on topology the LSA as described on the book with no change isn't refreshed after 30 minutes. Obviously if i made some change or change the status of some interface the change occur, but without change the rule "age of less than 1800 seconds" isn't as described from our collegue who written the book nor as i found on Cisco's material online...that's only strange. I've doesn't change any timer on router so it's the default behavior of the two router that is different one from the other because one finish the max age of 3600 and the other not.



You don't need to apologize i've seen your profile your knowledge is amazing :-D



I will try to reset the configuration to default and reconfigure a simple ospf from 0 to see if return's to the standard.

Richard Burts Sun, 01/29/2012 - 14:25
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Fabio


The behavior that you describe sounds very much like the features introduced in OSPF Demand Circuit. See this link for details

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094a8f.shtml


Perhaps you could post the output of the router configuration or at least the interface config and the OSPF config?


HTH


Rick

Beetlejuice01 Sun, 01/29/2012 - 22:22
User Badges:

Hi Richard,


I already know about that features, but it isn't my case. I've only configured a simple ospf over 2 serial interface and specified interface as point to point to auto establish a neighborship because i've configured frame relay. With that feature in the document you have posted when configured demand circuit to suppress lsa it's configured the do not advertise "dna" features, and it will be shown on the ip ospf database as example above:


Router_A#sh ip ospf database




            OSPF Router with ID (10.10.10.10) (Process ID 10)




                Router Link States (Area 0)




Link ID         ADV Router      Age         Seq#       Checksum Link count


9.9.9.9         9.9.9.9         2017      (DNA)  0x80000002 0x009AC3 2


Both Mohamed and Richard if you have an ospf case can you check if the timer goes over  1800?


Thanks


Fabio

Beetlejuice01 Mon, 01/30/2012 - 01:15
User Badges:

hi Peter,


no Ospf LSA Group Pacing configured, i've already tried to configure this feature to do the lsa flooding but both routers ignore the timer who i set and reset timer when it want.

Beetlejuice01 Tue, 02/14/2012 - 01:31
User Badges:

Hi all, after a lot of time i have deleted the old config and configured ospf from 0, but with the same result.


Here a config of one router. Is the same on both, except for dce on frame relay.


Router#sh run


Building configuration...




Current configuration : 1053 bytes


!


version 12.4


service timestamps debug datetime msec


service timestamps log datetime msec


no service password-encryption


!


hostname Router


!


boot-start-marker


boot-end-marker


!


!


aaa new-model


!


!


aaa authentication login default local


aaa authorization console


aaa authorization exec default local


!


aaa session-id common


ip cef


!        


!


!


!


!


frame-relay switching


!


!


username cisco privilege 15 secret 5 $1$c.Gq$Ra8zdDojuaaoek3X0gn8S1


!


!


!


!


!


!


interface FastEthernet0/0


no ip address


shutdown


duplex auto


speed auto


!


interface FastEthernet0/1


no ip address


shutdown


duplex auto


speed auto


!


interface Serial0/0/0


bandwidth 2000


ip address 192.168.100.1 255.255.255.252


encapsulation frame-relay IETF


ip ospf network point-to-point


frame-relay interface-dlci 100


frame-relay lmi-type cisco


frame-relay intf-type dce


!


router ospf 1


log-adjacency-changes


network 192.168.100.0 0.0.0.3 area 0


!


!


ip http server


no ip http secure-server


!


!


!


control-plane


!


!


line con 0


line aux 0


line vty 0 4


!


scheduler allocate 20000 1000


end








AFTER more than 1800 sec...




Router#show ip ospf database




            OSPF Router with ID (192.168.100.1) (Process ID 1)




                Router Link States (Area 0)




Link ID         ADV Router      Age         Seq#       Checksum Link count


192.168.100.1   192.168.100.1   1816        0x80000002 0x00AB0D 2


192.168.100.2   192.168.100.2   1817        0x80000002 0x009F17 2






AFTER counter reset of Router A.




Router#show ip ospf database




            OSPF Router with ID (192.168.100.1) (Process ID 1)




                Router Link States (Area 0)




Link ID         ADV Router      Age         Seq#       Checksum Link count


192.168.100.1   192.168.100.1   45          0x80000003 0x00A90E 2


192.168.100.2   192.168.100.2   1875        0x80000002 0x009F17 2

Timothy Hall Sun, 11/04/2012 - 15:21
User Badges:
  • Cisco Employee,

I know you asked this several months ago, but while studying for my CCNP Route exam I came across this which may shed some light...

http://www.cisco.com/en/US/docs/ios/12_1t/12_1t2/feature/guide/dt_ospff.html


You may want to check your IOS version and see if (DNA) or Do not Age is set to default.


Based on your output:

Link ID         ADV Router      Age         Seq#       Checksum Link count


9.9.9.9         9.9.9.9         2017      (DNA)  0x80000002 0x009AC3 2



It doesn't show this in the last output though...

Actions

This Discussion