Problems staying connected - Dell Latitude ST (1535C Half MiniCard Atheros based wifi)

Unanswered Question
Jan 30th, 2012

I have some Dell Latitude ST Windows 7 tablets and I am having major problems getting them to stay connected to wifi. They have the Dell wireless branded 1535C pci-e half minicard, which is atheros based and is running the only and latest driver I can find (3.1.2.41)

The devices connect to wifi but stop working after about 30-60 seconds and you sometimes have to completely reboot the tablet to get it to connect again. Basically you notice network activity stops and you get a limited conectivity exclaimation mark on the wireless icon in the systray.

Cleanair 3502i AP + some 1142N

3750G PoE Switches

WISM1 running 7.0.116.0

At the moment I have gone back to a simple WPA2 AES PSK wlan. It was the same with 802.1x authentication.

This device is connecting flawlessly on my Netgear router at home which is a WPA2 AES dual band 2.4 5ghz 802.11n.

Debugs Attached.

Any ideas would be good.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
daviwatk Thu, 02/09/2012 - 13:45

The debug indicates that your client entered the RUN state successfully at 16:58:17.451

*apfReceiveTask: Jan 30 16:58:17.451: e4:d5:3d:63:49:ab 192.168.254.158 DHCP_REQD (7) Change state to RUN (20) last state RUN (20)

Approximately 6 minutes later we de-authenticate the client with the reason...

*spamReceiveTask: Jan 30 17:04:48.540: e4:d5:3d:63:49:ab Received Idle-Timeout from AP 10:8c:cf:b0:43:10, slot 0 for STA e4:d5:3d:63:49:ab

*apfReceiveTask: Jan 30 17:04:49.455: e4:d5:3d:63:49:ab Sent Deauthenticate to mobile on BSSID 10:8c:cf:b0:43:10 slot 0(caller apf_ms.c:5094)

The client hit the WLC's default "user idle timeout" (Found in the WLC GUI at CONTROLLER > General > "User Idle Timeout (seconds)", which has a default of 300 seconds (5 minutes).  This is how long we will keep a client entry for a client we do not "hear" from (ie. a client that is not communicating at all; which ideally would be a client that has been turned off or left the service area)

This indicates that the client simply does not communicate to the AP for 300 seconds (or whatever your time is set to).

To "see" if this is really the case; does the tablet stay connected when you have initiated a continuous ping to, say, its gateway?  This sounds like it may be an issue "specifically" between the AP and client.

If the ping keeps the session active, I would highly suggest taking an over-the-air capture on the same channel as the AP to listen to the client/AP communication along with a simultaneous wireshark capture on a problem test client.  If the client is initating traffic (via wireshark); is it actually hitting the air(omnipeek)?  Is the traffic being ignored by the AP?  Over-the-air will be a tell all in this situation.

JroseTCMC Fri, 02/10/2012 - 15:27

Our school also has 10 of these Tablets and we are experiencing the same issues you have described here. We ar running a Cisco 5508 Controller with 1142 AP's. I did have one ST stay connected for about 3-4 minutes at one point. But I cannot seem to keep them connected at this point. We did a trouble on the wireless card and found the drivers were stating they were not correctly installed. I have tried multiple fixes for this issue and have found nothing that will resolve it yet. Will be collaberating with our Network Admin tomorrow to do logging of this error. I would apperciate any help at this point. Thanks!

Scott Fella Fri, 02/10/2012 - 15:34

Make sure client load balancing is disabled under the WLAN SSID advanced tab.

Thanks,

Scott Fella

Sent from my iPhone

JroseTCMC Sat, 02/11/2012 - 13:20

Scott,

We have tried this today and that did not solve our issue with these tablets.

David,

We have tried pinging our gateway continously from the tablet and the connection still drops.

We are recieving the same timeout message as the orignal poster and have not come across a solution as of yet. Any more thoughts and ideas are welcome. The timeout period of 300 seconds is MUCH shorter than the actual time the tablet is "connected" to the AP. So we are at a loss on trying to figure out why this issue is happening.

-Joshua Rose

Systems Support Tech

The Commonwealth Medical College

Scott Fella Sat, 02/11/2012 - 13:34

Well just keep that disabled. Do you have both wpa/tkip and wpa2/aes enabled on the SSID?

Thanks,

Scott Fella

Sent from my iPhone

Scott Fella Sat, 02/11/2012 - 13:57

Okay.... I don't know what you have done yet as far as troubleshooting, the only thing I would do to see if its an issue with the client side is create a test ssid and leave everything as default except for the status, interface and change the encryption to none, keeping everything else default, if your client still has issues, then it almost looks like Dell would have to be involved.  I'm also assuming every other device is working without any issues, just these Dell's.  The only other thing is maybe on the client device is to disable power save mode.

JroseTCMC Sat, 02/11/2012 - 14:04

We have tried tethering it to a mobile Verizon 3G WiFi and it stayed connected to that device for over and hour and half last night. We have tried connecting the device in multiple signal strength locations in our building with no luck. We Have been able to connect the device via a USB adapter to a wired connection to our network. We have also tried connecting them to our guest network which only allows outside access to the internet. The connection issue seems to be between the tablet and the AP. I am thinking at this point it has to be Dell issue related to drivers or something in the software package from the factory that is killing the connection. Not sure why this is such an issue, tried an update for drivers and bios on them and neither has seemed to clear the issue. All of our other devices on campus are working perfect.

Scott Fella Sat, 02/11/2012 - 14:07

Yeah... looks like its a Dell issue.... time to get on the Dell rep for some answers:)

JackMajor Sat, 02/11/2012 - 17:27

at home u only have 1 ap? when i had this problem the clients were roaming trying to find all the aps at my corp. i turned down the roaming aggressive setting on the nic and fixed it

Sent from Cisco Technical Support iPad App

andersonch Mon, 02/13/2012 - 14:06

After spending multiple hours working on it I decided to give up and put it on Dell's lap.  I have an open ticket with them so hopefully they will be able to duplicate the issue.

I did find a workaround.  If you put the device on an SSID what has 802.11n turned off it works fine.  In my case I created a new SSID using WCS.  The QoS > WMM Policy is set to Disable.  Found those instructions here

https://supportforums.cisco.com/thread/2007749

This can also be done if an LWAPP controller is used.  I do not know if it can be done to an autonomous AP since I don't have one.

chris.brunt Tue, 02/14/2012 - 01:47

Hi everyone I have tried disabling 802.11n by disabling WMM made no difference. Also tried going to b/g only, again no difference. I also have MFP disabled at the moment as well due to an issue with some Intel cards.

I have a tread on the dell forums regarding this issue. Feel free to post on this thread to attract some attention from dell.

http://en.community.dell.com/support-forums/mobile-devices/f/3824/p/19436479/20052368.aspx#20052368

It could be faulty hardware Thomas Enchelmeier but I have four of these tablets and they are all doing the same thing.

t.enchelmeier@s... Tue, 02/14/2012 - 00:38

I have exactly the same problem. The ST is online for 20-30 seconds after boot or after waking up from standby. Removing the driver or updating it causes the OS to hang, so I have to switch off hard. It's the original DELL W7 Pro Image.

I've just called the DELL Pro Support. They never heard about such a problem with the 1535C and they suppose defective hardware. Tomorrow a technician will come to change the card. I'll keep you informed.

JroseTCMC Tue, 02/14/2012 - 05:21

I have to agree with Chris on this one. The problem is not faulty hardware as the WLAN card on ours works...just not on N connections. We have 10 of these all doing the same thing as well. We also had a similiar problem with our new E6520 models they were connecting and then dropping. The problem there was adriver update and they look to be working ok now. The problem here seems to be exactly the same symptoms and I have troubleshot it the same way only more and really seems to be isolated to the way in which the WLAN card talks to the AP.

Dell seems to be aware of this issue and told me yesterday that they are aware that an issue is ongoing with connection issues with the ST. He had me remove all Athero's software from the system, which I found a way to do without the system hanging. But as I expected it did not solve the issue. So it is not a problem with Athero's and Windows conflicting and causing the issue. Seems to be completely on the WLAN card drivers at this point. Which Dell also told me that they are working on a new driver for the ST and hope to have one in "a few weeks."

The only thing I have not tried is using a USB wireless to see if I can connect via N that way. That would completely isolate the issue to how that specific card communicates. Anyone else try this yet?

-Joshua Rose

Systems Support Tech

TCMC

t.enchelmeier@s... Wed, 02/15/2012 - 08:12

As supposed, the change of the WLAN card didn't solve the problem. DELL advised to reinstall OS and drivers. Even this, be surprised, didn't bring the Latitude to stay connected. You wrote this problem exists only on N networks? I can tell you, it's also present in b/g network environment.

Just called again the DELL support. They want to test it in their lab and call me back tomorrow.

I'll keep you informed.

robert.murdoch@... Wed, 02/15/2012 - 11:38

Another Dell ST user with this same problem. In my case. In very rare cases I am able to stay connected for hours. Most times I loose connection in 20-30 seconds. I thought configuring the wifi network settings (in windows network and sharing center click manage wireless networks then the problematic network's properties) to Automatically use my windows login fixed this, however, I'm still experiencing the issue with that setting.

pccitcomms Fri, 03/02/2012 - 05:25

Just wanted to add my name to the hat.  Same problem with the same hardware. I have tried the suggestions here and on the dell link, with no change. Connects for 20-30 secs then drops and will not connect to any wireless device until a reboot.  This card works fine from home and connecting to a 877 router, but fails when using any controller based light weight access point.

t.enchelmeier@s... Fri, 03/02/2012 - 05:35

After my last phone conversation with DELL they confirmed that this is a problem with the network cards in conjunction with the Cisco access points. DELL global support is working together with Cisco to solve that issue. There will be a new driver or firmware for the card and possibly for the AP (WLC). Thats my last info.

Best regards

Thomas

becca1jane Fri, 04/06/2012 - 09:58

Any updates on this?  Our hospital wants to purchase 4 Latitude ST tablets - we are running 7.0.116.0 on our WISMs - with 1252 and 1142 APs.  Hoping to avoid the potential issues you all have been running into.

Thanks!

George Stefanick Fri, 04/06/2012 - 14:27

If you purchase new, request the intel card for your build. The intel doesn't have a issue.

Sent from Cisco Technical Support iPhone App

tomlukes Fri, 09/21/2012 - 18:42

I know if has been quite some time, but ran across this, as we are seeing the very same thing.   I have just discovered a very consistant pattern with this.    If we ping the device, we see high ping times.  From the device, we don't.    What I found was if the client had CCX 4 and Client E2E version was NOT supported (as yours shows in client detail), the issue existed.    If you have CCX 4 and Client E2E version WAS supported (Intel NICs), the issue was non-existent.   I confirmed this at least on at least 30 devices having each.      If the device had CCX 5, it did not need the E2E supported to work fine.

It is very early in my troubleshooting.  I have tried to disable Aironet Extensions on the controller without any change.   So I haven't nailed down the fix, but narrowing it down to devices that have that combination.





Scott Fella Fri, 09/21/2012 - 19:06

Funny that this came up. Im going onsite to a customer that is having issues like this with various laptops and some with the newer intel cards. They would ping their gateway and have ping times in the 100's to 1000's and the pings would stop for a little and come back. These devices work fine in and environment with 4400's and 1142, but have issues with 5508's and 3600's. I'm going to load the newest 7.2 on monday and see if I can get figure this our next week. Client doesn't want to touch contractor laptops and doesn't feel like having to update drivers, etc is a fix:)

Sent from Cisco Technical Support iPad App

tomlukes Fri, 09/21/2012 - 19:18

Please let me know what you find.  We are on 7.0.116.0 with 4400s and 5508s with 1242s, 3502s and 1142s.    I may an upgrade as well, if I can get a small enough of a location.

Scott Fella Fri, 09/21/2012 - 20:00

I will... the 5508's were initially on 7.2.103.0, then we upgraded to 7.2.110.0 and Monday I'm hoping to upgrade to 7.2.111.3 to see if that helps.  This is the only site that I'm having issues with.  I have other clients running various codes with no issues, so we shall see.

Thanks,

Scott

Help out other by using the rating system and marking answered questions as "Answered"

jgillfeather Thu, 12/06/2012 - 17:03

Hi all,

did anyone come up with any results for this?  We've been advised by Dell that there is an unsupported version of the Atheros driver which works "most of the time", the exception appearing to be either in a secure Wi-Fi environment, or maybe just with Cisco WLC's.

Did upgrading the 5500 work?

regards,

Justin

ewieder Wed, 02/06/2013 - 12:35

What allowed me to get them to even connect was to disable the Client Exclusion setting.  This allowed me to connect to all forms of authentication.

jgillfeather Wed, 02/06/2013 - 15:10

Cheers Eddie, will give that a try.

Pretty sure that will mean we fail our next Pen test though...

Scott Fella Wed, 02/06/2013 - 15:19

Some things that I have noticed also is the session timeouts.  Try to uncheck this and see if that helps... Try one thing at a time so you know if one thing works or not.  Pen test..... just enable it before they get there:)

Thanks,

Scott

Help out other by using the rating system and marking answered questions as "Answered"

tomlukes Wed, 02/06/2013 - 15:36

Just another update - my issues wetre resolved by disabling client exclusions as well, but also changing the NIC settings.  The default Power Saving Mode on the NIC is FAST. 

Scott Fella Wed, 02/06/2013 - 15:56

Was that default on the client or was that maually changed... doesn't seem right to have it set to fast.

Thanks,

Scott

Help out other by using the rating system and marking answered questions as "Answered"

tomlukes Wed, 02/06/2013 - 16:12

Oddly enough, with XP, it is set to "Fast".   The options were "enabled, disabled or fast".  We could see delays in Instant Messaging and other APPs.  As soon as it as disabled all of the performance issues went away.   What was really strange is when I was pinging between two devices.  One set to Fast, the other wired or wireless set to disabled.   To the device they ping times were higher and would drop periodically.  From the device, there were no delays or drops.  I could repeat those findings every time.   

My latest frustration was the 5002 and 5005 errors filling the event viewer on other XP devices (Intel NICs).   I traced it back to being caused by SP3 and is corrected with the latest NIC drivers.   I imagine a day of "silence"...but with over 15,000 clients, I should imagine it anytime soon.  lol

jgillfeather Wed, 02/06/2013 - 16:06

Hi Tom,

can you confirm which NIC driver version you're using - i have the Atheros AR6003 WLAN adapter, v 3.1.2.85.

Only Power Management options i have are "Allow the computer to turn off the device" and WoL.

Unrelatedly, we also still regularly get the Error 10 on NIC on startup (the device just doesn't start, happens approx 1 in 3 poer cycles).

On a brighter note, the Latitude 10 (Atheros 1536C) seems to work a treat...

Justin

tomlukes Wed, 02/06/2013 - 16:19

This is the DW1530 Wireless-N WLAN Half-Mini Card (with the following details - updated since the issue surfaced)

Driver Provider: Broadcom

Driver Date: 9/26/2012

Driver Version: 6.30.59.81

DW1530 Wireless-N WLAN Half-Mini Card

Driver Provider: Broadcom

Driver Date: 9/26/2012

Driver Version: 6.30.59.81

The setting is under the advanced tab for the NIC on these.

On the other issue - what is your wireless APs set to for WMM?

jgillfeather Wed, 02/06/2013 - 16:46

Cheers Tom.

Re: WMM, my production SSID's are set to Allowed, i have a test one that is Disabled, but behaviour seems the same.

Just to confirm, this is in a Dell Latitude ST ?  If so, can i ask what Country you're in?  Have been trying to convince Dell here in Australia to swap out my Atheros 1535C's, so have been looking for a potential replacement.  Maybe the Broadcom DW1530 is just a re-brand, though (chipset number is suspiciously similar) ?

Out of interest's sake, have you ever installed Windows 8 on the device with the DW1530? Would be good to know if it works..

rgrds

Justin

tomlukes Wed, 02/06/2013 - 18:23

We have a few models - one I am on now is the Dell Latitude E5420 with the DW1530 Half MiniCard...in the U.S.    From what I can see, the actually use both the Broadcom and Atheros Chipsets.   I don't know which are in what models by default or if the option exists to order one way or another.   The issues I saw were very similar - didn't mean to hijack the Atheros issue with the Broadcom issue.   :-)  

We used to insist on the Atheros Chipset with Intels early Broadcom issues, but we are back to the Broadcom ones again.   Here is a link that may answer some more questions, including findings on Windows 8.

http://en.community.dell.com/support-forums/mobile-devices/f/3824/p/19436479/20057641.aspx

holly030409 Wed, 04/17/2013 - 10:16

I have the same problems at the start of the year, and left the Slate is a drawer until now.

But Dell have released a newer driver for the Windows 8 wireless card in February 2013.

I loaded this new diver, and everything works now.

jgillfeather Wed, 04/17/2013 - 16:15

Hi Simon,

can you confirm the driver version and what sort of Wi-Fi you're using? (specifically the security model)

regards,

Justin

maristsion Wed, 05/22/2013 - 17:21

Hi,

I too have spent too much time trying to fix this issue, we've been using SCCM to deploy the OS and some drivers with the same results as above, it looks like it's connected but after a few minutes drops, ping response times are also bad during the connected time.

Installing just the 3.1.2.87 driver results in the same issue, installing the ST_Network_Driver_TKWFP_WN_3.1.2.87-7.4.0_A07 package which I believe includes a firmware update appears to resolve the issue, ping times are now normal and it hasn't dropped the connection yet. This was a clean install not using SCCM with no previous wireless driver installations.

Ben

Actions

Login or Register to take actions

This Discussion

Posted January 30, 2012 at 9:13 AM
Stats:
Replies:39 Avg. Rating:
Views:21426 Votes:0
Shares:1

Related Content

Discussions Leaderboard