New switch not working correctly

Unanswered Question
Jan 31st, 2012

I have a Catalyst 3750 switch configured in a network. I would like an additional 3750 switch as a "hot" standby.

A 2nd 3750 switch was purchased, and the same configuration was entered in to the new switch, so I have 2 switches with the exact same configuration.

When I move the connections to the new switch, I have a few VLANs that do not come up. One VLAN does come up and work normally.

The VLANs in question show down, protocol down, and a show ip route reveals routes to the networks on these VLANs are not there

When I put everything back on the original switch, everything works normally.

Why would the new switch not work with the exact same configuration?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
viswamin Tue, 01/31/2012 - 09:02

For the Vlan's to come up , you have to have atleast one port on that vlan which is in up state or atleast this vlan should be in the allowed list in the trunk link between the switches.

can you pls share the configs ?

-Vijay

Dholland64 Tue, 01/31/2012 - 09:12

Here is the config. In this case, when  I move over the connections, VLAN2 comes up and is operational, but 3-10 do not come up. I believe VLAN12 came up as well

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname 3750b

!

no logging console

enable secret 5 XXX

!

no aaa new-model

clock timezone MST -7

switch 1 provision ws-c3750g-24ts-1u

!

track 100 interface GigabitEthernet1/0/1 ip routing

ip subnet-zero

ip routing

no ip domain-lookup

!

          !

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

interface GigabitEthernet1/0/1

description WAN uplink to SonicWall

no switchport

ip address 172.23.5.2 255.255.255.0

!

interface GigabitEthernet1/0/2

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-12,241

switchport mode trunk

!

interface GigabitEthernet1/0/3

description uplink to 7206

switchport access vlan 3

switchport mode access

!

interface GigabitEthernet1/0/4

description uplink to 7206

switchport access vlan 3

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/5

description uplink to eCloser 1841 router

switchport access vlan 241

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/6

!

interface GigabitEthernet1/0/7

!

interface GigabitEthernet1/0/8

!

interface GigabitEthernet1/0/9

!

interface GigabitEthernet1/0/10

!

interface GigabitEthernet1/0/11

switchport access vlan 12

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/12

switchport access vlan 2

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/13

!

interface GigabitEthernet1/0/14

!

interface GigabitEthernet1/0/15

!

interface GigabitEthernet1/0/16

!

interface GigabitEthernet1/0/17

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-12

switchport mode trunk

          !

interface GigabitEthernet1/0/18

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-12

switchport mode trunk

!

interface GigabitEthernet1/0/19

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-12

switchport mode trunk

!

interface GigabitEthernet1/0/20

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-12

switchport mode trunk

!

interface GigabitEthernet1/0/21

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-12

switchport mode trunk

!

interface GigabitEthernet1/0/22

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-12

switchport mode trunk

!

interface GigabitEthernet1/0/23

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-12

switchport mode trunk

!

interface GigabitEthernet1/0/24

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2-12

switchport mode trunk

!

interface GigabitEthernet1/0/25

!

interface GigabitEthernet1/0/26

!

interface GigabitEthernet1/0/27

!

interface GigabitEthernet1/0/28

!

interface Vlan1

no ip address

!

interface Vlan2

ip address 10.0.1.251 255.255.255.0

ip helper-address 10.0.1.4

no ip redirects

standby 2 ip 10.0.1.5

standby 2 track 100 decrement 20

!

interface Vlan3

ip address 172.22.3.251 255.255.255.0

no ip redirects

standby 3 ip 172.22.3.1

standby 3 track 100 decrement 20

!

interface Vlan4

ip address 172.22.4.251 255.255.255.0

ip helper-address 10.0.1.4

no ip redirects

standby 4 ip 172.22.4.1

standby 4 track 100 decrement 20

!

interface Vlan5

ip address 172.22.5.251 255.255.255.0

ip helper-address 10.0.1.4

no ip redirects

standby 5 ip 172.22.5.1

standby 5 track 100 decrement 20

!

interface Vlan6

ip address 172.22.6.251 255.255.255.0

ip helper-address 10.0.1.4

no ip redirects

standby 6 ip 172.22.6.1

standby 6 track 100 decrement 20

!

interface Vlan7

ip address 172.22.7.251 255.255.255.0

ip helper-address 10.0.1.4

no ip redirects

standby 7 ip 172.22.7.1

standby 7 track 100 decrement 20

!

interface Vlan8

ip address 172.22.8.251 255.255.255.0

ip helper-address 10.0.1.4

no ip redirects

standby 8 ip 172.22.8.1

standby 8 track 100 decrement 20

!

interface Vlan9

ip address 172.22.9.251 255.255.255.0

ip helper-address 10.0.1.4

no ip redirects

standby 9 ip 172.22.9.1

standby 9 track 100 decrement 20

!

interface Vlan10

ip address 172.22.10.251 255.255.255.0

ip helper-address 10.0.1.4

no ip redirects

standby 10 ip 172.22.10.1

standby 10 track 100 decrement 20

!

interface Vlan11

ip address 172.22.11.251 255.255.255.0

ip helper-address 10.0.1.4

no ip redirects

standby 11 ip 172.22.11.1

standby 11 track 100 decrement 20

!

interface Vlan12

ip address 172.22.12.251 255.255.255.0

no ip redirects

standby 12 ip 172.22.12.1

standby 12 track 100 decrement 20

!

interface Vlan241

ip address 172.24.1.6 255.255.255.248

no ip redirects

standby 241 ip 172.24.1.1

standby 241 track 100 decrement 20

!

router eigrp 1

redistribute static

network 10.0.0.0

network 172.22.0.0

network 172.23.0.0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

no ip forward-protocol udp tftp

no ip forward-protocol udp nameserver

no ip forward-protocol udp domain

no ip forward-protocol udp time

no ip forward-protocol udp netbios-ns

no ip forward-protocol udp netbios-dgm

no ip forward-protocol udp tacacs

ip forward-protocol udp bootpc

ip forward-protocol udp bootps

ip route 0.0.0.0 0.0.0.0 172.23.5.1

ip route 10.3.10.0 255.255.255.0 172.24.1.2

ip route 10.201.32.0 255.255.252.0 172.24.1.25

ip route 10.201.32.0 255.255.252.0 172.24.1.2 200

ip route 10.201.37.0 255.255.255.0 172.24.1.2

ip route 10.201.38.31 255.255.255.255 172.24.1.2

ip route 10.201.64.0 255.255.255.0 172.24.1.2 200

ip route 10.201.128.0 255.255.255.0 172.24.1.2 200

ip route 10.201.176.0 255.255.255.0 172.24.1.2

ip route 10.201.248.0 255.255.255.0 172.24.1.2

no ip http server

!

!

access-list 199 permit ip 0.0.0.0 255.255.255.0 host 10.0.1.7

access-list 199 deny   ip any host 10.0.1.7

access-list 199 permit ip any any

snmp-server community gMv35t=Ws%iVLc9H RO

snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart

snmp-server enable traps stpx root-inconsistency loop-inconsistency

snmp-server host 172.22.8.101 version 2c gMv35t=Ws%iVLc9H

!

control-plane

!

!

line con 0

line vty 0 4

exec-timeout 60 0

password t_sfc0resw

login

line vty 5 15

password xxx

login

Leo Laohoo Tue, 01/31/2012 - 13:17

I have a Catalyst 3750 switch configured in a network. I would like an additional 3750 switch as a "hot" standby.

A 2nd 3750 switch was purchased, and the same configuration was entered in to the new switch, so I have 2 switches with the exact same configuration.

Why don't you just Stack them together?

Dholland64 Thu, 02/02/2012 - 08:16

The issue is resolved.

When the configuration was copied from the old switch, the virtual VLAN interfaces were created, however not all of the VLANs themselves were created. Creating the missing VLANs solved the problem

bikespace Thu, 02/02/2012 - 15:03

You need to create the vlan database (not shown in the config).

If you do a show vlan you will see which ones are active.

just type vlan 2 name blah blah blah for each vlan.

Edit: Ah, I see you already got there :-)

Message was edited

integreon Thu, 02/02/2012 - 15:49

Glad you fixed it:) good work

Sent from Cisco Technical Support iPad App

Actions

Login or Register to take actions

This Discussion

Posted January 31, 2012 at 8:32 AM
Stats:
Replies:6 Avg. Rating:
Views:604 Votes:0
Shares:0
Categories: Switches
+

Related Content

Discussions Leaderboard

Rank Username Points
1 15,007
2 8,150
3 7,725
4 7,083
5 6,742
Rank Username Points
165
82
70
69
55