×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

UCCE. Mobile Agent

Unanswered Question
Feb 2nd, 2012
User Badges:

Hi all,

I have UCCE 8 with CVP.


I have configured all necesary for mobile agent (I guess). I can loggin in nailed mode and call by call mode without problems.


When ICM selects a MA in Ready state, the call is not transfered to MA. In the status bar of CTIOS.Agent Desktop (or CAD) the Agent Status field blink between Ready and Reserved state.


If from IPPhone, I dial directly the DN of LCP where the MA is logged, the call works fine( in nailed mode the call is transfered directly ok and Call by Call the call to real agent phone is dialed).


Have you any idea?


Thank you so much.

Regards,

--

Alberto

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Kris Lambrechts Thu, 02/02/2012 - 10:14
User Badges:
  • Cisco Employee,

At a guess, the source of your call (most likely a SIP/H.323 Trunk originating from your incoming gateway or, iif you have it, CVP) has a Calling Search Space that does not include the Paritition that your LCP port is in, whereas your test phone does have that Partition. Have a look through your dialplan and ensure that all necessary components can call your agent extensions / LCP ports.


Cheers,


Kris

Alberto Sanz Fri, 02/03/2012 - 03:45
User Badges:

Hi Kris,

Thank you for the answer.


I use the same IPPhone for call to DN of LCP and service number (Dialed Number/Script Selector).

I have checked the CSS and I think that are ok.



Regards,

--

Alberto

Kris Lambrechts Fri, 02/03/2012 - 04:08
User Badges:
  • Cisco Employee,

Hi Alberto,


Ok so when it doesn't work, exactly where does your call go : is there an IVR involved ? Please show a screenshot of your routing script(s) in Monitoring mode after you made a test call so we can provide some further suggestions on where to check (although I'm still pretty convinced the most likely cause is a CSS issue somewhere).


Cheers,


Kris

vinodkewate Fri, 02/03/2012 - 05:58
User Badges:

ICM has reserved agent for calls so IPCC part of this config looks fine.


But there is something wrong with finding destination, i.e. route is missing.


Check if you have route pattern in CCM for Mobile Number.


If it is there, verify CSS and Partition are configured correctly for LCP, RCP port and have access to route pattern.

Alberto Sanz Sat, 02/04/2012 - 12:13
User Badges:

Hi,

I thought a issue with CSS/partitions too but did the next test:


  I have the next scenario:

      * I have LCP (1000) and RCP (2000), with the same configuration. I use CSS in line and device. The line's CSS has the partitions of the route patterns and device's CSS has internals partitions.

      * I have a IP Phone (3000)

      * The Mobile Agent is logged in LCP (call by call mode or nailed mode).


For call by call mode:  If the IPPhone(3000) dials the LCP(1000), the system dials the real agent phone and the call is established without problems.

For nailed mode: When the agent is logged, the system dials the real agent phone. When the IPPhone (3000) dials the LCP (1000) and the agent receive the call, the agent answer and the call is established with problems.


So, I guess that there are not problem with CSS/partition of LCP/RCP.


I don't know that other thing can be.

It's appreciate your help.

--

Alberto

Alberto Sanz Mon, 02/06/2012 - 04:07
User Badges:

Hi all,

First, thank you for your answer.


I found the issue. I forgot add a route in Local Statir Routes of CVPs for LCP/RCP.


Regards,

--

Alberto

Actions

This Discussion

Related Content