×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

OSFP not functioning

Answered Question
Feb 5th, 2012
User Badges:

Hi,


I have configured the OSPF on my branch office to head office, but It's work on one branch and not working on another branch. There is no any difference in configuration except the IP address in the working and non working branches.


The ospf functioning router shows all the data when the following command given

show ip ospf database

show ip ospf neigh

show ip route ospf


The ospf not functioning router doesn't show anything when show ip route ospf issued, but it shows the data of ospf database and ospf nieghbour. What may be the problem. Please help


Regards,



Mero

Correct Answer by Vivek Ganapathi about 5 years 6 months ago

Please provide the configuration + topology setup. Without this there is no way to say what problem you may be having.


Thanks

Vivek

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Reza Sharifi Sun, 02/05/2012 - 18:58
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

Hi,


Please post the config from both routers.

sreenath1987 Sun, 02/05/2012 - 20:18
User Badges:

Hi Mero,


Please provide the output of the commands Executed by you ie:


show ip ospf database

show ip ospf neigh

show ip route ospf


Please ensure that there is no MTU Mismatch between the Routers.


You may also want to check if OSPF is configured as Point To Multi point if you are working in a NBMA type of network.


Regards

Sreenath

Vivek Ganapathi Sun, 02/05/2012 - 22:04
User Badges:
  • Silver, 250 points or more

Make sure you have a right network type configured on your branch router. There are many other reasons why you could have seen routes in database but not in routing table. Please provide the outputs as requested by Reza.


Thanks

Vivek

Mero Cisco Sun, 02/05/2012 - 22:36
User Badges:

Hi,


In the morning I tried for 2 hours, it doesn't work. But now it's working, no any changes have been done. What may be the problem ?


Regards,



Mero

Correct Answer
Vivek Ganapathi Sun, 02/05/2012 - 22:39
User Badges:
  • Silver, 250 points or more

Please provide the configuration + topology setup. Without this there is no way to say what problem you may be having.


Thanks

Vivek

Mero Cisco Mon, 02/06/2012 - 08:48
User Badges:

Dear Vivek,


I have a mesh topology network. Please go through the following informations.

ne

ROUTER A#sh ip int brief

Interface                  IP-Address      OK? Method Status                Protocol

FastEthernet0/0            10.10.245.26   YES NVRAM  up                    up

FastEthernet0/1            10.10.26.1     YES NVRAM  up                    up

Loopback0                  10.10.25.26   YES NVRAM  up                    up



Router A#sh run

interface Loopback0

ip address 10.10.25.26 255.255.255.255

!

interface FastEthernet0/0

description ***** CONNECTED TO WAN 1 *****

ip address 10.10.245.26 255.255.255.0

ip ospf message-digest-key 1 md5 7 XXXXXXXX

duplex auto

speed auto

!

interface FastEthernet0/1

description ***** CONNECTED TO WAN 2 + LAN *****

ip address 10.10.246.26 255.255.255.0 secondary (WAN 2 IP ADDRESS)

ip address 10.10.26.1 255.255.255.0 (LAN IP ADDRESS)

ip ospf message-digest-key 1 md5 XXXXXXXXX

duplex auto

speed auto



router ospf 1

log-adjacency-changes

area 1 authentication message-digest

network 10.10.26.1 0.0.0.0 area 1

network 10.10.245.26 0.0.0.0 area 0

network 10.10.246.26 0.0.0.0 area 1

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.246.1 230

ip route 0.0.0.0 0.0.0.0 10.10.245.1 240

!



Router A#show ip ospf data



            OSPF Router with ID (10.10.25.26) (Process ID 1)



                Router Link States (Area 0)



Link ID         ADV Router      Age         Seq#       Checksum Link count

10.10.25.24   10.10.25.24   592         0x80000045 0x00941B 1

10.10.25.26   10.10.25.26   583         0x80000010 0x00588F 1



                Net Link States (Area 0)



Link ID         ADV Router      Age         Seq#       Checksum

10.10.245.24   10.10.25.24   592         0x80000003 0x00E813



                Summary Net Link States (Area 0)



Link ID         ADV Router      Age         Seq#       Checksum

10.10.24.0     10.10.25.24   1870        0x8000003A 0x0092CB

10.10.25.0     10.10.25.24   345         0x8000000F 0x006ADC

10.10.26.0     10.10.25.26   583         0x80000007 0x00D6B6

10.10.27.0     10.10.25.24   1870        0x8000003C 0x00F91E

10.10.28.0     10.10.25.24   1870        0x8000003C 0x00EE28

10.10.32.0     10.10.25.24   345         0x8000000D 0x002121

10.10.246.0    10.10.25.24   5           0x80001BF5 0x003672

10.10.246.0    10.10.25.26   583         0x80000007 0x005957

10.10.248.0    10.10.25.24   1874        0x8000003C 0x00EBBD

10.10.25.24   10.10.25.24   1874        0x8000003A 0x00E181

10.10.25.25   10.10.25.24   349         0x8000000F 0x00BA91

10.10.25.26   10.10.25.26   587         0x80000009 0x00246C

10.10.25.27   10.10.25.24   1874        0x8000003C 0x004CD0

10.10.25.28   10.10.25.24   1874        0x8000003C 0x0042D9

10.10.25.29   10.10.25.24   1874        0x8000003C 0x0038E2

10.10.25.32   10.10.25.24   349         0x8000000D 0x0078CE

10.10.252.76   10.10.25.24   1874        0x8000003A 0x0028C8

10.10.252.220  10.10.25.24   9           0x80000001 0x0092F6



                Router Link States (Area 1)



Link ID         ADV Router      Age         Seq#       Checksum Link count

10.10.25.26   10.10.25.26   587         0x80000003 0x00ED1F 3



                Summary Net Link States (Area 1)



Link ID         ADV Router      Age         Seq#       Checksum

10.10.24.0     10.10.25.26   587         0x80000003 0x00FE93

10.10.25.0     10.10.25.26   587         0x80000003 0x0080CF

10.10.27.0     10.10.25.26   587         0x80000003 0x006AE3

10.10.28.0     10.10.25.26   587         0x80000003 0x00er 5FED

10.10.32.0     10.10.25.26   587         0x80000003 0x003316

10.10.245.0    10.10.25.26   587         0x80000005 0x00684B

10.10.25.24   10.10.25.26   587         0x80000003 0x004E49

10.10.25.25   10.10.25.26   587         0x80000003 0x00D084

10.10.25.27   10.10.25.26   587         0x80000003 0x00BC96

10.10.25.28   10.10.25.26   587         0x80000003 0x00B29F

10.10.25.29   10.10.25.26   587         0x80000003 0x00A8A8

10.10.25.32   10.10.25.26   587         0x80000003 0x008AC3

10.10.252.76   10.10.25.26   587         0x80000003 0x009490

10.10.252.220  10.10.25.26   9           0x80000001 0x0090F5



                Type-5 AS External Link States



Link ID         ADV Router      Age         Seq#       Checksum Tag

0.0.0.0         10.10.25.251  642         0x800005A3 0x00246C 1

0.0.0.0         10.10.25.253  287         0x8000093B 0x000ACA 1



Router A# show ip ospf neighbor



Neighbor ID     Pri   State           Dead Time   Address         Interface

10.10.25.24    10   FULL/DR         00:00:37    10.10.245.24   FastEthernet0/0


The show ip ospf router does not show anything. The same kind of configuration works in another router, but over here it is not working. What may be the problem. There are lots of neighbor over this network, but can't see other network in show neighbour command, why ?


What are the commands for troubleshooting ospf ?


Regards,



Mero

Vivek Ganapathi Mon, 02/06/2012 - 20:03
User Badges:
  • Silver, 250 points or more

frankly speaking, with the above information i haven't been able to understand your setup. Is it possible for you to provide me a topology / diagram? Diagrams will help us to solve your problem much easily.


The config which you provide is it of your head office or of your branch?


Thanks

Vivek

Actions

This Discussion