Unable to upload prompt in Unity Connection 7.1

Unanswered Question
Feb 6th, 2012

Hello,

I am unable upload prompt in Cisco Unity Connection version: 7.1.5ES18.31900-18.  When I upload the file I am able to play it from Connection through the java plugin, but as soon as I save it, it reverts back to a blank file.  No error message, it just does not save.

I have rebooted the server, I have tried creating a new call handler and uploading wav file, but the same thing happens.  Once I click save it discards the uploaded file.

Please let me know if any has encountered this issue and how it was resolved.

Thanks,

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Chris Deren Mon, 02/06/2012 - 17:10

are you sure the correct greeting is enabled?

Have you tried different browsers?

Sent from Cisco Technical Support iPhone App

Turion307 Mon, 02/06/2012 - 18:37

Thanks for the reply, we tried Firefox and explorer, on two different pc.

Chris Deren Mon, 02/06/2012 - 18:41

If you are sure the Greeting is Active, perhaps you are running into this:

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCto92753

CSCto92753          Bug Details
Unable to upload wav files and save as greeting or send as message
Symptom:
Unable to upload an existing wav file, or create a new recording using the PC microphone and save as greeting, voice name, or send as message. In the case of trying to send as a message, the user receives a "Failed to Send Message" error.

You might see Failed to Record Name if attempting to overwrite a Call Handler with a file.

You might also see Unable to save recording due to SSL certificate error.

Conditions:
Cisco Unity Connection versions 7.1(5)ES45, 8.0(3)ES27, 8.5(1)ES37

When using either the Cisco Unity Connection Administration (CUCA) or the Cisco Unity Connection Personal Communications Assistant (PCA) web applications to upload an existing wav file, or create a new recording using the PC microphone and save as a voice name, greeting, or send as a message.

In the client side Java Console logs, you see the following exception:
Exception in thread "Timeout guard" java.security.AccessControlException: access denied (java.net.SocketPermission 10.93.231.234:8443 connect,resolve)


Workaround:
In your client side JRE security profile file....commonly named:  java.policy...add the below entry.  Will need to use the ipaddress of the Connection server (for a cluster, put an entry for each of publisher and subscriber).

permission java.net.SocketPermission "10.93.237.101:8443", "connect,resolve";

If get a permission error when trying to modify java.policy, then you may need to set the permissions of the file to not inhearent permissions from it's parent and not be read-only.  (aka by default the entire JRE folder is read-only but you need to modify a file within it).

A good article on the Sun website with more detail on the workaround:  http://java.sun.com/developer/onlineTraining/Programming/JDCBook/appA.html

Chris

Turion307 Wed, 02/15/2012 - 12:31

Hello Chis,

I noticed we were not running the minimum Java version.  After updating I was able to upload the wav file.

Thanks for your help.

gapande Fri, 02/17/2012 - 23:41

Ayaz,

Good to see the issue resolved but please note queries about CUC should have been posted in the IP Telephony section.

Cheers !!

GP.

Actions

Login or Register to take actions

This Discussion

Posted February 6, 2012 at 3:32 PM
Stats:
Replies:5 Avg. Rating:
Views:2360 Votes:0
Shares:0

Related Content

Discussions Leaderboard