×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Remote monitoring not work after divided into data vlan and voice vlan?

Answered Question
Feb 7th, 2012
User Badges:

Hi all,


I am currently using CM8.5 and UCCX8.0, and testing the remote monitoring feature

Originally, all CAD, CSD, IP phone, CM and UCCX are in the same VLan, and the remote monitoring works great~


However, after I divided the data VLan and voice VLan in the switch

Seems the remote monitoring feature not working now ...


##############################

Voice VLan 3001 - 10.10.1.0

Data VLan 3002 - 10.10.2.0


CM - 10.10.1.10

UCCX - 10.10.1.40


IP Phone A 10.10.1.130

CAD Agent A - 10.10.2.128


* IP Phone PC port connect to CAD Agent A's Computer


IP Phone B 10.10.1.131

IP Phone C 10.10.1.132


- The Agent PC is able to ping all the device in 10.10.1.0 and 10.10.2.0

- UCCX is able to ping the Agent PC and the IP Phone A


##################################

Here are the setting of the switch


#########################

Switch setting

#########################


vlan 3001-3002

!

interface GigabitEthernet1/0/13

description IP PHONE A AND PC CLIENT A

switchport access vlan 3002

switchport voice vlan 3001

spanning-tree portfast

!

interface GigabitEthernet1/0/14

description IP PHONE B AND PC CLIENT B

switchport access vlan 3002

switchport voice vlan 3001

spanning-tree portfast

!

interface GigabitEthernet1/0/15

description CONNECT CM AND UCCX (VM)

switchport access vlan 3001

spanning-tree portfast

!

interface GigabitEthernet1/0/16

description IP PHONE C AND PC CLIENT C

switchport access vlan 3002

switchport voice vlan 3001

spanning-tree portfast

!

interface GigabitEthernet1/0/17

description IP PHONE D AND PC CLIENT D

switchport access vlan 3002

switchport voice vlan 3001

spanning-tree portfast

!

interface GigabitEthernet1/0/18

description TRUNK TO ROUTER FA0/0

switchport trunk encapsulation dot1q

switchport mode trunk

!

!

interface Vlan3001

ip address 10.10.1.111 255.255.255.0

no ip route-cache

!

interface Vlan3002

ip address 10.10.2.111 255.255.255.0

no ip route-cache


##########################

The router setting

##########################

!

interface FastEthernet0/0.3001

encapsulation dot1Q 3001

ip address 10.10.1.29 255.255.255.0

!

interface FastEthernet0/0.3002

encapsulation dot1Q 3002

ip address 10.10.2.29 255.255.255.0

!



Am I doing any mistake on the setting ??

Thanks
Sam

Correct Answer by Jonathan Schulenberg about 5 years 6 months ago

I see no reference to a SPAN setup in your switch configuration snippet. Are you using SPAN-based or CAD-based recording? If you're using CAD-based then the workstation NICs need to support 802.1q tagged Ethernet frames. The phone simply forwards a copy of the encapsulated voice VLAN frame down the PC Port and does not strip the 802.1q header. Many PC NICs discard tagged packets by default. You may need to Google how to get your specific NIC to accept tagged frames and pass them to the NDIS stack.


http://www.cisco.com/en/US/prod/voicesw/custcosw/ps5693/ps14/prod_system_requirements0900aecd800e3149.pdf


Please rate helpful replies.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
samhopealpha Tue, 02/07/2012 - 01:02
User Badges:

hi,


I had followed the steps and successfully implemented the remote monitoring feature in the same VLan,


However, after I separated the VLan into Voice and Data... seems the remote mon feature doesn't work any more ...


Sam

anchoudh Tue, 02/07/2012 - 01:41
User Badges:
  • Red, 2250 points or more

The following phone settings must be enabled in Unified CM for desktop packet

capture to work:


■PC Port. If this is not enabled, the second network port on the back of the phone will simply not work as a network connection for the user's PC.

■PC Voice VLAN Access. Voice and data traffic can be segregated into separate VLANs in order to best use the networking resources. If the user's PC and phone are daisy-chained, and the voice and data are separated into different VLANS, the c0omputer will be a device in the data VLAN and the phone will be a device in the voice VLAN. If this option is not enabled, no voice traffic will be sent out the second network port to the daisy-chained PC.

■Span to PC Port. If this is not enabled, the phone will not forward any network traffic to the daisy-chained PC.

NOTE: Not all versions of Unified CM have all three options. Enable those that do appear on the phone device configuration.


Please use the below link for more information,


http://www.cisco.com/en/US/docs/voice_ip_comm/cust_contact/contact_center/cad_enterprise/non_release_docs/voip-mon-troubleshooting.pdf


Hope it helps.


Thanks,

Anand Choudhari


Please rate helpful posts..

samhopealpha Tue, 02/07/2012 - 01:46
User Badges:

Hi Anand,


all these phone settings had configured already, and work fine in the same VLan environment

But still not working in the separated Data and Voice VLan environment ...


Sam

Correct Answer
Jonathan Schulenberg Tue, 02/07/2012 - 03:33
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

I see no reference to a SPAN setup in your switch configuration snippet. Are you using SPAN-based or CAD-based recording? If you're using CAD-based then the workstation NICs need to support 802.1q tagged Ethernet frames. The phone simply forwards a copy of the encapsulated voice VLAN frame down the PC Port and does not strip the 802.1q header. Many PC NICs discard tagged packets by default. You may need to Google how to get your specific NIC to accept tagged frames and pass them to the NDIS stack.


http://www.cisco.com/en/US/prod/voicesw/custcosw/ps5693/ps14/prod_system_requirements0900aecd800e3149.pdf


Please rate helpful replies.

Actions

This Discussion