Shared line + Messages Button behavior help

Answered Question
Feb 7th, 2012

Recently added a shared line to several 7942's.  Now when the messages button is pressed, I get "Hello, cisco unity connection messaging..." instead of prompting for the password for my primary extension. I have to hit "*" then put my extension in etc. I'd like it to just default to the primary extension and prompt for the password for the mailbox.

I changed the service parameter of "Always use prime line for voice message" to true, but it did not change the way the button behaves. It also behaves the same whether or not there are messages on the prime line. Thanks for any help, this voice stuff really isn't my thing.

UCMBE 6.1.2.1000-13

I have this problem too.
0 votes
Correct Answer by Chris Deren about 2 years 2 months ago

Ok, instead of looking for the Route Pattern, look for Hunt Pilot under Call Routing --> Route/Hunt and find one used for voicemail integration and uncheck the same checkbox.

Chris

Correct Answer by Chris Deren about 2 years 2 months ago

If it is being established on line then the parameter is working as designed.  Is line 1 DN associated with voicemail box?  Does it have proper Voicemail Profile assigned?  Did it work before and after you added other shared lines to this phone it stopped working? 

Can you look at UCON port viewer to see if proper digits are being delivered and match voicemail extension?

Chris

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (4 ratings)
Chris Deren Tue, 02/07/2012 - 11:33

The service parameter should have done it, did you reset the phone after you have made the change?

Is the connection being established on line2, or any other line but line1?

Chris

acomiskey Tue, 02/07/2012 - 11:57

Yes I reset the phone.  The connection is being established on line1.

Correct Answer
Chris Deren Tue, 02/07/2012 - 12:03

If it is being established on line then the parameter is working as designed.  Is line 1 DN associated with voicemail box?  Does it have proper Voicemail Profile assigned?  Did it work before and after you added other shared lines to this phone it stopped working? 

Can you look at UCON port viewer to see if proper digits are being delivered and match voicemail extension?

Chris

acomiskey Tue, 02/07/2012 - 12:20

Yes, line1 DN is associated with my user in unity. Default profile is the only profile and it is applied. It worked until I added a shared line on button2. Will try to find out where and how to use the port viewer. Appreciate the help Chris.

acomiskey Tue, 02/07/2012 - 12:51

Thanks Chris, the port monitor pointed me to the right direction.

Here is the real issue.  I had also wanted to change a few peoples outbound CLID, so I had removed the existing CLID from Calling Party Transform Mask under the Route Group.  I then added individiaul outbound CLID's to External Phone Number Mask under each DN. This changes the label on the top right display of the phone to the new 10digit CLID number, not the internal 4 digit extension. Apparently this is also what unity was seeing which was why I wasn't going right to the mailbox for extension xxxx.

So I guess the question is how do I get the best of both worlds?  I want users 1-10 to have their outbound CLID be xxxxxxxxxx and users 11-20's outbound CLID to be yyyyyyyyyy. But I want their phones to display their local extensions which would fix the unity issue.

Chris Deren Tue, 02/07/2012 - 13:00

What is your integration type? It sounds like it is SIP, so what you need to do is remote "use external phone number mask" checkbox from the Route Pattern/List pointing to UCON SIP Trunk.

HTH,

Chris

acomiskey Tue, 02/07/2012 - 13:10

You'd have to dumb that down for me a bit...haha. This is UCMBE w/ 2821 SRST + PRI.

I played around in unity and gave my user an "alternate extension" with a value of my outbound CLID, this fixes the unity issue(my messages button goes straight to asking for password), but several users share the same outbound CLID so that method won't help me.

Chris Deren Tue, 02/07/2012 - 13:17

Sorry, first of all what protocol are you using to integrate CUCM with UCON?

You can check it on UCON side by going to Telephony Integration --> Port Group and noticing the "Integration Method"

Then if it is SIP, in CUCM locate the Route Pattern that points to UCON SIP trunk, if cannot locate this Pattern, you can reverse track it by finding Voicemail Profile --> Voicemail Pilot then looking for identical Route Pattern, for example if voicemail pilot is 9999, so is the route pattern. On the Route Pattern there is a checkbox "Use Calling Party's External Phone Number Mask", simply uncheck it.

HTH,

Chris

acomiskey Tue, 02/07/2012 - 13:22

SCCP (Skinny)

On the route list configuration I have Use calling party's external phone number mask set to default with no mask listed. This is supposed to

Default: This setting indicates that the route group does not govern the calling party external phone number and calling party transform masks. If a calling party external phone number mask or transform mask is chosen for the route pattern, calls that are routed through this route group use those masks.

This is what I want since I want to enter an external mask for each DN. I just don't want it to use that mask when calling unity.

Correct Answer
Chris Deren Tue, 02/07/2012 - 13:26

Ok, instead of looking for the Route Pattern, look for Hunt Pilot under Call Routing --> Route/Hunt and find one used for voicemail integration and uncheck the same checkbox.

Chris

Actions

Login or Register to take actions

This Discussion

Posted February 7, 2012 at 10:54 AM
Stats:
Replies:11 Avg. Rating:5
Views:513 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 21,026
2 15,047
3 10,314
4 7,999
5 4,856
Rank Username Points
135
90
72
66
55