Reset CAR Admin password

Unanswered Question
Feb 9th, 2012
User Badges:

Customer is using Call manager 7.x and have lost CAR admin password.


Now they can login with a user but cannot generate QoS Detail reports. To run those reports the user must have Admin privileges.

Problem is that we cannot assign admin privileges until CAR Admin logs in and assign privileges. The normal CAR admin and admin password is not working which means a CAR admin has been created. Customer network and credentials have gone through several transitions and throught different 3rd party managed service providers so they don't have any information about CAR Admin.


Is there any way to reset password for CAR Admin for Linux based Call manager? I know there is a way to do it in CCM 3.x, 4.x but how can we do in CCM 7.x?




Link:


http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/service/4_2_3/ccmsrva/sacar2.html#wp1092239


To grant administrative privileges to users, you must first log onto CAR using admin as the initial user name and password. Log onto CAR using this user  name and password to grant CAR administrator rights to user(s) for the  first time. This user ID and password will only work when there are no  CAR administrators configured in the system. Once one or more users have  been granted administrator rights, this initial logon (admin, admin) will be disabled. At this point, only CAR administrators (users who have been granted administrator rights initially using admin, admin, can grant CAR administrator rights to other users.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
asharsidd Mon, 02/13/2012 - 02:00
User Badges:

Thank you.


I have gone through the link and seems like users who have CAR admin privileges should be CAR Administrators? the user has following:


Here are the User Groups assigned to my user account

  • •-       CiscoAdminRepToolAdminGroupUsers
  • •-       Standard CAR Admin Users
  • •-       Standard CCM Admin Users
  • •-       Standard CCM End Users
  • •-       Standard CCM Super Users
  • •-       Standard RealtimeAndTraceCollection
  • •-       SuperUserGroup


Among the roles there are:

  • •-       Standard Admin Rep Tool Admin
  • •-       Standard RealTimeAndTraceCollection


BUT still this user cannot run QoS Detail repoorts. All he is getting is a blank report. I have searched through and found this document which says "

Only CAR administrators generate the QoS detail  report. The report details the QoS ratings that are attributed to  inbound and outbound calls on the Cisco Unified Communications Manager  network for the period that is specified"


http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/service/7_1_2/car/carsyqos.html


Now how to assign CAR Administrator rights? I found this:


http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/service/4_2_3/ccmsrva/sacar2.html#wp1092239



To grant administrative privileges to users, you must first log onto CAR using admin as the initial user name and password. Log onto CAR using this user  name and password to grant CAR administrator rights to user(s) for the  first time. This user ID and password will only work when there are no  CAR administrators configured in the system. Once one or more users have  been granted administrator rights, this initial logon (admin, admin) will be disabled. At this point, only CAR administrators (users who have been granted administrator rights initially using admin, admin, can grant CAR administrator rights to other users.



Procedure




Step 1 In the CAR window, choose System > System Parameters > Admin Rights.


The Grant/Revoke CAR Admin Rights window displays.



Now the problem is that even this user is a super user with all CAR Admin rights in Call manager user page (shown above), he cannot see "Admin rights" option in CAR/CDR tool. This means there must be another user assigned these rights as admin, admin is not working. Hence my question is there any way to reset password for CAR Admin so that we can assign Administrator rights from the CAR tool and then may be he can generate QoS detail reports.


Any help would be much appreciated.

Aaron Harrison Sun, 02/19/2012 - 10:22
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015

Hi


You have the admin rights set up already - this is controlled by the membership of the group 'CiscoAdminRepToolAdminGroupUsers'.


I think your problem is that the QoS report just doesn't have any data.


Check that:


- You have collection of CMRs as well as CDRs enabled in CUCM service parameters. The CMRs contain the QoS statistics.

- In System/Scheduler/CDR Load in the CAR website, ensure you do not have 'CDR Load Only' - this means 'do not load CMRs' in plain english.


Regards


Aaron Harrison

Principal Engineer at Logicalis UK


Please rate helpful posts...

asharsidd Thu, 03/08/2012 - 08:02
User Badges:

Thanks Aaron.


A TAC case has been raised and due to the complexity of their cluster it is taking a bit longer to get to the bottom of it.

Actions

This Discussion

Related Content