×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

DHCP Server will work on cisco 2950/2960 switch

Unanswered Question
Feb 12th, 2012
User Badges:

Hi friends,


With out using any server, will DHCP be configured in cisco 2950/2960 switch?

I man cisco it self should work as a dhcp server also.


If any body help me, it would be great full....


Thanks & Regards,

Srinivas. N

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Peter Paluch Sun, 02/12/2012 - 13:36
User Badges:
  • Cisco Employee,

Hi Srinivas,


Yes, even 2950 or 2960 Catalyst switches can be configured as DHCP servers. There is a limitation on 2950: this switch can have at most one SVI (Switched Virtual Interface) activated at any time. This means that a 2950 switch can provide DHCP Server services only for a single directly-attached VLAN. This limitation does not affect the 2960 which can have multiple SVIs activated.


Best regards,

Peter

Srinivas Narava Sun, 02/19/2012 - 07:29
User Badges:

Hi peter,


thanks for your support and i am not avare of it plz can u tell me config for 2960 switch?



Thanks & Regards,

Srinivas. N

Srinivas Narava Sun, 02/19/2012 - 14:40
User Badges:

Hi vijay,


Thank u very much for your support,

i configured as per your link... i am able to get the ip and dns also, but i am not able to get the gateway and no browsing.



Note:-    my up-link switch 2950 is running with 115.119.187.35, gateway is 115.119.187.33 and vlan is 109.

the same is connected to cisco 2960 (192.168.50.2, gateway is 192.168.50.1and vlan is 1. executally there is no devise 192.168.50.1i mean gate way)


My requirement is

The 2960 switch, wihich is connected to 2950 (main switch), the same switch (2960) should pass the dhcp, dns for the another sigment

plz find out my config on below for 2960 and guide me to get result.



User Access Verification

Password:
TEM_2960_8Ports>en
Password:
TEM_2960_8Ports#sh run
Building configuration...

Current configuration : 3134 bytes
!
version 12.2
service config
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname TEM_2960_8Ports
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
system mtu routing 1500
vtp mode transparent
ip subnet-zero
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.50.1 192.168.50.10
!
ip dhcp pool TEST
   network 192.168.50.0 255.255.255.0
   domain-name cisco.com
   dns-server 121.242.190.180 121.242.190.211
   lease 4
!
!
no ip domain-lookup
ip dhcp-server 192.168.50.2
!
!
crypto pki trustpoint TP-self-signed-2182349824
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2182349824
revocation-check none
rsakeypair TP-self-signed-2182349824
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 10,20,30,109
!
!
!
interface FastEthernet0/1
spanning-tree portfast
!
interface FastEthernet0/2
spanning-tree portfast
!
interface FastEthernet0/3
spanning-tree portfast
!
interface FastEthernet0/4
spanning-tree portfast
!
interface FastEthernet0/5
spanning-tree portfast
!
interface FastEthernet0/6
spanning-tree portfast
!
interface FastEthernet0/7
spanning-tree portfast
!
interface FastEthernet0/8
spanning-tree portfast
!
interface GigabitEthernet0/1
!
interface Vlan1
ip address 192.168.50.2 255.255.255.0
no ip route-cache
!
interface Vlan109
no ip address
no ip route-cache
!
ip default-gateway 192.168.50.1
ip http server
ip http secure-server
!
control-plane
!
!
line con 0
line vty 0 4
password cisco
login
line vty 5 15
login
!
end

TEM_2960_8Ports#


Srinivas.

ebarticel Sun, 02/19/2012 - 14:54
User Badges:
  • Bronze, 100 points or more

"default-router 192.168.50.1" should be configured under "ip dhcp pool TEST"

Srinivas Narava Mon, 02/20/2012 - 08:45
User Badges:

Hi Vijay,


As u sed i configured...


switch ip is 192.168.50.2 (vlan 1)

default-router 192.168.50.1
dhcp-server 192.168.50.2

dns-server insted of 192.168.50.2, i have give 121.242.190.180 121.242.190.211 (my running dns)

network 192.168.50.0 255.255.255.0


i am getting ip and all but no browsing.....

plz tell me how to get browsing also?


Srinivas. N

viswamin Mon, 02/20/2012 - 08:50
User Badges:
  • Cisco Employee,

Srinivas,


Are you performing NAT/PAT in your setup ( I dont see that on your running configuration although) . the IP address that you use in your pool are private addressing which cannot be routed into the network. so you got to translate that into a public IP which can be routed over the internet.


Details about Nat  can be found here


http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080094e77.shtml




-Vijay

Srinivas Narava Mon, 02/20/2012 - 10:48
User Badges:

Hi vijay,




I under stand, but cisco 2960 will not support nating, than how can i servey...... ?

is there any other way?




Best regards,

Srinivas.

cadet alain Mon, 02/20/2012 - 12:54
User Badges:
  • Purple, 4500 points or more

Hi,


You'll have to add a router or firewall to perform your NAT.


Regards.


Alain

ebarticel Mon, 02/20/2012 - 18:21
User Badges:
  • Bronze, 100 points or more

Check your PCs if they get a default gateway. In your DHCP pool configuration you are missing the default-router statement.


!

ip dhcp pool TEST

   network 192.168.50.0 255.255.255.0

   domain-name cisco.com

   dns-server 121.242.190.180 121.242.190.211

   lease 4

!

!

Actions

This Discussion