LMS 4.1 -- RICS0001-Error during InvCollection

Unanswered Question
Feb 14th, 2012
User Badges:

Hi all,


with LMS 4.1 we discovered an internal Inventory-collection RICS0001 error, logging

the following in IC_Server.log

[ Mon Feb 13 13:46:18 CET 2012 ],ERROR,[Thread-23],com.cisco.nm.rmeng.util.logger.RMELogger,791,com.cisco.nm.rmeng.inventory.ics.invchange.AddInvChange,effect,33,Unexpected error :com.sybase.jdbc2.jdbc.SybSQLException: SQL Anywhere Error -143: Column 'SlotNum' not found

       at com.sybase.jdbc2.tds.Tds.processEed(Tds.java:2884)

       at com.sybase.jdbc2.tds.Tds.nextResult(Tds.java:2206)

       at com.sybase.jdbc2.jdbc.ResultGetter.nextResult(ResultGetter.java:69)

       at com.sybase.jdbc2.jdbc.SybStatement.nextResult(SybStatement.java:220)

       at com.sybase.jdbc2.jdbc.SybStatement.nextResult(SybStatement.java:203)

       at com.sybase.jdbc2.jdbc.SybStatement.executeLoop(SybStatement.java:1766)

       at com.sybase.jdbc2.jdbc.SybStatement.execute(SybStatement.java:1758)

       at com.sybase.jdbc2.jdbc.SybPreparedStatement.execute(SybPreparedStatement.java:630)

       at com.cisco.nm.rmeng.inventory.ics.dbrep.DBRecord.insert(DBRecord.java:61)

        at com.cisco.nm.rmeng.inventory.ics.util.ICSDatabaseConnection.insert(ICSDatabaseConnection.java:99)

       at com.cisco.nm.rmeng.inventory.ics.invchange.AddInvChange.effect(AddInvChange.java:29)

       at com.cisco.nm.rmeng.inventory.ics.server.InvDataProcessor.processInvData(InvDataProcessor.java:380)

       at com.cisco.nm.rmeng.inventory.ics.core.CollectionController.run(CollectionController.java:635)

       at java.lang.Thread.run(Thread.java:662)

[ Mon Feb 13 13:46:18 CET 2012 ],INFO ,[Thread-23],com.cisco.nm.rmeng.inventory.ics.server.InvDataProcessor,494,Commiting the Connection at processInvData in InvDataProcessor [email protected]13

[ Mon Feb 13 13:46:18 CET 2012 ],ERROR,[Thread-23],com.cisco.nm.rmeng.inventory.ics.core.CollectionController,641, Exception occured in process method while processing: 10.194.32.186 SQL Anywhere Error -143: Column 'SlotNum' not found


[ Mon Feb 13 13:46:18 CET 2012 ],INFO ,[Thread-23],com.cisco.nm.rmeng.util.logger.RMELogger,745,com.cisco.nm.rmeng.inventory.dm.UDMDeviceAccessManager,updateCollectorStatusTOUDM,84,Parameters....

[ Mon Feb 13 13:46:18 CET 2012 ],INFO ,[Thread-23],com.cisco.nm.rmeng.util.logger.RMELogger,745,com.cisco.nm.rmeng.inventory.dm.UDMDeviceAccessManager,updateCollectorStatusTOUDM,85,Dev_id : 174 [ Mon Feb 13 13:46:18 CET 2012 ],INFO ,[Thread-23],com.cisco.nm.rmeng.util.logger.RMELogger,745,com.cisco.nm.rmeng.inventory.dm.UDMDeviceAccessManager,updateCollectorStatusTOUDM,86,apptype : 4 [ Mon Feb 13 13:46:18 CET 2012 ],INFO ,[Thread-23],com.cisco.nm.rmeng.util.logger.RMELogger,745,com.cisco.nm.rmeng.inventory.dm.UDMDeviceAccessManager,updateCollectorStatusTOUDM,87,status : 0 [ Mon Feb 13 13:46:18 CET 2012 ],INFO ,[Thread-23],com.cisco.nm.rmeng.util.logger.RMELogger,745,com.cisco.nm.rmeng.inventory.dm.UDMDeviceAccessManager,updateCollectorStatusTOUDM,88,updatedtime : 2012-02-13 13:46:18.108 [ Mon Feb 13 13:46:18 CET 2012 ],INFO ,[Thread-23],com.cisco.nm.rmeng.util.logger.RMELogger,745,com.cisco.nm.rmeng.inventory.dm.UDMDeviceAccessManager,updateCollectorStatusTOUDM,89,reason : RICS0001:Internal Error,unable to process the collected data from the device.

[ Mon Feb 13 13:46:18 CET 2012 ],INFO ,[Thread-23],com.cisco.nm.rmeng.util.logger.RMELogger,745,com.cisco.nm.rmeng.inventory.dm.UDMDeviceAccessManager,updateCollectorStatusTOUDM,120,status to update the last config time: 0


Problematic Device Types:


cisco ME-3400G-12CS-D,

Cisco IOS Software, ME340x Software (ME340x-METROIPACCESSK9-M), Version 12.2(54)SE, RELEASE SOFTWARE (fc1),

Image: me340x-metroipaccessk9-mz.122-54.SE.bin



Are there any known problems with ICServer and theses Devices?


Thanks a lot for your feedback.


Lothar

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lo.mueller Mon, 02/27/2012 - 22:27
User Badges:

Hi all,


got a solution from TAC.


Via https:///dbreader/dbreader.html the column SlotNum has to be manually added in RME-DB


SQL-Statement


ALTER TABLE PhysicalElement ADD SlotNum integer


Now it works.

Actions

This Discussion