Problem with ISDN on c2600.

Unanswered Question
Feb 14th, 2012

Hello,

I see a very strange problem with our ISDN slot on c2600 and can't somehow explain it.

If I connect a normal ISDN phone the line is working perfectly but if I connect  ISDN port on our router then ISDN status shows:

#sh isdn status

Global ISDN Switchtype = basic-net3

ISDN BRI1/0 interface

        dsl 0, interface ISDN Switchtype = basic-net3

    Layer 1 Status:

        DEACTIVATED

    Layer 2 Status:

        Layer 2 NOT Activated

    Layer 3 Status:

        0 Active Layer 3 Call(s)

    Active dsl 0 CCBs = 0

    The Free Channel Mask:  0x80000003

    Total Allocated ISDN CCBs = 0

and I can't start a connection, I've tried with help of "isdn test call", it shows an error like "no B chanel available"

If I make an incoming call to the telephone number of that ISDN line then the status of the line changes to "MULTIPLE_FRAME_ESTABLISHED" and I can use the line just normal for Dialer connections.

After some period of time (sometime is hours, sometimes is only a minutes) the Line status  goes again to "DEACTIVATED" and Dialer connection doen't work until I place an incoming call.

The ISDN  Hardware is:

BRI S/T - 2186 WAN daughter card

        Hardware revision 1.3           Board revision A0

        Serial number     19923810      Part number    800-01833-03

        FRU Part Number   WIC-1B-S/T=

BRI configuration:

interface BRI1/0

description isdn-backup

no ip address

encapsulation ppp

dialer pool-member 3

isdn switch-type basic-net3

isdn point-to-point-setup

isdn outgoing display-ie

no cdp enable

router version is 2600-advipservicesk9-mz.124-2.T.bin

I can see the same problem on two different locations, where we use this type of hardware.

Please give some advise. may there is a kind of "keepalive" for BRI interfaces?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Paolo Bevilacqua Fri, 02/17/2012 - 23:52

This is discussed very often.

It is normal that the line goes de-activated after a certain amount of time.

You must update IOS because what you're using is buggy, configure "isdn tei-negotiation preserve", and try again.

Konstantin Dunaev Mon, 02/20/2012 - 07:05

Hi Paolo,

thank you for the update.

We have some other ISDN line but they stays the hole time active, may be they went in "deactivate" status sometimes but at least comes online again without problem. But in these cases I can them "wake up"   only if I try to call the number on those ISDN linens.

Do you mean that a IOS update should solve our problem?

Konstantin Dunaev Thu, 02/23/2012 - 01:39

Hi Paolo,

I've updated the IOS to  c2600-entservicesk9-mz.124-15.T14.bin but the problem is exactly the same.

You said that is "normal" if the line goes de-activated after a certain amount of time, but how can the router re-activate the line again?

We used ealier the cisco 1800 with the same  ISDN connection without any problem over a year, and  the problem first arised after we replaced it to c2600.

Paolo Bevilacqua Sun, 02/26/2012 - 03:01

Please configure "isnd tei-negotiation preserve" if still problems, post "debug bri" when line is de-activate and you try an outgoing calls.

lgijssel Fri, 02/17/2012 - 23:55

Such strange behavior can be caused by improper grounding.

Please verify that the router is properly grounded to the same ground as the ISDN lines.

regards,

Leo

Konstantin Dunaev Thu, 02/23/2012 - 01:42

Hi Leo,

I don't really believe that grounding can cause such a strange behavior, but we can try. 

The question is how can I "connect" the cisco to the same  ground as ISDN line? I mean we get ISDN line from outside and I have no idea how and where it's grounded. Or is it enough just to graound our cisco to a normal house ground?

lgijssel Fri, 02/24/2012 - 09:25

Hi Konstantin,

There was a time when I also considered this unlikely but after I saw a troublesome installation working when it was connected to an improvised ground circuit I took a lesson out of it. Racks are normally grounded also but perhaps not in your case; you never know. Anyway, your ISDN router has the option to attach a special grounding clamp:

http://www.cisco.com/en/US/docs/routers/access/2600/hardware/installation/guide/2600ch3.html#wp1057120

Connect this to the ground circuit in your server room and check if it resolves your problem.

regards,

Leo

zoltanszasz Sun, 03/04/2012 - 11:55

Telcos power up the lines so it is their interest to break up connection if lines not in use.

Try dialer persistent on the dialer interface and tell us if it helps. It's just a guess, but maybe solves problem.

Konstantin Dunaev Mon, 03/05/2012 - 00:23

Hi  Zoltan,

with power saving would be all OK, but how can end-device use then the ISDN line if it were power-off? As I said I can't bring the line UP fron the Cisco side.

zoltanszasz Mon, 03/05/2012 - 05:39

So i read around more on this, very interesting situation and few people kinda have same issue.

1. Check switch type with provider

2. Some providers don't bring the line up without SPID's

3. If you make up an rj45 loopback plug(pin 1> pin5 and pin 2> pin  4)then plug this into you BRI INTERFACE it should bring your interface  up then do an isdn statusto see if layer 1 and 2 stay up.

Here is a preety good url for "troubleshooting LAYER 1 on isdn bri line"

http://www.cisco.com/warp/public/129/bri-layer1.html

for layer 2 pl. visit

http://www.cisco.com/warp/public/129/bri-layer2.html

ISDN line provisioning: http://www.cisco.com/en/US/docs/routers/access/800/801/software/configuration/guide/provisio.pdf

Konstantin Dunaev Mon, 03/12/2012 - 01:44

Hi,

thank you for the info, I've tried different things but without  result.

The funny thing is following, we have 2 sites, one of them (SiteA) is connected directly to Telco port, the second (SiteB) is connected to local PBX port.

With Telco port I've got the stable link only after  I've staticly  configured TE to "0", auto TE and all other values don't bring the inteface UP.

With PBX port is working strange as well - during the port in " MULTIPLE_FRAME_ESTABLISHED " I can place a  call, but only a single one, after the call terminates port goes to status "TEI_UNASSIGNED" and stays until I manulaly reset the BRI interface, after the reset the line goes back to normal "MULTIPLE_FRAME_ESTABLISHED " and stays there until port gets  "DEACTIVATED" status.

Paolo Bevilacqua Mon, 03/12/2012 - 08:09

You can have a problem with 2600 obsolete hardware. As you noted in you first message, a 1800 works fine with the same config.

jefffisher Thu, 03/15/2012 - 05:14

Here is an old config from when I did a lot of ISDN work. It is on a 2600 series router. Never had any issues. I used 800 series routers to connect back to the 2600.

!

! Last configuration change at 09:24:49 cst Tue Dec 4 2001

! NVRAM config last updated at 09:24:51 cst Tue Dec 4 2001

!

version 11.2

service timestamps debug uptime

service timestamps log datetime msec localtime show-timezone

no service password-encryption

no service udp-small-servers

no service tcp-small-servers

!

hostname sci-aus

!

!

ip subnet-zero

ip name-server 172.16.20.20

isdn switch-type basic-ni1

clock timezone cst -6

clock summer-time cdt recurring

!

interface Ethernet0

ip address 207.200.40.193 255.255.255.224

!

interface Ethernet1

ip address 172.16.20.2 255.255.255.128

!

interface Virtual-Template1

no ip address

no ip mroute-cache

!

interface Serial0

description To ONR

ip address 207.200.54.6 255.255.255.252

!

interface Serial1

no ip address

shutdown

!

interface BRI0

description To Manchaca Village Vet

no ip address

encapsulation ppp

no ip mroute-cache

bandwidth 64

isdn spid1 51291611180101 9161118

isdn spid2 51291611190101 6161119

dialer rotary-group 0

no fair-queue

compress stac

no cdp enable

!

interface BRI1

no ip address

shutdown

!

interface BRI2

no ip address

shutdown

!

interface BRI3

no ip address

shutdown

!

interface Dialer0

ip address 172.16.20.237 255.255.255.252

encapsulation ppp

no ip mroute-cache

dialer in-band

dialer idle-timeout 900

dialer hold-queue 10

dialer load-threshold 2 either

dialer-group 1

no fair-queue

compress stac

no cdp enable

ppp negotiation-timeout 300

ppp authentication chap

ppp chap hostname sci-vet

ppp chap password 7 010213054802565E

ppp multilink

!

router rip

version 2

redistribute connected

network 172.16.0.0

network 207.200.40.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 207.200.54.5

dialer-list 1 protocol ip permit

!

line con 0

line aux 0

line vty 0 4

login

!

end

Actions

Login or Register to take actions

This Discussion

Posted February 14, 2012 at 5:38 AM
Stats:
Replies:15 Avg. Rating:
Views:1085 Votes:0
Shares:0
Tags: bri, isdn
+

Related Content

Discussions Leaderboard