Network issue

Answered Question
Feb 14th, 2012

Hi guys,

My network structure in on image.

Network.jpg

There were no problems untill I've added another unmanaged swich Cisco SR2024. It's connected via 4 cables to managed switch Cisco 2960. There is config for these 4 ports:

interface Port-channel2

switchport mode trunk

!

interface GigabitEthernet0/41

description Netgear_SW_link1

switchport access vlan 10

switchport trunk native vlan 10

switchport mode trunk

mls qos trust cos

channel-group 2 mode auto

!

interface GigabitEthernet0/42

description Netgear_SW_link2

switchport mode trunk

mls qos trust cos

spanning-tree bpduguard enable

channel-group 2 mode auto

!

interface GigabitEthernet0/43

description Netgear_SW_link3

switchport mode trunk

mls qos trust cos

spanning-tree bpduguard enable

channel-group 2 mode auto

!

interface GigabitEthernet0/44

description Netgear_SW_link4

switchport mode trunk

mls qos trust cos

spanning-tree bpduguard enable

channel-group 2 mode auto

Also 2960 is DHCP!

So problems are:

- unable to get access to VMs VPN, AD (server connected to SR2024) from 192.168.10.7 (same VLAN)

- unable to get access to SMTP from Printer which connected to 2960

- VPN client unable to get IP from DHCP (errors 691,733,800)

What should I change to fix these issue? (Just a reminder, all these problems started with SR2024, but I have to use it - not enough ports on 2960)

Thanks

I have this problem too.
0 votes
Correct Answer by darren.g about 2 years 2 months ago

Nick Sinyakov wrote:

Thanks for clear answer. Also I have Netgear GS748TS which is smart switch and should be able to carry few VLANS via 1 port, but I didn't find the instruction how to setup "CISCO TRUNK through NETGEAR" and how use etherchannel between them.

This Netgear switch supports dot1q trunking, so you can make it work. it also supports 802.3ad, so you can probably use a port-channel to get more bandwidth between the switches - although instead of "mode auto", I'd suggest "mode active" because the Netgear only supports LACP, and this will force the Cisco to use LACP for the port-channel.

because the Netgear supports dot1q, you can also trunk - so carry VLAN 1 and VLAN 2 across the link, and assign ports in it to different VLAN's - but I have no idea how to set this up, as I've never used one of those.

Good luck.

Correct Answer by darren.g about 2 years 2 months ago

Nick Sinyakov wrote:

Hi guys,

My network structure in on image.

There were no problems untill I've added another unmanaged swich Cisco SR2024. It's connected via 4 cables to managed switch Cisco 2960. There is config for these 4 ports:

interface Port-channel2

switchport mode trunk

!

interface GigabitEthernet0/41

description Netgear_SW_link1

switchport access vlan 10

switchport trunk native vlan 10

switchport mode trunk

mls qos trust cos

channel-group 2 mode auto

!

interface GigabitEthernet0/42

description Netgear_SW_link2

switchport mode trunk

mls qos trust cos

spanning-tree bpduguard enable

channel-group 2 mode auto

!

interface GigabitEthernet0/43

description Netgear_SW_link3

switchport mode trunk

mls qos trust cos

spanning-tree bpduguard enable

channel-group 2 mode auto

!

interface GigabitEthernet0/44

description Netgear_SW_link4

switchport mode trunk

mls qos trust cos

spanning-tree bpduguard enable

channel-group 2 mode auto

Also 2960 is DHCP!

So problems are:

- unable to get access to VMs VPN, AD (server connected to SR2024) from 192.168.10.7 (same VLAN)

- unable to get access to SMTP from Printer which connected to 2960

- VPN client unable to get IP from DHCP (errors 691,733,800)

What should I change to fix these issue? (Just a reminder, all these problems started with SR2024, but I have to use it - not enough ports on 2960)

Thanks

The SR2024 supports neither etherchannel nor 802.1q trunking - so I'm not surprised it doesn't work!

As far as the SR2024 is concerned, all ports are in the same VLAN/Broadcast domain, and all are access ports - there's no tagging.

So your etherchannel won't work, and neither will trying to trunk multiple VLAN's to the SR2024.

If you *must* use it, then put ONE connecting port on the 2960 into access mode in ONE VLAN, and then all devices on the SR2024 will be in that VLAN. But there's no way you can have VLAN1/VLAN2 hanging off the SR2024. And you'll only have the bandwidth of one port linking the two devices together - trying to add another will result in the 2960 puttint ports into blocking mode.

Best solution - buy a better switch! Or modify your requirements to include only one VLAN

Cheers.

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (2 ratings)
Leo Laohoo Tue, 02/14/2012 - 14:28

SR2024, I believe, is an un-managed switch.  I don't know it this will support etherchannel.

kolyan007 Tue, 02/14/2012 - 14:33

Yes, you right, it's unmanaged switch. I meant channel-group is setup only on 2960 site for connection redundance. So I can't create etherchannel between managed and un-managed switches?

Leo Laohoo Tue, 02/14/2012 - 17:14
So I can't create etherchannel between managed and un-managed switches?

You can create an etherchannel on a managed switch (if this feature is supported) but an un-managed switch doesn't "understand" and just might create an STP loop.

Correct Answer
darren.g Tue, 02/14/2012 - 16:26

Nick Sinyakov wrote:

Hi guys,

My network structure in on image.

There were no problems untill I've added another unmanaged swich Cisco SR2024. It's connected via 4 cables to managed switch Cisco 2960. There is config for these 4 ports:

interface Port-channel2

switchport mode trunk

!

interface GigabitEthernet0/41

description Netgear_SW_link1

switchport access vlan 10

switchport trunk native vlan 10

switchport mode trunk

mls qos trust cos

channel-group 2 mode auto

!

interface GigabitEthernet0/42

description Netgear_SW_link2

switchport mode trunk

mls qos trust cos

spanning-tree bpduguard enable

channel-group 2 mode auto

!

interface GigabitEthernet0/43

description Netgear_SW_link3

switchport mode trunk

mls qos trust cos

spanning-tree bpduguard enable

channel-group 2 mode auto

!

interface GigabitEthernet0/44

description Netgear_SW_link4

switchport mode trunk

mls qos trust cos

spanning-tree bpduguard enable

channel-group 2 mode auto

Also 2960 is DHCP!

So problems are:

- unable to get access to VMs VPN, AD (server connected to SR2024) from 192.168.10.7 (same VLAN)

- unable to get access to SMTP from Printer which connected to 2960

- VPN client unable to get IP from DHCP (errors 691,733,800)

What should I change to fix these issue? (Just a reminder, all these problems started with SR2024, but I have to use it - not enough ports on 2960)

Thanks

The SR2024 supports neither etherchannel nor 802.1q trunking - so I'm not surprised it doesn't work!

As far as the SR2024 is concerned, all ports are in the same VLAN/Broadcast domain, and all are access ports - there's no tagging.

So your etherchannel won't work, and neither will trying to trunk multiple VLAN's to the SR2024.

If you *must* use it, then put ONE connecting port on the 2960 into access mode in ONE VLAN, and then all devices on the SR2024 will be in that VLAN. But there's no way you can have VLAN1/VLAN2 hanging off the SR2024. And you'll only have the bandwidth of one port linking the two devices together - trying to add another will result in the 2960 puttint ports into blocking mode.

Best solution - buy a better switch! Or modify your requirements to include only one VLAN

Cheers.

kolyan007 Tue, 02/14/2012 - 16:37

Thanks for clear answer. Also I have Netgear GS748TS which is smart switch and should be able to carry few VLANS via 1 port, but I didn't find the instruction how to setup "CISCO TRUNK through NETGEAR" and how use etherchannel between them.

Correct Answer
darren.g Tue, 02/14/2012 - 19:35

Nick Sinyakov wrote:

Thanks for clear answer. Also I have Netgear GS748TS which is smart switch and should be able to carry few VLANS via 1 port, but I didn't find the instruction how to setup "CISCO TRUNK through NETGEAR" and how use etherchannel between them.

This Netgear switch supports dot1q trunking, so you can make it work. it also supports 802.3ad, so you can probably use a port-channel to get more bandwidth between the switches - although instead of "mode auto", I'd suggest "mode active" because the Netgear only supports LACP, and this will force the Cisco to use LACP for the port-channel.

because the Netgear supports dot1q, you can also trunk - so carry VLAN 1 and VLAN 2 across the link, and assign ports in it to different VLAN's - but I have no idea how to set this up, as I've never used one of those.

Good luck.

kolyan007 Tue, 02/14/2012 - 19:44

Thanks for replies. I've raised this setup with Netgear support.

Actions

Login or Register to take actions

This Discussion

Posted February 14, 2012 at 2:05 PM
Stats:
Replies:8 Avg. Rating:5
Views:823 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard