ip device tracking

Unanswered Question
Feb 16th, 2012

Hello,

I have enabled "ip device tracking" on my switches. However, I have a switch that doesn't show any info!! It works on all other switches.

What exactly does this output means;

NY-EF0.1-01#  sh ip dev trac all
IP Device Tracking = Enabled
IP Device Tracking Probe Count = 3
IP Device Tracking Probe Interval = 30
---------------------------------------------------------------------
  IP Address     MAC Address   Vlan  Interface              STATE   
---------------------------------------------------------------------
172.17.20.166   5c26.0a4b.b179  320  GigabitEthernet2/0/47  INACTIVE
192.168.16.24   0021.703a.9316  666  GigabitEthernet1/0/19  ACTIVE

Total number interfaces enabled: 3
Enabled interfaces:
  Gi1/0/3, Gi1/0/19, Gi2/0/47

The "Enabled interfaces" - I thought IP device tracking was enabled for all interfaces once the command "ip device tracking" was entered globally? The config on all ports are the same, still I only get device info from a few, and according to the switch it's only enabled on 3 interfaces;

switchport access vlan 320

switchport mode access

authentication control-direction in

authentication event fail action authorize vlan 666

authentication event server dead action authorize vlan 320

authentication event no-response action authorize vlan 666

authentication event server alive action reinitialize

authentication port-control auto

snmp trap mac-notification change added

snmp trap mac-notification change removed

dot1x pae authenticator

dot1x timeout quiet-period 20

dot1x timeout tx-period 10

storm-control broadcast level 5.00

storm-control multicast level 30.00

no cdp enable

no cdp tlv server-location

no cdp tlv app

spanning-tree portfast

spanning-tree bpduguard enable

spanning-tree guard root

What do to people?

I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Daniel Hunter Tue, 09/10/2013 - 03:12

In case you are still interested in this I have just run into this problem myself and may have stumbled on to the answer (at least for my case). Having entered on 'ip device tracking' on a C3750 the output of the 'show ip device tracking all' reports:

Total number of interfaces enabled: 0

After a bit of messing around enabling tracking on individual ports I changed to another switch and again entered the 'ip device tracking' this time the show command reports:

Total number of interfaces enabled: 1

Enabled interfaces:

Fa1/0/21

Comparing the interface configs the only difference on this port is 'dot1x port-control auto', adding this to command to port 20 and the show command no reports:

Total number of interfaces enabled: 2

Enabled interfaces:

Fa1/0/20, Fa1/0/21

Now off to read how ip device tracking and dot1x are inter-dependant.

isaacalves27 Tue, 03/11/2014 - 00:11

Same issue here. I think that the issue could be the IOS running onm the device. Have to test further.

Actions

Login or Register to take actions

This Discussion

Posted February 16, 2012 at 12:04 AM
Stats:
Replies:3 Avg. Rating:
Views:6230 Votes:1
Shares:0
Tags: No tags.

Discussions Leaderboard