RIPv2 summarization

Answered Question
Feb 19th, 2012
User Badges:
  • Silver, 250 points or more

Hello


suppose we have the following diagram

Untitled.jpg

using RIPv2.

RIPv2 will auto-summaries by default. i thought it will make summary to 192.168.1.0/25 since this includes 192.168.1.0/26 and 192.168.1.64/26. however i discoverd that it summaries to 192.168.1.0/24 !!

any explanaition why it is doing so?

note that according to the example in ICND2 (volume1 , page 3-58) it should be 192.168.1.0/25.

the config file looks like this:


interface FastEthernet0/0

ip address 192.168.1.1 255.255.255.192

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.1.65 255.255.255.192

duplex auto

speed auto

!

interface Ethernet1/0

ip address 192.168.0.1 255.255.255.252

half-duplex

!

router rip

version 2

network 192.168.0.0

network 192.168.1.0

!

no ip http server

ip classless

Correct Answer by Peter Paluch about 5 years 6 months ago

Hello,


RIPv2 will auto-summaries by default. i thought it will make summary to  192.168.1.0/25 since this includes 192.168.1.0/26 and 192.168.1.64/26.  however i discoverd that it summaries to 192.168.1.0/24 !!


Yes, your observation is correct - and your confusion is shared by many people that have tried to look more closely at the auto-summarization process


This behavior is correct. Automatic summarization does not try to find the best fitting summary network. Instead, it always performs summarization to the classful network into which the subnets belong. As your subnetworks 192.168.1.0/26 and 192.168.1.64/26 are both allocated from the C-class classful network 192.168.1.0/24, this is what the RIPv2 will advertise.


The reason for this behavior lies in the backward compatibility with classful routing protocols. As you know, classful routing protocols did not include netmasks in their updates, and instead, they relied on deducing the correct netmask. If a router wanted to advertise a subnet of a particular classful network through an interface that was itself located in a different classful network, this subnet would be automatically summarized to its own classful network and advertised in this form. The receiving router would receive this update through its interface, discover that the network inside the update is from a different classful network than the receiving interface, and in turn assign a classful netmask to it. This was the original automatic summarization in classful routing protocols that could not be deactivated because it formed a key component of their operation. With classless routing protocols, automatic summarization is just a legacy to keep backward compatibility but as you see yourself, it is not really usable, save for special environments.


Feel welcome to ask further!


Best regards,

Peter

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Peter Paluch Sun, 02/19/2012 - 23:48
User Badges:
  • Cisco Employee,

Hello,


RIPv2 will auto-summaries by default. i thought it will make summary to  192.168.1.0/25 since this includes 192.168.1.0/26 and 192.168.1.64/26.  however i discoverd that it summaries to 192.168.1.0/24 !!


Yes, your observation is correct - and your confusion is shared by many people that have tried to look more closely at the auto-summarization process


This behavior is correct. Automatic summarization does not try to find the best fitting summary network. Instead, it always performs summarization to the classful network into which the subnets belong. As your subnetworks 192.168.1.0/26 and 192.168.1.64/26 are both allocated from the C-class classful network 192.168.1.0/24, this is what the RIPv2 will advertise.


The reason for this behavior lies in the backward compatibility with classful routing protocols. As you know, classful routing protocols did not include netmasks in their updates, and instead, they relied on deducing the correct netmask. If a router wanted to advertise a subnet of a particular classful network through an interface that was itself located in a different classful network, this subnet would be automatically summarized to its own classful network and advertised in this form. The receiving router would receive this update through its interface, discover that the network inside the update is from a different classful network than the receiving interface, and in turn assign a classful netmask to it. This was the original automatic summarization in classful routing protocols that could not be deactivated because it formed a key component of their operation. With classless routing protocols, automatic summarization is just a legacy to keep backward compatibility but as you see yourself, it is not really usable, save for special environments.


Feel welcome to ask further!


Best regards,

Peter

ohassairi Mon, 02/20/2012 - 02:30
User Badges:
  • Silver, 250 points or more

thanks Peter

so the example in ICND2 (volume1 , page 3-58) is incorrect

it said router A will summarize :

172.16.168.0/24

172.16.169.0/24

172.16.170.0/24

172.16.171.0/24

172.16.172.0/22


in


172.16.168.0/21.


according to you it will summarize to 172.16.0.0. isn't it

Peter Paluch Mon, 02/20/2012 - 03:01
User Badges:
  • Cisco Employee,

Hello,


It seems that the ICND2 book is wrong on this topic. If these 172.16.x.x subnets are to be advertised out an interface that is in a different network than 172.16.x.x, the automatic summarization will produce just the entire network 172.16.0.0/16, exactly as you pointed out.


If more precise summaries are to be advertised, they have to be configured manually. Automatic summarization is not going to help you here.


Best regards,

Peter

ohassairi Mon, 02/20/2012 - 21:10
User Badges:
  • Silver, 250 points or more

thanks peter for your help

Actions

This Discussion