×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

UCS C210 m2 Fan Speed issues

Answered Question
Feb 20th, 2012
User Badges:

one of my servers has the fans going very fast at 6K to 8K.

Screen Shot 2012-02-20 at 11.17.26 PM.png


my second server of similar config is at a normal fan speed around 2K.



i have had this happen in the past and i think i updated the firmware which seemed to fix. but it seems to have reoccurred.

i have restarted the server and the fans are still going fast.


both servers are running BIOS

C200.1.4.1.0 (Build Date: 07/13/2011)


CIMC

Screen Shot 2012-02-20 at 11.40.57 PM.png

======

update:

I have just also just now tested to compleatly shutting down the server and rebooting which seems to have helped.

except now only the PSU fans are going around 5K

the system fans seem to have stablised back to normal 2-3K range.

Screen Shot 2012-02-21 at 12.09.59 AM.png

my other UCS server PSU fans are running at 2 to 2.5K.


Tempreature is not an issue, they are both running approx same temps.

...and both are under minimal load


any ideas as to why the PSU fans are running high?

Correct Answer by mtimm about 5 years 5 months ago

Hi Robert,


I guess I should also point out that your two servers have two different versions of power supplies in them which explains the differences in steady state PSU fan speeds even after working around the bug I think one of the servers may have run into.  ucs-c200 has older PSUs that have two inline fans so the fans can run at a lower speeds to maintain the required temperature.  ucs-c210-m2 has newer PSUs that have only a single fan in them so they have to run the fans at higher speeds to maintain the required temperatures.



Mike

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
padramas Mon, 02/20/2012 - 07:48
User Badges:
  • Cisco Employee,

Hello Robert,

How long the problematic server has been in use ?


SSH into CIMC and please provide us the following output


scope chassis

show psu detail

show pci-adapter detail

exit

scope sensor

show fan

show temperature



Padma

robertkruk Tue, 02/21/2012 - 18:50
User Badges:

ucs-c210-m2# scope chassis

ucs-c210-m2 /chassis # show psu detail

Name PSU1:

    In. Power (Watts): 89

    Out. Power (Watts): 650

    Firmware : 00.01.04

    Status : Present

    Product ID : R2X0-PSU2-650W-SB

Name PSU2:

    In. Power (Watts): 107

    Out. Power (Watts): 650

    Firmware : 00.01.04

    Status : Present

    Product ID : R2X0-PSU2-650W-SB

ucs-c210-m2 /chassis # show pci-adapter detail

Name PCIe Adapter1:

    Slot: 5

    Vendor ID: 0x1000

    Device ID: 0x0079

    Product Name : LSI 9261-8i MegaRAID SAS HBA

ucs-c210-m2 /chassis # exit

ucs-c210-m2# scope sensor

ucs-c210-m2 /sensor # show fan

Name                 Sensor Status        Reading    Units      Min. Warning    Max. Warning    Min. Failure    Max. Failure   

-------------------- -------------------- ---------- ---------- --------------- --------------- --------------- ---------------

PSU1_FAN_1           Normal               5248       RPM        N/A             N/A             N/A             N/A            

PSU2_FAN_1           Normal               4992       RPM        N/A             N/A             N/A             N/A            

W793_FAN1_TACH1      Normal               2300       RPM        N/A             N/A             800             N/A            

W793_FAN1_TACH2      Normal               2700       RPM        N/A             N/A             800             N/A            

W793_FAN2_TACH1      Normal               2400       RPM        N/A             N/A             800             N/A            

W793_FAN2_TACH2      Normal               2800       RPM        N/A             N/A             800             N/A            

W793_FAN3_TACH1      Normal               2400       RPM        N/A             N/A             800             N/A            

W793_FAN3_TACH2      Normal               2500       RPM        N/A             N/A             800             N/A            

ucs-c210-m2 /sensor # show temperature

Name                      Sensor Status  Reading    Units      Min. Warning Max. Warning Min. Failure Max. Failure

------------------------- -------------- ---------- ---------- ------------ ------------ ------------ ------------

IOH_TEMP_SENS             Normal         39.0       C          N/A          80.0         N/A          85.0        

P2_TEMP_SENS              Normal         17.5       C          N/A          72.0         N/A          77.0        

P1_TEMP_SENS              Normal         16.0       C          N/A          72.0         N/A          77.0        

DDR3_P2_D1_TMP            Normal         25.0       C          N/A          68.0         N/A          70.0        

DDR3_P2_D2_TMP            Normal         25.0       C          N/A          68.0         N/A          70.0        

DDR3_P2_E1_TMP            Normal         23.0       C          N/A          68.0         N/A          70.0        

DDR3_P2_E2_TMP            Normal         23.0       C          N/A          68.0         N/A          70.0        

DDR3_P2_F1_TMP            Normal         23.0       C          N/A          68.0         N/A          70.0        

DDR3_P2_F2_TMP            Normal         24.0       C          N/A          68.0         N/A          70.0        

DDR3_P1_A1_TMP            Normal         28.0       C          N/A          68.0         N/A          70.0        

DDR3_P1_A2_TMP            Normal         27.0       C          N/A          68.0         N/A          70.0        

DDR3_P1_B1_TMP            Normal         29.0       C          N/A          68.0         N/A          70.0        

DDR3_P1_B2_TMP            Normal         28.0       C          N/A          68.0         N/A          70.0        

DDR3_P1_C1_TMP            Normal         27.0       C          N/A          68.0         N/A          70.0        

DDR3_P1_C2_TMP            Normal         28.0       C          N/A          68.0         N/A          70.0        

PSU1_TEMP_1               Normal         41.0       C          N/A          60.0         N/A          65.0        

PSU2_TEMP_1               Normal         40.0       C          N/A          60.0         N/A          65.0        

FP_AMBIENT_TEMP           Normal         24.0       C          N/A          40.0         N/A          45.0        

robertkruk Tue, 02/21/2012 - 18:59
User Badges:

This is from my other server for comparison (the one with no issue)


ucs-c200# scope chassis

ucs-c200 /chassis # show psu detail

Name PSU1:

    In. Power (Watts): 82

    Out. Power (Watts): 650

    Firmware : R0E

    Status : Present

    Product ID : SUNNY651AM

Name PSU2:

    In. Power (Watts): 97

    Out. Power (Watts): 650

    Firmware : R0E

    Status : Present

    Product ID : SUNNY651AM

ucs-c200 /chassis # show pci-adapter detail

Name PCIe Adapter1:

    Slot: 2

    Vendor ID: 0x8086

    Device ID: 0x10e8

    Product Name : Intel E1G44ET 1 Gbps 4 port NIC

Name PCIe Adapter2:

    Slot: 5

    Vendor ID: 0x1000

    Device ID: 0x0079

    Product Name : LSI 9261-8i MegaRAID SAS HBA

ucs-c200 /chassis # exit

ucs-c200# scope sensor

ucs-c200 /sensor # show fan

Name                 Sensor Status        Reading    Units      Min. Warning    Max. Warning    Min. Failure    Max. Failure   

-------------------- -------------------- ---------- ---------- --------------- --------------- --------------- ---------------

PSU1_FAN_1           Normal               2176       RPM        N/A             N/A             N/A             N/A            

PSU2_FAN_1           Normal               2560       RPM        N/A             N/A             N/A             N/A            

W793_FAN1_TACH1      Normal               2300       RPM        N/A             N/A             800             N/A            

W793_FAN1_TACH2      Normal               2400       RPM        N/A             N/A             800             N/A            

W793_FAN2_TACH1      Normal               2300       RPM        N/A             N/A             800             N/A            

W793_FAN2_TACH2      Normal               2600       RPM        N/A             N/A             800             N/A            

W793_FAN3_TACH1      Normal               2500       RPM        N/A             N/A             800             N/A            

W793_FAN3_TACH2      Normal               2600       RPM        N/A             N/A             800             N/A            

ucs-c200 /sensor # show temperature

Name                      Sensor Status  Reading    Units      Min. Warning Max. Warning Min. Failure Max. Failure

------------------------- -------------- ---------- ---------- ------------ ------------ ------------ ------------

IOH_TEMP_SENS             Normal         38.0       C          N/A          80.0         N/A          85.0        

P2_TEMP_SENS              Normal         16.5       C          N/A          66.0         N/A          74.0        

P1_TEMP_SENS              Normal         15.5       C          N/A          66.0         N/A          74.0        

DDR3_P2_D1_TMP            Normal         26.0       C          N/A          68.0         N/A          70.0        

DDR3_P2_D2_TMP            Normal         25.0       C          N/A          68.0         N/A          70.0        

DDR3_P2_E1_TMP            Normal         24.0       C          N/A          68.0         N/A          70.0        

DDR3_P2_E2_TMP            Normal         25.0       C          N/A          68.0         N/A          70.0        

DDR3_P1_A1_TMP            Normal         27.0       C          N/A          68.0         N/A          70.0        

DDR3_P1_A2_TMP            Normal         27.0       C          N/A          68.0         N/A          70.0        

DDR3_P1_B1_TMP            Normal         27.0       C          N/A          68.0         N/A          70.0        

DDR3_P1_B2_TMP            Normal         27.0       C          N/A          68.0         N/A          70.0        

PSU1_TEMP_1               Normal         37.0       C          N/A          60.0         N/A          65.0        

PSU2_TEMP_1               Normal         38.0       C          N/A          60.0         N/A          65.0        

FP_AMBIENT_TEMP           Normal         25.0       C          N/A          40.0         N/A          45.0       


jfalzoneCORP Thu, 09/29/2016 - 10:46
User Badges:

I have 4 C240's where the power supply fans on all four are not working/spinning; is this normal?  the nodes are about 1 year old.



kg6itcraig Tue, 02/21/2012 - 09:19
User Badges:

We had issues like this through the 1.4(3m) code levels.

Craig

robertkruk Tue, 02/21/2012 - 18:56
User Badges:

so am i not at the latest firmware?

I can only see 1.4(2) in the download area

mtimm Tue, 02/21/2012 - 21:01
User Badges:
  • Cisco Employee,

Hi Robert,


I believe Craig was referring to B-series firmware version 1.4(3m). 


For the C-series this is likely due to a bug in the processor temperatue sensing code of CIMC, CSCtu08709.  The fix will be in the next release of CIMC which confusingly will most probably be numbered 1.4(3something) and is due either some time late this month or early next month.  Unfortunately software release schedules are never set in stone and are difficult to predict. 


For full confirmation I would suggest collecting a tech support the next time the server exhibits the problem before trying to workaround it and opening a TAC case.  You could try collecting that now and opening a TAC case but there is a chance that the logs have wrapped and evidence of the issue is no longer available.


Mike

robertkruk Tue, 02/21/2012 - 22:35
User Badges:

Thats cool.

It was bugging me when all the fans were going fast, but after shutdown its just the PSU so the audible fan noise is not noticable.

I look forward to the new firmware patch when it is available.

Correct Answer
mtimm Tue, 02/21/2012 - 22:57
User Badges:
  • Cisco Employee,

Hi Robert,


I guess I should also point out that your two servers have two different versions of power supplies in them which explains the differences in steady state PSU fan speeds even after working around the bug I think one of the servers may have run into.  ucs-c200 has older PSUs that have two inline fans so the fans can run at a lower speeds to maintain the required temperature.  ucs-c210-m2 has newer PSUs that have only a single fan in them so they have to run the fans at higher speeds to maintain the required temperatures.



Mike

robertkruk Wed, 02/22/2012 - 04:56
User Badges:

ahh yes that would explain the PSU fans.  But they still seem a little high (RPMs) considering the temperature?

robertkruk Tue, 02/28/2012 - 16:15
User Badges:

system fans have speed up again

edit: actually its on the other UCS server. Just the system fans are going nuts.

I have opened a TAC

Actions

This Discussion