×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

SPA509G Firmware 7.4.9a Upgrade Broke Distinctive Ring

Unanswered Question
Feb 20th, 2012
User Badges:

Hello all,


I just upgraded two of the SPA509G phones on our system to formware version 7.4.9a.  Now it seems that the phones are no longer honoring the Alert-Info SIP header and defaulting to the Classic-1 ring tone.  This caused a minor revolt in the office so I tried backing the phones back to 7.4.7 and the phones no longer registered with the Asterisk server.  I've been able to manually set the Simple-1 ring tone on the two phones, but the distinctive ring patterns that differentiate between internal and external calls isn't working since the phones seem to ignore the Alert-Info header.  I'd sure appreciate some help resolving this before I get lynched.


Is it possible to successfully back the phones back down to the 7.4.7 firmware?


I've watched the network traffic with an analyzer and I can see that the Alert-Info header is being sent and the phones that weren't upgraded to 7.4.9 are still accepting the Alert-Info header and ringing as desired.  I am using asterisk v1.6.1.10.  Here is an exerpt from the dial plan that has been working until the firmware upgrade.


First, an internal call:

exten => 123,1,SIPAddHeader(Alert-Info: Simple-1)

exten => 123,n,Dial(SIP/phone-001,30,Tt)

exten => 123,n,Voicemail(123@default,su)

exten => 123,n,Hangup()


and, an external call:

exten => 100,1,SIPAddHeader(Alert-Info: Simple-2)

exten => 100,n,Dial(SIP/phone-001&SIP/phone-002&SIP/phone-003&SIP/phone-004,30,T)

exten => 100,n,VoiceMail(1@default,su)

exten => 100,n,Hangup()


Again, everything worked fine until the two phones I upgraded to firmware v7.4.9a seemed to stop paying attention to the Alert-Info SIP header.


Thanks for any help you can offer.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
nseto Wed, 02/22/2012 - 16:33
User Badges:
  • Silver, 250 points or more

I do see that the cisco.com site has the older software avail.


http://www.cisco.com/cisco/software/release.html?mdfid=282724650&softwareid=282463651&release=7.4.9&relind=AVAILABLE&rellifecycle=&reltype=latest


After hitting the link, go to the All Releases, you'll find it there.

We are coming out with a 7.5.1 in a couple of weeks, I believe it will have the fix as well.

msheldon1127 Thu, 02/23/2012 - 11:41
User Badges:

Thank you for the reply.


I was able to obtain the older, 7.4.7 firmware, but when I applied the 7.4.7 firmware to the phone it stopped registering to the Asterisk server. I even tried doing a factory reset and re-applying the 7.4.7 firmware without success. Unless I can find a way to successfully downgrade the firmware it looks like I'm out of luck until the new firmware is released. I'll keep my fingers crossed that the new firmware fixes this.

konoskoncepts Thu, 05/31/2012 - 02:05
User Badges:

I can confirm that updating to 7.4.9a or above breaks the Alert-Info in SPA509G and SPA525G2

(7.4.8a works. Anything above it does not.)


This seems to have happened after the provisioning of "Support for Distinctive Call Waiting Tone".


I have found that with Asterisk PBX (including FreePBX), firmware version 7.4.7 and below have BLF, CP & SD troubles.


7.4.8a seems to be reasonable middle ground.


Cisco please fix the Alert-Info response bug!

Actions

This Discussion