SPA 504G MWI

Unanswered Question
Feb 21st, 2012

I have SPA504g connected to my voip PBX. When the MWI option is set to yes, it turns the MWI on permanently, regardless of whether there is a message or not.

The only way to turn off the MWI is set the option to NO.

Any ideas why this ahhpens and how to rectify?

Jim

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
klogata Tue, 02/21/2012 - 12:42

If you are referring to the flag in the "Call Feature Settings" section in the "Ext" tab in the GUI, if it is set to "yes," the light will remain on (always). I believe the field should be left on the default setting, no, unless there is some type of problem with the MWI indicator and there is a need to turn the light on manually. Normally even if it is set to "no," if the phone has messages, the MWI indicator will light up.

Hope this helps.

jwarrenr6 Tue, 02/21/2012 - 12:47

Thank you. So how do I set the phone to accept MWI from the Voipswitch itself?, as this does not light at all with the setting set to no.

klogata Tue, 02/21/2012 - 13:30

It is something that your VoIP service provider has to support. I think if they support it, some kind of flag is set in the SIP messages from the provider to the phone and that triggers the light to come on. I don't think there is any configuration required on the phone side, other than entering your mailbox ID and server in the GUI.

jwarrenr6 Tue, 02/21/2012 - 13:37

The system lights the MWI on other IP phones such as polycom and Yealink..... But not Cisco... So the question is, what is the SPA504G looking for to trigger the lamp on, that is different from every other phone?

klogata Tue, 02/21/2012 - 14:20

I configured my voice mailbox ID and server in the GUI and I didn't have to do additional configuration, but I am using the SPA400 for voicemail.

I will send this thread to one of the engineers to see if we can get the information that you need.

rbordner Tue, 02/21/2012 - 14:43

James,

Under the EXT 1 tab there are 3 options fields related to the Phones MWI light.

Mailbox ID: (phone number or user id)

Voice Mail Server: (ip address or domain name:port)

Voice Mail Subscriber Interval: (default value of 86400 should be ok)

With the 3 options configured the phone should subscribe to the PBX voice mail service and through the NOTIFY messages the MWI light should turn on and off per the status from the voice mail service.

Regards,

Randy

jwarrenr6 Wed, 02/22/2012 - 06:32

Randy,

On the SPA504G I see only the mailbox number option, as well as a restrict MWI option. Nothing else...?

James

rbordner Wed, 02/22/2012 - 11:28

James,

Are you logged into the phone web browser with admin & advancedpage mode?
Upper right hand corner of web broswer page provide the access.

After the admin/advancedpage is accessed then the Voicemail settings are in the EXT 1 tab.

Regards,

Randy

jwarrenr6 Wed, 02/22/2012 - 12:04

Thanks Randy, I logged in at that level. All set correctly, but still does not work. I can turn the led and interupted dial tome on and off by setting MWI yes / no. But does not respond or work with the VPS

fclement91 Thu, 05/31/2012 - 08:40

Hi,

I have the same kind of issue with a SPA504G.

The light keeps being on.

In the feature settings, I set "no" for "Message Waiting:".

I also have a sip trace where I can see the "NOTIFY" messages :

Notification arrivée nouveau message :

U 91.213.79.49:5060 -> 80.12.80.19:5062

NOTIFY sip:9998@192.168.1.253:5062 SIP/2.0.

Via: SIP/2.0/UDP 91.213.79.49:5060;branch=z9hG4bK71e08586;rport.

Max-Forwards: 70.

From: "Unknown" ;tag=as0d2c0717.

To: .

Contact: .

Call-ID: 5a0e8f385dcdaa9f182a88cf0b8e8975@91.213.79.49:5060.

CSeq: 102 NOTIFY.

User-Agent: FPBX-2.9.0(1.8.7.1).

Event: message-summary.

Content-Type: application/simple-message-summary.

Content-Length: 93.

.

Messages-Waiting: yes.

Message-Account: sip:*97@91.213.79.49:5060.

Voice-Message: 1/0 (0/0).

Notification "plus de message" :

U 91.213.79.49:5060 -> 80.12.80.19:5062

NOTIFY sip:9998@192.168.1.253:5062 SIP/2.0.

Via: SIP/2.0/UDP 91.213.79.49:5060;branch=z9hG4bK08b98f37;rport.

Max-Forwards: 70.

From: "Unknown" ;tag=as2a49a4d6.

To: .

Contact: .

Call-ID: 66bfcd720205f4404a6577aa71d85990@91.213.79.49:5060.

CSeq: 102 NOTIFY.

User-Agent: FPBX-2.9.0(1.8.7.1).

Event: message-summary.

Content-Type: application/simple-message-summary.

Content-Length: 92.

.

Messages-Waiting: no.

Message-Account: sip:*97@91.213.79.49:5060.

Voice-Message: 0/0 (0/0).

So why my led keeps being on ?

mtimm0002 Tue, 11/26/2013 - 18:55

I am having the same issue.MWI will not come on, even with message. I configured the 504g as follows - Call feature Settings
Message waiting: no
Mailbox ID: anveo user ID number
Voicemail subscribe interval: 86400
Voice Mail Server: anveo domain and port

I can see the subscription updating on my anveo user account page. MWI still does not light when I get a voicemail. Thanks for any help you may be able to provide.


Sent from Cisco Technical Support iPad App

Actions

Login or Register to take actions

This Discussion

Posted February 21, 2012 at 12:19 PM
Stats:
Replies:12 Avg. Rating:
Views:2690 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard