×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

ISDN30e set outbound CLID presentation on H.323 Gateway

Answered Question
Feb 28th, 2012
User Badges:

I am based in the UK and have just enabled "Presentation Number (Type 3,4,5)" on an ISDN30 circuit. This should allow me to set the CLID used on outbound calls "allows your customer to decide what number is displayed as the Presentation Number for each outgoing call. The Presentation Number to be used on each call would be controlled by your customers’ PABX switch, and not set up within the BT network".


I am having problems doing this. I thought that I could set this as the calling number that I see in a Q.931 debug message for the call :


Bearer Capability i = 0x8090A3

                Standard = CCITT

                Transfer Capability = Speech

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0xA98388

                Exclusive, Channel 8

        Calling Party Number i = 0x00A1, '[intended outbound CLI]'

                Plan:Unknown, Type:Unknown

        Called Party Number i = 0x80, '[called number]'

                Plan:Unknown, Type:Unknown


However, I still see the number withheld. Am I missing something in the config for the H.323 gateway?


I am actually testing the feature with just trying to send a DDI number associated with that circuit (ultimately I want to send a non-geo)


Interestingly I am only able to present a outbound CLI at all, if I prefix the dialled number with 1470 (and in which case only the main number associated with the circuit is presented). 1470 as I understood it, was to reverse your default CLI position, ie if your default is to withhold, this would present and vice versa. However, the carrier tells me CLI presentation is enabled as per option described earlier.

Hi


Prefixing the dialled number with 1470 should always cause BT to withold your calling number.


My suspicion here is your numbering plan and type - which are currently both set to unknown on both calling and called number. Dredging up from my memory, I once had a similar issue and I had to set these to "National" and "ISDN" via a translation rule on my gateway.


HTH. Barry

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer

Hi


Prefixing the dialled number with 1470 should always cause BT to withold your calling number.


My suspicion here is your numbering plan and type - which are currently both set to unknown on both calling and called number. Dredging up from my memory, I once had a similar issue and I had to set these to "National" and "ISDN" via a translation rule on my gateway.


HTH. Barry

ajenks Wed, 02/29/2012 - 03:21
User Badges:

Thanks for your help Barry, it looks like I have this solved now.


The CLI being witheld (when not using 1470 prefix) was down to settings on the GW :


"Calling Party Presentation" should be Allowed

"Display IE Delivery" should be checked


I did in fact, try a number of combinations regarding number type, number plan. You were correct in saying National/ISDN :

       

Calling Party Number i = 0x2181, '[intended outbound CLI]'

                Plan:ISDN, Type:National        


BUT the intended outbound CLI needs to NOT have the leading '0' - otherwise it appears (on the call recievers side) as being "+.........." and gives the appearance of being a weird international code.


With these settings it appears to work correctly. Thanks for your help.

Actions

This Discussion