FXO Card refuses to go on-hook after an incoming call disconnects

Unanswered Question
Mar 1st, 2012

Hello,

I have a 3825 router with 2 4-port FXO cards that has been in use for a couple of years now. Recently, we have been unable to make calls through the PSTN lines connected to those ports except we restart the router. After an extended period of use, the problem comes again and we then have to restart the router yet again. This has sort of turned into a daily affair and I know this definately isn't normal.

Below is the show ver output:

Cisco IOS Software, 3800 Software (C3825-SPSERVICESK9-M), Version 12.4(9)T2, REL

EASE SOFTWARE (fc4)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2006 by Cisco Systems, Inc.

Compiled Sat 18-Nov-06 19:00 by prod_rel_team

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

System image file is "flash:c3825-spservicesk9-mz.124-9.T2.bin"

Cisco 3825 (revision 1.1) with 236544K/25600K bytes of memory.

Processor board ID FCZ104774JK

2 Gigabit Ethernet interfaces

1 terminal line

8 Voice FXO interfaces

1 cisco service engine(s)

DRAM configuration is 64 bits wide with parity enabled.

479K bytes of NVRAM.

62720K bytes of ATA System CompactFlash (Read/Write)

Configuration register is 0x2102

I'm lost as to what to do and would appreciate any form of guidance to identify where the problem may be as i dont want to have to replace the cards and then find out that the card was never really the problem.

Thanks in advance.

Regards,

Femi

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Jonathan Schulenberg Sun, 03/04/2012 - 16:28

If you shutdown and then no shutdown the voice ports for the analog line (instead of a full router reboot) does the problem clear temporarily? Along these lines does the problem happen after the first call or at some unknown point over the course of the day? The most common scenario is that the analog line isn't going on-hook.

femi.agboade Mon, 03/05/2012 - 04:29

Hi Jonathan,

Thanks for the feedback. I actually made additional observations over the weekend. First of all, this issue occurs after a couple of calls have gone into the day. Running a status on the ports shows that the lines dont go to the 'on-hook' status. What I eventually resolved doing was to pysically go to the router to unplug the rj cables that go into the voice ports and then plug them back in. That resturns the port into an on-hook status and calls go through again.

Its strange because this just happened and there was no change done on the router config.

Regards,

Femi

Jonathan Schulenberg Mon, 03/05/2012 - 04:43

The symptom at least makes sense, if not the cause. With FXO loop start there is no way to tell that the far end has ended the call; it's always dependant on the local IP device to hang up the call. This is an issue if they hang up during ringing or while at an IVR. It's possible that whatever disconnect supervision method you were using (which typically requires carrier cooperation) stopped working due to a change at the carrier.

This document explains your options and configuration:

http://www.cisco.com/en/US/docs/ios/12_2t/12_2t2/feature/guide/ft_ansds.html

In my opinion your best option would be to convert the FXO lines to ground start instead of loop start. This would offer an explicit hangup confirmation when the call has ended which would solve this problem much more reliably. The VIC-?FXS card you have is capable of doing ground start but you must reconfigure it after your carrier makes the change on their end.

femi.agboade Mon, 03/05/2012 - 08:32

Hi again Jonathan,

Thanks for the prompt feedback. By converting the FXO lines to ground start, going by the document you stated above, I assume you are refering to the following:

Router(config)# voice port 1/1

Router(config-voiceport)# echo-cancel enable

Router(config-voiceport)# connection plar 12

Router(config-voiceport)# supervisory disconnect anytone

Router(config-voiceport)# exit

Kindly confirm.

However, please see a sample config on the router below:

!

voice-port 2/0/0

supervisory disconnect dualtone mid-call

compand-type a-law

cptone NG

timeouts call-disconnect 3

timeouts wait-release 3

connection plar opx 21000

impedance complex2

description FXO CONNECTION TO PSTN

caller-id enable

!

Regards,

Femi

femi.agboade Wed, 03/07/2012 - 08:07

Hi Jonathan,

Just as an update, i made the changes on the config of the FXO card but the port still doesnt go to on-hook after a call is dropped. I however observed that this only happens when it is an incoming call. All incoming calls land on the IVR. So when I call in, I disconnect the call just after the attendant starts talking. When I check the status of the port, it remains off-hook till I shut down the port or disconnect the telephone line physically from the FXO card.

After applying echo-cancel enable and supervisory disconnect anytone commands, here is the config I have on the router now:

!

voice-port 2/0/0

supervisory disconnect anytone

cptone NG

timeouts call-disconnect 3

timeouts wait-release 3

connection plar opx 21000

description FXO CONNECTION TO PSTN

caller-id enable

!

I removed the following commands:

compand-type a-law

impedance complex2

Would appreciate any further suggestions.

Regards,

Femi

femi.agboade Sat, 03/10/2012 - 07:16

Hi Paolo,

Thank you for your comments. Can you maybe help with sample configs of what you are referring to?

Also, I thought the supervisory disconnect anytone wouldnt require and specific tone definition?

Regards,

Femi

Actions

Login or Register to take actions

This Discussion

Posted March 1, 2012 at 2:56 AM
Stats:
Replies:8 Avg. Rating:
Views:1207 Votes:0
Shares:0
Tags: fxo
+

Related Content

Discussions Leaderboard