×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

SPA3102 not registering with any SIP provider. Please Help

Answered Question
Mar 12th, 2012
User Badges:

I have been through almost all the blogs and tried almost all the different combinations of settings, but all in vain. can any one tell me what's wrong in my setting. i am behind NAT and want to connect to sip provider. I tried almost 10's of different providers with NAT without NAT with STUN and without STUN, public (STUN /DNS) settings etc. but nothings worked out.

Any help will be highly appriciated. I recently purchased the device and updated the Firmware to the latest. so don't know if the problem is from the new update or my ISP (in UAE) blocks such services( but i can ping the server and can open their websites in browser).

Correct Answer by Howard Wittenberg about 5 years 5 months ago

Your configuration looks OK.  On the Sip Tab under NAT Support Parameters I would have the following set to Yes in addition to the STUN settings:

Handle VIA received, Insert VIA Received, Substitute VIA Address, Handle VIA rport, Insert VIA rport.  I would try this change first in the chance that makes any difference.


The INFO tab shows that STUN appears to be working, your external IP address is shown.  The tab also shows a significant number of SIP Bytes Sent without any SIP bytes Received.  It could be caused by your router's firewall, or it could be a sign of voip traffic blocking.


Depending on the sophistication of the blocking you may be able to circumvent it by altering the port numbers used.  As you know, in communication your voip provider uses an incoming port number and your SPA3102 can use a different port number for sip signalling communication.  Most voip providers only offer port 5060 for traffic to the provider, a few offer alternate ports.  With the SPA3102 you can set most any number for the sip port(s) to be used by the adapter for incoming packets coming back from the provider.


PBXes offers a free account for your sip calling for users with low (2000 minutes a month) volume.  PBXes offers a number of alternate ports for the sip signalling.  I would test for the port blocking by signing up for a free PBXes account and use a different number for your packets to the PBXes proxy.  For example, after you obtain an account with them you could setup an extension with their proxy as pbxes.org:1701.  I would also setup your sip port on the SPA3102 as something other than the standard, for example 6502.  Then see if you can register your extension to PBXes.


If registration is successful then you could setup your voip provider under PBXes as an outgoing trunk (and an incoming trunk if you set it to Register) and place and receive calls thru them.  An alternative, not using PBXes, would be to find another voip provider that will allow you to send packets to their proxy using a non-standard port number in the proxy address.


If the account UserID on the Line 1 Tab and the PSTN Line Tab are for the same account, I would not have them both set to Register.  These are two different VoIP addresses and I would only Register the one where you would receive calls incoming voip calls.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Howard Wittenberg Tue, 03/13/2012 - 12:39
User Badges:
  • Bronze, 100 points or more
  • Community Spotlight Award,

    Small Business, June 2015

Your configuration looks OK.  On the Sip Tab under NAT Support Parameters I would have the following set to Yes in addition to the STUN settings:

Handle VIA received, Insert VIA Received, Substitute VIA Address, Handle VIA rport, Insert VIA rport.  I would try this change first in the chance that makes any difference.


The INFO tab shows that STUN appears to be working, your external IP address is shown.  The tab also shows a significant number of SIP Bytes Sent without any SIP bytes Received.  It could be caused by your router's firewall, or it could be a sign of voip traffic blocking.


Depending on the sophistication of the blocking you may be able to circumvent it by altering the port numbers used.  As you know, in communication your voip provider uses an incoming port number and your SPA3102 can use a different port number for sip signalling communication.  Most voip providers only offer port 5060 for traffic to the provider, a few offer alternate ports.  With the SPA3102 you can set most any number for the sip port(s) to be used by the adapter for incoming packets coming back from the provider.


PBXes offers a free account for your sip calling for users with low (2000 minutes a month) volume.  PBXes offers a number of alternate ports for the sip signalling.  I would test for the port blocking by signing up for a free PBXes account and use a different number for your packets to the PBXes proxy.  For example, after you obtain an account with them you could setup an extension with their proxy as pbxes.org:1701.  I would also setup your sip port on the SPA3102 as something other than the standard, for example 6502.  Then see if you can register your extension to PBXes.


If registration is successful then you could setup your voip provider under PBXes as an outgoing trunk (and an incoming trunk if you set it to Register) and place and receive calls thru them.  An alternative, not using PBXes, would be to find another voip provider that will allow you to send packets to their proxy using a non-standard port number in the proxy address.


If the account UserID on the Line 1 Tab and the PSTN Line Tab are for the same account, I would not have them both set to Register.  These are two different VoIP addresses and I would only Register the one where you would receive calls incoming voip calls.

khalidnisar Wed, 03/14/2012 - 10:18
User Badges:

Thanks ALOOOoooT, finally for the first time i saw four lights on my routers. It worked, it was the port issue, which was making it from connection to the providers.


Alright now the issue with it is it droping line/connection every 5min, and further i am unable to make it ring through softphone while both of em are connected to the host server (pbxes). could you help me to figuer out where could be the problem.


Register Expires:900


thanks in advance

regards


Howard Wittenberg Wed, 03/14/2012 - 14:45
User Badges:
  • Bronze, 100 points or more
  • Community Spotlight Award,

    Small Business, June 2015

For the registration dropping after 5-minutes that is probably caused by your router due to inactivity.  You can either reduce the Register Expires setting or enable the NAT Keep Alive Enable or both.


Reading PBXes "Getting Started" that I previously posted I would try their recommended settings of

Register Expires: 120


They also have a recommendation of using the ip address instead of the symbolic proxy name when using an alternative port in other words

Proxy: 188.40.65.148:1701 (instead of pbxes.org:1701) where 1701 is the alternative port you selected).  I would try that, I'm not sure it makes any difference in your case.


I assume you have the SPA3102 setup as one 3-digit extension and the softphone setup as another 3-digit extension and both are registered.  You should be able to call from one to the other using the extension number.


PBXes has a "Call Monitor" on your signon page that I would use to help in troubleshooting.  After each test call I would verify that the call shows up in the call monitor and that the fields look reasonable.


After you get the extension to extension working and then you can setup your voip provider as a trunk, setup outbound routing from your extensions pointing to the trunk and setup inbound routing for calls from the voip provider to ring your extension if you are using the voip provider for incoming calls.

khalidnisar Mon, 03/26/2012 - 10:18
User Badges:

Alright i got it finally running, the line drop issue was due to NAT settings. forgot to FWD port from my router to the SPA. it works perfectly fine after port FWDing. I'm happy with the setting.

Although an ulternative i found is iNum for same kinda settings to my need.

Actions

This Discussion