×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

BGP between 2 ISP links with auto failover & load balancing

Unanswered Question
Mar 12th, 2012
User Badges:

Dear friends, plz help in following scenerio.

My company have 7 locations all over India.We had a link from one ISP.Now, my company want to a link from other ISP which would be act as back up in case of primary goes down & can use in load balancing facility.

My doubts:

1. My doubt is can a BGp router has 2 AS since, in this case , both ISPs would provide me 2 AS.

2. How can I configure load balancing in BGP?

3. How can I configure auto failover ?

PLz guide me

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
r.malviya Tue, 03/13/2012 - 01:16
User Badges:

Hi Abhi ,


Answers


1) You no need to use 2 AS no .


ISP 1 (AS 100)                ISP 2(AS 200)

            |                                   |

            |                                   |

                       U R (AS 300)

U can't do Ioadbalancing in BGP like other routing protocol do .


Sample config

--------------------


interface Serial 0
ip address 10.10.10.1 255.255.255.0
no ip route-cache
   
interface Serial 1
ip address 20.20.20.1 255.255.255.0
no ip route-cache
  
router bgp 300
neighbor 10.10.10.2 remote-as 100
neighbor 10.10.10.2 route-map UPDATES-1 in

!--- This allows only the networks up to 128.0.0.0.

neighbor 20.20.20.2 remote-as 200
neighbor 20.20.20.2 route-map UPDATES-2 in

!--- This allows anything above the 128.0.0.0 network.

auto-summary
 
route-map UPDATES-1 permit 10
match ip address 1
set weight 100

route-map UPDATES-1 permit 20
match ip address 2
 
route-map UPDATES-2 permit 10
match ip address 1
 
route-map UPDATES-2 permit 20
match ip address 2
set weight 100
 
access-list 1 permit 0.0.0.0  127.255.255.255
access-list 2 deny 0.0.0.0 127.255.255.255
access-list 2 permit any


There are other paramiter as well you can set to influance the incoming & outgoing traffic

like u can set local Pref/weight attribute for outgoing
& AS Path prepand for incoming traffic as well .


Regards

Ritesh 

                         


needtechhelp Tue, 03/13/2012 - 02:50
User Badges:

Ritesh, Thanks for answer.

There is one command in BGp : Maximum-path =

can I use the same for load balancing?

amigomnemonik Tue, 03/13/2012 - 03:04
User Badges:

Load balancing works only if you have 2 peer connections to the same AS number. Filtering prefixes via route maps and attaching them to the neighbour statements seems to be the best option.


Sent from my iPhone

r.malviya Tue, 03/13/2012 - 07:18
User Badges:

How can I configure auto failover ?


Auto failover is always there becasue when u config both off the ISP , So on u r router u can see u are getting the same prefix from 2 different Next-hop(or ISP)


it will use only one as best & next will be ideal ,


when u r primary will down u still have same prefix from other ISP in bgp table


& automatically it will install in routing table .


Regards

Ritesh

Actions

This Discussion