SPA112 Not adjusting for daylight savings time, unable to change to manual NTP server

Unanswered Question
Mar 13th, 2012

Two issues I've seen with my SPA112:

1.  If I change the NTP server to "Manual", and try to enter a server URL (such as 0.pool.ntp.org), I get "Invalid NTP Server Address".

2.  The SPA112 does not seem to have adjusted automatically to DST, at least judging by the time it shows on the status screen.  (I have set the timezone to GMT-05:00 Eastern Time, and checked the "Adjust Clock for Daylight Saving Changes" box.)

Dan

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Patrick Born Tue, 03/13/2012 - 14:24

Hi Dan,

Thanks for letting us know about this problem. I've tested and found that the issue is related to the web-User Interface testing the parameter. I'll file a defect against this. This is not an issue if a configuration file is used. I'm able to set the server to "0.pool.ntp.org" using a configuration file as follows:

  

      

        ...

        ...

        0.pool.ntp.org

        ...

        ...

   

  

Set the time server to "pool.ntp.org" to work around this.

I tested and found that my SPA122 does correctly set its time when configured as follows:

Regards,

Patrick

----------

Patrick Born Wed, 03/14/2012 - 07:26

Dan,

I tested the DST and it worked for me. The ATA displayed EDT and not standard time.

Click on the screenshot I posted to make it display in higher quality and you'll see the time is 17H22. I'm in CDT (Texas) and posted the screenshot at 16H24, two minutes after taking the shot.

    

If you're having issues with time not syncing fast enough, try reduce the Resync Timer down from an hour. Also, select the "Auto Recovery After Reboot" box to make sure that the ATA actively solicits the NTP server at boot time. Read more in the SPA100 Admin Guide.

Regards,

Patrick

----------

danbuchko@gmail.com Wed, 03/14/2012 - 07:44

Hi Patrick,

Hmmm, wonder why mine is not showing DST since it kicked in on the weekend.  Do you think it is because my time server address is set to "Auto"?  My screen looks as follows:

You can see that the current time is 1 hour behind, as though the DST is not working.  Note that I'm running firmware version 1.1.0 (011) Feb 10 2012.

Also, how do I change the settings via the XML config file, as you earlier did?

Thanks,

Dan

Actions

Login or Register to take actions

This Discussion

Posted March 13, 2012 at 9:14 AM
Stats:
Replies:5 Avg. Rating:
Views:1974 Votes:0
Shares:0

Related Content

Discussions Leaderboard