Dual MPLS problem...

Answered Question
Mar 13th, 2012

hi guys..

In my company to connect between main office to branch office we are using one service provider for primary MPLS link and another service provider for Fall back MPLS link..

I have provided a high and low prirority routes between the two MPLS link... but

When the Primary MPLS link got down i have to manually switch off the primary service provider modem at main office and branch office.

then only the secondary service provider MPLS link got up..

After the primary link service provider cleared the link issue i have to again switch on the modem at main office and branch office.

Instead of this manual switch on and off process is there is any other way to sort out this issue..

Thanks in advance.

Naveen....

I have this problem too.
0 votes
Correct Answer by ajnallicruz about 2 years 1 month ago

Two things.

You need this:

interface Tunnel0

backup interface s0/1

And this:

You need to reverse the administrative distance on the static routes. They should be:

ip route 0.0.0.0 0.0.0.0 1.1.1.2 50

ip route 0.0.0.0 0.0.0.0 2.2.2.3

because even if the tunnel goes down the static route to 1.1.1.2 will remain in the table until the modem is shut down.

If you reverse the administrative distance, when the tunnel goes down it will bring up s0/1 and install the better (0.0.0.0 0.0.0.0 2.2.2.3) default route.

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
jpvh12345 Tue, 03/13/2012 - 18:53

Don't know what kind of router you have but you need to look into ip sla.

Sent from Cisco Technical Support iPad App

naveen_yummy Wed, 03/14/2012 - 17:17

hi houten..

In mani office using 2600 Router and in brance office using 1841 router.

And what is ip sla?????

jpvh12345 Wed, 03/14/2012 - 18:13

http://www.cisco.com/en/US/customer/products/ps6602/products_ios_protocol_group_home.html

But I'm not sure about availability on he 2600.

Sent from Cisco Technical Support iPad App

jpvh12345 Thu, 03/15/2012 - 12:20

You probably need a Cco login.

Thanks,

Jeff Van Houten

Vice President &

Chief Technology Officer

First Bank and Trust

909 Poydras St.

Suite 3300

New Orleans, LA 70112

www.fbtonline.com

"Your Goals Come First"

milan.kulik Thu, 03/15/2012 - 09:45

Hi,

how are your sites peering to the providers?

Any dynamic routing protocol involved?

BR,

Milan

naveen_yummy Thu, 03/15/2012 - 12:12

hi merlin..

No dynmaic protocols are used... only static routings are used between the company's...

Regards,

naveen

ajnallicruz Thu, 03/15/2012 - 12:49

Below are a couple different solutions I can think of. They are based on a couple assumptions-

Assumption 1: Your MPLS connections are brought into a single WAN router.

Assumption 2: You are unable to fail over with floating static routes because when you lose the MPLS link your line protocol on the WAN router interface remains up.

================================

Solution 1: Next-hop tracking with IP-SLA-

ip sla 1

icmp-echo source-interface

  frequency

!

ip sla schedule 1 start now life forever

!

track 1 rtr 1 reachability

(optional paramaters delay up/down)

!

ip route 0.0.0.0 0.0.0.0 track 1

ip route 0.0.0.0 0.0.0.0 2

=============================

===================================

Solution 2: Backup interface with GRE

interface Tunnel0

ip address

keepalive

tunnel source

tunnel destination

backup interface

!

ip route 0.0.0.0 0.0.0.0

ip route 0.0.0.0 0.0.0.0 2

(tunnel interface needed at remote site as well)

====================================

Both of these solutions are based on how IOS handles static routing. A static route will be installed into the RIB as long as the exit interface for the next-hop ip address is in the protocol up state. In order to use floating static routes we need some way to withdraw a route based on true ip connectivity status instead of line protocol status.

for solution 1, IP-SLA can do this by sending a ping to the next-hop IP address. The static route points to the IP-SLA and withdraws itself from the RIB if the SLA fails

Solution 2 uses the backup interface feature on GRE tunnels with keepalives enabled. When the GRE tunnel loses keepalive it will tear down its line protocol and bring up the standby interface (ISPB). You would need to make sure the tunnel destinations do not route over ISPB or the tunnel will immediately pick back up and shut down the ISPB interface.

naveen_yummy Thu, 03/15/2012 - 14:17

i think in my comp solution 2 is used. fBut there is no automatic change over is not happening. manual modem off/on is required.

ind the configuration below of both main office and branch office configurtaion ,

Main office Router Configuration - 2621

interface Tunnel0
ip address 192.168.16.1 255.255.255.0
keepalive 300 200
tunnel source 1.1.1.1
tunnel destination 1.1.1.4

interface FastEthernet0/1
description Service Provider1
ip address 1.1.1.1 255.255.255.252
load-interval 30
speed 100
full-duplex
no cdp enable
!
interface Serial0/1
description Service Provider 2
ip address 2.2.2.1 255.255.255.252
ip route-cache flow
no fair-queue
!

ip route 0.0.0.0 0.0.0.0 1.1.1.2
ip route 0.0.0.0 0.0.0.0 2.2.2.3 50

Branch office Router Configuration - 1841

interface Tunnel0
ip address 192.168.16.2 255.255.255.0
keepalive 300 200
tunnel source 1.1.1.4
tunnel destination 1.1.1.1

interface Serial0/0/0
description Service Provider 1
ip address 1.1.1.4 255.255.255.252
no ip mroute-cache
no fair-queue
serial restart-delay 0

interface FastEthernet0/1.3000
description Service Provider 2
encapsulation dot1Q 3000
ip address 2.2.2.4 255.255.255.252
no snmp trap link-status
!
ip route 192.168.0.0 255.255.240.0 Serial0/0/0
ip route 192.168.0.0 255.255.240.0 FastEthernet0/1.3000 50
!

Regards,

naveen

Attachment: 
Correct Answer
ajnallicruz Thu, 03/15/2012 - 14:24

Two things.

You need this:

interface Tunnel0

backup interface s0/1

And this:

You need to reverse the administrative distance on the static routes. They should be:

ip route 0.0.0.0 0.0.0.0 1.1.1.2 50

ip route 0.0.0.0 0.0.0.0 2.2.2.3

because even if the tunnel goes down the static route to 1.1.1.2 will remain in the table until the modem is shut down.

If you reverse the administrative distance, when the tunnel goes down it will bring up s0/1 and install the better (0.0.0.0 0.0.0.0 2.2.2.3) default route.

Actions

Login or Register to take actions

This Discussion

Posted March 13, 2012 at 5:56 PM
Stats:
Replies:11 Avg. Rating:5
Views:797 Votes:0
Shares:0
Tags: mpls
+

Related Content

Discussions Leaderboard