Configure MOH Multicast for Unity connection and remote branches

Answered Question
Mar 14th, 2012
User Badges:

Hi ,


I'm facing an issue with one of our customer. The customer has a Corporate and remote branches.In the coporate site i configure Multicast MOH and added in a MRG with enabling Multicast and put in MRGL.All ip phones and Voicemail ports in the same DP which contain the MOH Server.Now when  calling from outside and put outside callers on hold they hear silence and MOH is not streaming.I tried removing the multicast checkbox on the MRG and now it's working but i lost the part of making remote branches to have MOH stream from the flash on the router it's self.


What other solution can be done so i can have Multicast for remote branches and remain MOH for the internal and outside callers?

Correct Answer by ronpatel about 5 years 2 months ago

HI



Cisco recommends that you configure multicast MoH  audio sources to use IP addresses in the range 239.1.1.1 to  239.255.255.255, which is reserved for administratively controlled  applications on private networks.


So you can use


access-list 1 deny 239.1.1.1
access-list 1 permit any


Above is not tested one. You wil lhave to test is before deployment and see if it is not restricting any other traffic.


regards

Ronak patel


Please rate helpfull posts.

Correct Answer by ronpatel about 5 years 2 months ago

Hi,


It means your Corporate network gateway is 3 hops away from the CUCM MOH source. you can do two things


1) Switch back hop to 1 and configure you Corporate gateway to generate locle MOH file like your branch site does.


2) keep hop as 3 and apply ACL through out network to stop Multicast MOH related traffic on WAN.


Regards

Ronak Patel


Please rate helpful posts.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Chris Deren Wed, 03/14/2012 - 06:35
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,
  • Cisco Designated VIP,

    2017 IP Telephony, Contact Center, Unified Communications

The question here is why did the PSTN caller did not hear music when MMOH was on, couple of questions:

Is the voice GW on the same VLAN as the phones?

Is MRGL assigned to the voice GW?

Is the PSTN connection a SIP trunk by any chance?


Chris

asherif82 Wed, 03/14/2012 - 07:36
User Badges:

Hi Chris,


Voice gateway has FXO trunk lines only with no SIP circuit.They have a flat network so everything is in the same vlan (VGW,IP Phone,CUCM,CUC). MRGL is assigned to the VGW ,IP Phones,VoiceMail Ports as well as DP.


Call flow as follow:


PSTN-->Fxo-->Connection plar opx 5555 (AA)--->AA greetings-->VoiceMail Port and then dial extension or go for the operator.


As i mentioned previously,If i remove the Multicast MOH check box from the MRG i can hear MOH for outside caller,If added it gives silence. how to imeplement it and in the same time configure remote branches for streaming from flash?


Appreciate your help.

Chris Deren Wed, 03/14/2012 - 08:04
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,
  • Cisco Designated VIP,

    2017 IP Telephony, Contact Center, Unified Communications

Let's start with basics, do you hear the MOH when using multicast just between 2 Cisco IP phones?

Is the audio source configured for multicast?

Is multicst routing enabled on your switches? If everything is on 1 VLAN this is not required.


Chris

asherif82 Wed, 03/14/2012 - 23:57
User Badges:

Internal IP Phone can hear MOH between each other with no problems. Audio source is configured for play continously and allow multicast.It is added to a MRG which has a check box of using multicast and later is added to a MRGL which is configured in DP for IP Phones,VGW,VoiceMail ports.


Otherwise multicast is not enabled on the switch but as i mentioned everything configured in one vlan.

ronpatel Thu, 03/15/2012 - 00:06
User Badges:
  • Blue, 1500 points or more

HI


What is the value of Max Hops in  Music On Hold (MOH) Server Configuration page.


regards

Ronak patel

asherif82 Thu, 03/15/2012 - 00:15
User Badges:

The value is 1 and counting upon the IP Address with multicast ip address 239.1.1.1. I tried to add MOH-3 for the subscriber to be in another unicast MRG and added to a new MRGL .I assigned this new MRGL to voicemail ports only so outside caller can hear Unicast MOH while internal and remote branch user hear MMoH. but it didnot work.


Any suggestion?

ronpatel Thu, 03/15/2012 - 00:19
User Badges:
  • Blue, 1500 points or more

Hi,


Just of testing,Please Try to change the vlaue to 3 and restart Cisco IP Voice Media Streaming App.


Regards

Ronak Patel

asherif82 Thu, 03/15/2012 - 00:23
User Badges:

I tried increaing the value to be 2 and it didnot work.I'll try make it 3 but in that case i'll not manage to perform multicast MOH to be streamed from the flash in remote branches.

ronpatel Thu, 03/15/2012 - 00:25
User Badges:
  • Blue, 1500 points or more

Hi.


Let us see if 3 works. If 3 works we will get to know the problem and we can have workaround then.


regards

Ronak patel

asherif82 Thu, 03/15/2012 - 01:01
User Badges:

Hi,


I tried increase it to Hop count 3 and It works very well as needed. Now for remote branch i expect to face an issue for MOH streaming from flash as the requirements is to make the Hop to be 1 not 3.

Correct Answer
ronpatel Thu, 03/15/2012 - 01:05
User Badges:
  • Blue, 1500 points or more

Hi,


It means your Corporate network gateway is 3 hops away from the CUCM MOH source. you can do two things


1) Switch back hop to 1 and configure you Corporate gateway to generate locle MOH file like your branch site does.


2) keep hop as 3 and apply ACL through out network to stop Multicast MOH related traffic on WAN.


Regards

Ronak Patel


Please rate helpful posts.

asherif82 Thu, 03/15/2012 - 01:14
User Badges:

Hi,


If i'm going to go with the second solution. Please can you give me the syntax of the ACL to block the Multicast MOH.


Thanks.

Correct Answer
ronpatel Thu, 03/15/2012 - 01:27
User Badges:
  • Blue, 1500 points or more

HI



Cisco recommends that you configure multicast MoH  audio sources to use IP addresses in the range 239.1.1.1 to  239.255.255.255, which is reserved for administratively controlled  applications on private networks.


So you can use


access-list 1 deny 239.1.1.1
access-list 1 permit any


Above is not tested one. You wil lhave to test is before deployment and see if it is not restricting any other traffic.


regards

Ronak patel


Please rate helpfull posts.

asherif82 Fri, 03/16/2012 - 04:33
User Badges:

Hi,


I'll try to test this configuration and let you know the outcome .


Regards,

Amr Sherif

Actions

This Discussion