×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

VTP Trunking on 2801

Answered Question
Mar 14th, 2012
User Badges:

I am very new at this, but we have a 2801 router running 12.4, a 3560 that acts as the "Core" switch, and a bunch of remote 2960G's that connect via fiber to different buildings.




I am tasked to VLAN this network to reduce broadcast traffic. I started by setting up a VLAN 169 on the "3560" named the VTP domain, changed to  version 2, and no password. THe Core switch and remote switch can share the VTP info, I HAD the Router seeing it too (able to ping 192.168.169.1) until I changed the "Domain" and "VTP Version"




The switches see each other fine, my problem is the Router sub interface 0/0.169 I cannot get to see the VTP domain. I imagine because I don’t have a "Trunk port" set on the Router, but the option is not there. Meaning I cannot do a "switchport mode trunk" on it. The only thing I see is to make it:




TCRouter(config-subif)#encapsulation dot1Q 169 native




But, my "int fas 0/0" is used now as the main interface for our "only" network 192.168.0.0, do I need to turn this over to a subinterface and make it "Native" then the difference of the subinterfaces will advertise?




Help......




Here is some of my conf:




Core SW:



TCCoreSW#sh vtp status

VTP Version                     : running VTP2

Configuration Revision          : 8

Maximum VLANs supported locally : 1005

Number of existing VLANs        : 10

VTP Operating Mode              : Server

VTP Domain Name                 : Tecnico

VTP Pruning Mode                : Disabled

VTP V2 Mode                     : Enabled

VTP Traps Generation            : Disabled

MD5 digest                      : 0x6B 0x93 0x23 0xD8 0x62 0x65 0x94 0xCF

Configuration last modified by 192.168.0.42 at 3-14-12 18:21:58

Local updater ID is 192.168.0.15 on interface Vl100 (lowest numbered VLAN interface found)


Vlan169 is up, line protocol is up

  Internet address is 192.168.169.2/24

  Broadcast address is 255.255.255.255

  Address determined by setup command

  MTU is 1500 bytes

  Helper address is 192.168.0.16

  Directed broadcast forwarding is disabled

  Outgoing access list is not set

  Inbound  access list is not set

  Proxy ARP is enabled

  Local Proxy ARP is disabled

  Security level is default

  Split horizon is enabled

  ICMP redirects are always sent

  ICMP unreachables are always sent

  ICMP mask replies are never sent

  IP fast switching is enabled

  IP CEF switching is enabled

  IP CEF switching turbo vector

  IP Null turbo vector

  IP multicast fast switching is enabled

  IP multicast distributed fast switching is disabled

  IP route-cache flags are Fast, CEF

  Router Discovery is disabled

  IP output packet accounting is disabled

  IP access violation accounting is disabled

  TCP/IP header compression is disabled

  RTP/IP header compression is disabled

  Probe proxy name replies are disabled

  Policy routing is disabled

  Network address translation is disabled

  BGP Policy Mapping is disabled

  Output features: Check hwidb

  WCCP Redirect outbound is disabled

  WCCP Redirect inbound is disabled

  WCCP Redirect exclude is disabled


Router:

VTP Version                     : 2

Configuration Revision          : 1

Maximum VLANs supported locally : 19

Number of existing VLANs        : 5

VTP Operating Mode              : Server

VTP Domain Name                 : Tecnico

VTP Pruning Mode                : Enabled

VTP V2 Mode                     : Enabled

VTP Traps Generation            : Disabled

MD5 digest                      : 0x0D 0xFD 0x5D 0xFD 0x55 0xA8 0x6F 0x6D

Configuration last modified by 192.168.0.1 at 3-14-12 19:26:26

Local updater ID is 192.168.0.1 on interface Fa0/0 (first interface found)

Preferred interface name is 192.168.0.1


TCRouter#sh interfaces fastEthernet 0/0.169

FastEthernet0/0.169 is up, line protocol is up

  Hardware is Gt96k FE, address is 0023.33b5.ecd4 (bia 0023.33b5.ecd4)

  Internet address is 192.168.169.1/24

  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation 802.1Q Virtual LAN, Vlan ID  169.

  ARP type: ARPA, ARP Timeout 04:00:00

  Last clearing of "show interface" counters never

Correct Answer by Reza Sharifi about 5 years 5 months ago

If you have multiple vlans that need to reach the router on interface Fa0/0, than you need to create a sub-interface for each vlan.  You would need to remove the current IP from the main interface and apply it to a sub-interface:


encapsulation dot1Q 169

encapsulation dot1Q 170

and so on


Doing this will require an outage window.



HTH

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Reza Sharifi Wed, 03/14/2012 - 13:56
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 LAN

If you have multiple vlans that need to reach the router on interface Fa0/0, than you need to create a sub-interface for each vlan.  You would need to remove the current IP from the main interface and apply it to a sub-interface:


encapsulation dot1Q 169

encapsulation dot1Q 170

and so on


Doing this will require an outage window.



HTH

andrewwilson1980 Thu, 03/15/2012 - 05:47
User Badges:

Thanks for the prompt response, I will work that in today. Is there a need for the "native" command?

Jan Hrnko Thu, 03/15/2012 - 06:55
User Badges:
  • Silver, 250 points or more

Hi Andrew,


If you want to recieve and forward data from the native vlan you should create an appropriate subinterface for it. What native vlan are you using?


If you are using vlan 169 as native you should do similar:


TCRouter(config)#interface fa0/0.169

TCRouter(config-subif)#encapsulation dot1Q 169 native

TCRouter(config-subif)#ip address YOUR_IP YOUR_MASK


Best regards,

Jan

milan.kulik Thu, 03/15/2012 - 07:28
User Badges:
  • Red, 2250 points or more

Hi,


there is one workaround available for a case you've got no maintenence window available.

You could leave the IP address used for the native VLAN on the main interface.

And create subinterfaces for the other (tagged) VLANs only.

This is a trick coming from the old days when "native" keyword was not available yet.

It's not a nice configuration but works.


If you've got a maintenance window available for a short outage, creating a subinterface with encapsulation ... native is definitely recommended though.


HTH,

Milan

andrewwilson1980 Thu, 03/15/2012 - 09:17
User Badges:

Beautiful, I have changed the sub interface to my network 192.168.0.0 and I can now ping my other VLAN.


Still the same problem is I cannot seem to get the VTP to update the router, but the switches will talk to each other, this seemed to occur when I swapped the router to version 2. Do I NEED a password?

andrewwilson1980 Thu, 03/15/2012 - 11:04
User Badges:

Answering my own question here for anyone else that might have this problem. Again I am new at this.


I have my router interface connected to my core switch on port 0/3, which is not configured as a "switchport trunk encapsulation dot1q" then "switchport mode trunk" finally "switchport trunk allowed vlan all".


I am not sure if this will drop connections, so I will schedule down time, I inherited this "setup" which I am working to fix, thanks for the prompt responses.

Actions

This Discussion