Response=503 Service Unavailable.

Unanswered Question
Mar 15th, 2012

Hi All ,

We are experiencing the below given error message  in the servers which are kept before the cisco ACE .

………………….,Backend Response=503 Service Unavailable,Backend processing time=17,Processing time=21 “

Any stcky configuration has not been enabled on the server farm    where we kept the Rserver . Also we can see the live connection on the

Rserver  through the loadbalancer.

But the  probe configuration is as a below.

probe http TCP35812_HTTP

port 35812

interval 5

faildetect 2

passdetect interval 2

request method get url /esales/is_available

expect status 200 200

connection term forced.

The server team confirmed as there is no issue at their end and  it is working  fine if they access without the loadbalancer  ( VIP).

Please suggest me what is the “ request method get url /esales/is_available “ . Also suggest me is it related to loadbalancer or   server related issue .

Regards,

Sinjish.K 

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
sivaksiv Thu, 03/15/2012 - 07:27

Hi,

Have only one server in the serverfarm and see if it fixes your problem. If the problem still persist with one server, then most likely this is not a loadbalancer issue.

-

Siva

k_sinjish Thu, 03/15/2012 - 07:43

Hi ,

It is not possible ..it got five  Rservers in the server farm...

Can anyone brief me what is  role of below configuraion in probe.

request method get url /esales/is_available

Regards,

Sinjish.K

sivaksiv Thu, 03/15/2012 - 08:28

Hi,

Try'n have a look at this, I think you will find it useful.

http://www.cisco.com/en/US/docs/interfaces_modules/services_modules/ace/vA2_3_0/configuration/slb/guide/probe.html#wpxref46342

But  in short, when applying e.g an http-probe to your serverfarm, you can  specify a request method (GET og HEAD) to request specific content from  the rserver using http. Combined with either http response-code check or  regex, this provides for more detailed availibility information on the  specific rserver.

-

Siva

Surya ARBY Thu, 03/15/2012 - 09:08

You probably have to forge a whole HTTP header for your probe (Host field)

k_sinjish Fri, 03/16/2012 - 01:13

Hi Surya/Siva,

Thanks for the response .

Could you please elaborate me  how this request method “request method get url /esales/is_available “ in the above probe can be replaced with the  “forge a whole HTTP header for your probe   “ ( The suggested method )

Regards,

Sinjish.K

Actions

Login or Register to take actions

This Discussion

Posted March 15, 2012 at 12:44 AM
Stats:
Replies:6 Avg. Rating:
Views:433 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 1,551
2 369
3 333
4 228
5 212
Rank Username Points
5