LMS4.2 NullPointerException with no User Tracking?

Unanswered Question
Mar 16th, 2012
User Badges:

I have just got LMS 4.2 soft appliance up and running. When going to Inventory >> Acquisition summary, I get a HTTP 500 error with

java.lang.NullPointerException.


That is obviously a bug somewhere (although the TAC engineer disagrees with me). I am just wondering if this is could have been caused by the fact that I have not done any user tracking on this LMS server yet?


HTTP Status 500 -


type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

java.lang.NullPointerException
     com.cisco.nm.ani.clients.utng.action.UTDiscoveryStatAction.perform(UTDiscoveryStatAction.java:47)
     org.apache.struts.action.ActionServlet.processActionPerform(ActionServlet.java:1786)
     org.apache.struts.action.ActionServlet.process(ActionServlet.java:1585)
     org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:491)
     javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
     javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
     org.ajaxanywhere.AAFilter.doFilter(AAFilter.java:46)
     com.cisco.nm.cmf.util.AccessLogFilter.doFilter(AccessLogFilter.java:128)

note The full stack trace of the root cause is available in the Apache Tomcat/6.0.33 logs.


Apache Tomcat/6.0.33

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Michel Hegeraat Sat, 03/17/2012 - 01:59
User Badges:
  • Gold, 750 points or more

Usertracking is on by default so after some time it should have gathered UT info.


You need devices in campus 'Topology' of course.


UT is a subprocesses of ANIServer so you can't see it running, you can only see it in the status of the collection summary view.


You can crank up the debug levels to see whats going on.


Cheers,


Michel

Actions

This Discussion

Related Content