LDAP Corporate Directory lookup won't work on Win 2008 64-bit

Unanswered Question
Mar 16th, 2012

I just spent like 20 hours chasing this problem so I thought I'd post the solution here.

We host the IP Phone Corporate Directory on a Win 2003 web server and it works fine, but failed when we tried to move it to a Win 2008 server.

When the multidirectory.asp or localizeddirectory.asp script is run, it fails on this line:

var s = new ActiveXObject("LDAPSearch.LDAPSearchList");

If you try to access the service from a browser like this:  http://myserver/CiscoIPServices/ASP/localizeddirectory/localizeddirectory.asp you'll get an error something like this:

XML Parsing Error: not well-formed

Location: http://myserver/CiscoIPServices/ASP/localizeddirectory/localizeddirectory.asp

Line Number 1, Column 26:

View the page source and you'll see something like this:

<font face="Arial" size=2>
<p>Microsoft JScript runtime </font> <font face="Arial" size=2>error '800a01ad'</font>
<p>
<font face="Arial" size=2>Automation server can't create object</font>
<p>
<font face="Arial" size=2>/CiscoIPServices/ASP/localizeddirectory/localizeddirectory.asp</font><font face="Arial" size=2>, line 51</font> 

If you configure IIS to send detailed error messages to the browser, disable user-friendly error messages on your browser, and change

Response.ContentType from "text/xml" to "text/html" in the ASP script, you'll see the REAL error:

Microsoft JScript runtime error '800a01ad'

Automation server can't create object

/CiscoIPServices/ASP/localizeddirectory/localizeddirectory.asp, line 51

Microsoft provides this, which is may be of help for some issues, but not this one:

http://support.microsoft.com/default.aspx?scid=kb;en-us;q194801

This '800a01ad' error is discussed in quite a few other posts on this forum (search for LDAP COM, or COM ERROR, or LDAPSEARCH) but I could not find anything about win 2008.

In the end I discovered the problem is that the Cisco DLL (LDAPSearch.dll) is 32-bit but Win 2008 is running in 64-bit mode.  To fix it:

Run Server Manager

Navigate to IIS manager --> Application Pools --> DefaultAppPool

Edit Advanced Settings

Change "Enable 32-bit applications" to True

I hope this helps someone!

Regards,

Tim

I have this problem too.
2 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Mike Lydick Sun, 03/18/2012 - 05:33

Tim,

Same issue and your research and post saved me a good bit of time. Thank for sharing the fix.

Mike

DmytroSoloviov Wed, 12/05/2012 - 01:04

timbo66, you're really great guy: you've saved my brain from explosion

Thanks a lot! You solution really works!

Nicolas MICHEL Tue, 03/11/2014 - 08:56

Solved my issue too .... Yeah indeed this saved my brain from explosion :)

 

Thanks a lot.

 

Nicolas

ganpatel Mon, 08/25/2014 - 23:30

Hey Mate ,

 

Thanks a lot for sharing , it did really help me a lot . Your solution really worked

Actions

Login or Register to take actions

This Discussion

Posted March 16, 2012 at 9:52 AM
Stats:
Replies:4 Overall Rating:
Views:1123 Votes:2
Shares:0

Related Content

 
 
 

Discussions Leaderboard

Rank Username Points
1
rob.huffman
6,155
2
David Hailey
3,008
3
Chris Deren
2,324
4
Tommer Catlin
1,882
5
Ginger Dillon
1,761
Rank Username Points
Terry Cheema
81
Shadi Shami
80
Aaron Harrison
64
Aman Soi
45
rob.huffman
30