×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

CME 8.0 / ISR2821 / Basic Configuration

Unanswered Question
Mar 16th, 2012
User Badges:

Hi everyone,


I have what I feel like is a basic issue that for some reason or another I can't solve today.  I have an ISR 2821 router running CME 8.0 and what I'm trying to do is get one phone to register with it.  The part I'm having an issue with is that yesterday I configured the router and the phone registered with no issues, using a bare/basic configuration.  I'm talking no VLANs, isolated network type basic setup; one router, one switch, one IP phone and that's it.  The phones I've tried registering (yesterday successfully) are 7940, 7960, 7970.


I'm sure or at least hoping I'm just having a brain fart and I'm missing something completely obvious.  I didn't need to add any additional commands before (particulary any loads or tftp flash:/ commands) and everything was fine.  I'm having this issue on this 2821 today because I erased my config that was working and started over due to having an identical set setup and not being able to get that phone to register to its CME either.  I thought maybe there was an issue with a file missing in flash or something related.


I did turn on auto-reg-ephone instead of statically mapping the mac address, which also worked fine before.  Any suggestions?  I DO know that its trying to find the SEP<mac_address).cnf.xml file and it can't but I "assumed" it would default to the default XML.cnf file in flash, which based on the status messages on the phone and a quick debug tftp events command showed.


VoiceR2#

*Mar 16 22:52:35.567: TFTP: Looking for CTLSEP001C58A28C4C.tlv

*Mar 16 22:52:35.695: TFTP: Looking for SEP001C58A28C4C.cnf.xml

*Mar 16 22:52:35.763: TFTP: Looking for XMLDefault.cnf.xml

*Mar 16 22:52:35.763: TFTP: Opened system:/its/vrf1/XMLDefault.cnf.xml, fd 10, size 3167 for process 314

*Mar 16 22:52:35.775: TFTP: Finished system:/its/vrf1/XMLDefault.cnf.xml, time 00:00:00 for process 314


I have been reading the guides/documentation but so far no luck.


Here is a view of the current config:


VoiceR2#sh run

Building configuration...



Current configuration : 1402 bytes

!

! Last configuration change at 22:29:41 UTC Fri Mar 16 2012

!

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname VoiceR2

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

!

dot11 syslog

ip source-route

!

!

ip cef

!

!

ip dhcp pool BR-Phones

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.1

   option 150 ip 192.168.1.1

!

!

no ipv6 cef

multilink bundle-name authenticated

!

!

!

!

!

!

!

!

!

!

!

voice-card 0

!

crypto pki token default removal timeout 0

!

!

!

!


!

!

interface GigabitEthernet0/0

ip address 192.168.1.1 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/3/0

ip address 172.16.1.2 255.255.255.0

!

interface Serial0/3/1

no ip address

shutdown

clock rate 125000

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

!

!

!

!

control-plane

!

!

!

!

mgcp profile default

!

!

!

!

telephony-service

max-ephones 5

max-dn 20

ip source-address 192.168.1.1 port 2000

max-conferences 8 gain -6

transfer-system full-consult

create cnf-files version-stamp Jan 01 2002 00:00:00

!

!

ephone-dn  1  dual-line

number 5552001

!

!

!

line con 0

line aux 0

line vty 0 4

login

transport input all

!

scheduler allocate 20000 1000

end

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
RalphSmithIII Fri, 03/16/2012 - 16:31
User Badges:

Additionally this is the version of code I am running on both ISR's.

VoiceR2#sh ver

Cisco IOS Software, 2800 Software (C2800NM-IPVOICEK9-M), Version 15.1(3)T2, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2011 by Cisco Systems, Inc.

Compiled Wed 10-Aug-11 05:17 by prod_rel_team


ROM: System Bootstrap, Version 12.3(8r)T7, RELEASE SOFTWARE (fc1)


VoiceR2 uptime is 1 hour, 9 minutes

System returned to ROM by reload at 22:19:41 UTC Fri Mar 16 2012

System restarted at 18:21:28 UTC Fri Mar 16 2012

System image file is "flash:c2800nm-ipvoicek9-mz.151-3.T2.bin"

Last reload type: Normal Reload

AlykhovEV Fri, 03/16/2012 - 16:48
User Badges:

Configure SCCP to enable it like this:

sccp local GigabitEthernet2/0

sccp ccm 10.21.0.1 identifier 1 version 7.0

sccp


Also will be good if you will place firmware updates for phones:

tftp-server flash0:SCCP11.8-4-2S.loads

tftp-server flash0:SCCP31.8-4-2S.loads

tftp-server flash0:SCCP41.8-4-2S.loads

tftp-server flash0:SCCP42.8-4-2S.loads

tftp-server flash0:SCCP45.8-4-2S.loads

tftp-server flash0:SCCP70.8-4-2S.loads

tftp-server flash0:SCCP75.8-4-2S.loads

telephony-service

load 7906 SCCP11.8-4-2S.loads

load 7911 SCCP11.8-4-2S.loads

load 7931 SCCP31.8-4-2S.loads

load 7941 SCCP41.8-4-2S.loads

load 7942 SCCP42.8-4-2S.loads

load 7945 SCCP45.8-4-2S.loads

load 7961 SCCP41.8-4-2S.loads

load 7962 SCCP42.8-4-2S.loads

load 7965 SCCP45.8-4-2S.loads

load 7970 SCCP70.8-4-2S.loads

load 7971 SCCP70.8-4-2S.loads

load 7975 SCCP75.8-4-2S.loads


and don't forget to use the command "create cnf-files" after that


Sent from Cisco Technical Support iPad App

RalphSmithIII Fri, 03/16/2012 - 16:55
User Badges:

Thank you for the fast reply, and I will certaintly try your suggestion but I shouldn't need to use any of that configuration to get the phones to register, that registered yesterday.  My only logical reason for that is because I didn't use any of your suggested commands and it registered fine.  I feel like I'm missing something real obvious yet I can't nail it down.

AlykhovEV Fri, 03/16/2012 - 17:14
User Badges:

You must have this commands in basic configuration (example):

interface GigabitEthernet0/0

ip address 10.21.0.1 255.255.128.0

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.21.0.1


Sent from Cisco Technical Support iPad App

RalphSmithIII Fri, 03/16/2012 - 17:26
User Badges:

Again thanks for the reply but I'm not quite sure if you've even read my original post.  What you are posting has nothing to do with my original post or situation.  I am simply trying to get 1 Cisco IP phone to register with CME 8.0 running on a ISR 2821 router. 


Only thing cabled together are:


ISR Gi0/0 to 3560 on FA0/1

Cisco IP Phone 7940 or 7960 to 3560 on FA0/2


That's it.

heathrw Fri, 03/16/2012 - 20:55
User Badges:
  • Bronze, 100 points or more

Your config has a line config "ephone-dn" but you need he ephone command add the Mac address an the type (model) and add the button 1:x where x is the ephone-dn x in your config.




Sent from Cisco Technical Support iPhone App

RalphSmithIII Sat, 03/17/2012 - 05:30
User Badges:

I do not believe these commands are needed if I am using auto registration, however, I went ahead and turned off auto-reg-ephone and added the commands.


Here is my output:

VoiceR2#sh ephone


ephone-1[0] Mac:001C.58A2.8C4C TCP socket:[-1] activeLine:0 whisperLine:0 UNREGISTERED

mediaActive:0 whisper_mediaActive:0 startMedia:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:0

IP:0.0.0.0* 0 Unknown 0  keepalive 0 max_line 0 available_line 0

Preferred Codec: g711ulaw

Lpcor Type: none

heathrw Sat, 03/17/2012 - 16:10
User Badges:
  • Bronze, 100 points or more

Hi Ralph,


The configuration posted did not reflect auto registration enabled or have an extension range, could have been chopped off.


From what I can see if you have the basic telephony service, dhcp, ephone and ephone-dn and your handsets are running SCCP you should get basic registration.


If you have physical access to your router, erase the config (or remove ALL the VOIP components) apply your IP addressing, routing etc (everything except voip) then run the 'telephony-service setup' command from global configuration this will run you through the voip setup wizard (and from memory will do the DHCP also) with auto registration enabled.


Also check out the Unified CM admin guide.


http://www.cisco.com/en/US/partner/docs/voice_ip_comm/cucme/admin/configuration/guide/cmeadm.html

RalphSmithIII Sun, 03/18/2012 - 10:56
User Badges:

Thanks for the suggestion Heath.  Unfortunatlely with the version of code I'm running the setup command is deprecated.  I'm starting to wonder if theres an issue with the file location and how the flash memory is setup on these routers.  I had to format one of the flash memory cards before, but I can't imagine it would change how CME locates the files it needs.


When I copied over the full CME file suite, I extracted the .tar file into flash, and I'm wondering if it needed to be extracted into system, if there's a difference.  Regardless, I should be able to tell the router where to look for the files it needs via command-line by using the tftp-server:(location) command.


It's killing me because I've had both of these routers register the same phones before yet I can't get either one to work now.  I'll take your advice and wipe them completely clean again, then start from scratch and see what happens.  It's my understanding that auto registration is enabled by default, but I still issued the command under telephony-servce: auto-reg-ephone.


I've even hardcoded one of the phones via mac-address and still have nothing.

paolo bevilacqua Sat, 03/17/2012 - 01:56
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Evgeny Alykhov wrote:


You must have this commands in basic configuration (example):

interface GigabitEthernet0/0

ip address 10.21.0.1 255.255.128.0

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.21.0.1


Sent from Cisco Technical Support iPad App

No, these commands are not needed.

RalphSmithIII Sat, 03/17/2012 - 05:34
User Badges:

Interesting enough, I have issued the commands:


telephony-service

ip source-address


yet I am not seeing the SEPDEFAULT.cnf or XMLDefault.cnf.xml in flash.


Does anyone know why that is?

RalphSmithIII Sat, 03/17/2012 - 05:43
User Badges:

And I answer that question.  The SEP and XML Default files are located in /its/vrfi and not simply in flash:/


Could that be my issue as to why the phones won't register?  Are these files needed for the registration process to happen?

paolo bevilacqua Sun, 03/18/2012 - 11:13
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

They can be located in either place depending on configuration of "cnf-file location". Flash makes a faster star on router reaload, and other advantages.


They are needed and you can take "debug tftp events" with "term mon" to see phones pulling them.

RalphSmithIII Tue, 03/20/2012 - 09:51
User Badges:

I'm not 100% sure what I added to get the phones to register, and I'll be going back over my config and slowly removing commands until I nail it down but this config works for now.


Remember, I was only having an issue with REGISTRATION, not dial-peers, routing, etc.  I can now place calls from one network to the other.  Before, I couldn't get a single IP phone to even register.


Basically, I added the:

voice register global

mode cme

load 7960-7940 P0S3-07-5-00

create profile sync 0001561428275555


and


auto assign 1 to 20



VoiceR1#sh run

Building configuration...



Current configuration : 1868 bytes

!

! Last configuration change at 19:27:32 UTC Mon Mar 19 2012

!

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname VoiceR1

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

!

dot11 syslog

ip source-route

!

!

ip cef

!

ip dhcp excluded-address 10.1.1.1 10.1.1.99

!

ip dhcp pool VOICE

   network 10.1.1.0 255.255.255.0

   default-router 10.1.1.1

   option 150 ip 10.1.1.1

!

!

no ipv6 cef

multilink bundle-name authenticated

!

!

!

!

!

!

!

!

voice register global

mode cme

load 7960-7940 P0S3-07-5-00

create profile sync 0001561428275555

!

!

!

!

voice-card 0

!

crypto pki token default removal timeout 0

!

!

!

!

license udi pid CISCO2821 sn FTX1221A01Y

license accept end user agreement

!

!

!

!

!

!

!

interface GigabitEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 10.1.1.1 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0/0

ip address 172.16.1.1 255.255.255.0

clock rate 125000

!

interface Serial0/0/1

no ip address

shutdown

clock rate 125000

!

interface Serial0/2/0

no ip address

shutdown

!

!

router eigrp 1

network 10.0.0.0

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 172.16.1.2

!

!

!

!

control-plane

!

!

!

!

mgcp profile default

!

!

dial-peer voice 1 voip

destination-pattern 555....

session target ipv4:172.16.1.2

!

!

!

telephony-service

max-ephones 10

max-dn 20

ip source-address 10.1.1.1 port 2000

auto assign 1 to 20

max-conferences 8 gain -6

transfer-system full-consult

create cnf-files version-stamp Jan 01 2002 00:00:00

!

!

ephone-dn  1

number 5551234

!

!

ephone  1

mac-address 0007.8513.2076

type 7960

button  1:1

!

!

!

!

line con 0

line aux 0

line vty 0 4

login

transport input all

!

scheduler allocate 20000 1000

end

Actions

This Discussion