×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Sync Archive failed LMS 3.2 using TACACS

Answered Question
Mar 19th, 2012
User Badges:

Dear All,


Iam using LMS 3.2. In short, there is 2 type of router, 2800series and 2900series.

These device already join to TACACS server. When I try to sync archive I got:

- failed on 2900series

- successful on 2800series


I have doing same config (credential, snmp, protocol for sync archive), for those device on ciscoworks but why I find the error??

Attachment: 
Correct Answer by Vinod Arya about 5 years 5 months ago

Usually it is essential to configure the $NMSROOT\objects\cmf\data\TacacsPrompts.ini file. As with tacacs+ Auth you can also define custom login username and password prompt, hence this file is important to be configured, only in case of Telnet not SSH.


So just check the login prompt you get in your device when you try to do telnet and mention the same in you

TacacsPrompts.ini file.


Example:


>Following is the content of TacacsPrompts.ini :


[TELNET]

USERNAME_PROMPT=

PASSWORD_PROMPT=


> Following is the username and pasword propmt for my device :

> As per this please modify the file as :


[TELNET]

USERNAME_PROMPT=Username:

PASSWORD_PROMPT=Password:


Just save and try to run the job again for failing device.





.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Vinod Arya Thu, 03/22/2012 - 04:24
User Badges:
  • Cisco Employee,

Usually it is essential to configure the $NMSROOT\objects\cmf\data\TacacsPrompts.ini file. As with tacacs+ Auth you can also define custom login username and password prompt, hence this file is important to be configured, only in case of Telnet not SSH.


So just check the login prompt you get in your device when you try to do telnet and mention the same in you

TacacsPrompts.ini file.


Example:


>Following is the content of TacacsPrompts.ini :


[TELNET]

USERNAME_PROMPT=

PASSWORD_PROMPT=


> Following is the username and pasword propmt for my device :

> As per this please modify the file as :


[TELNET]

USERNAME_PROMPT=Username:

PASSWORD_PROMPT=Password:


Just save and try to run the job again for failing device.





.

budi-afianto Tue, 04/10/2012 - 02:58
User Badges:

Dear Vinod,


I have doning this on tacacsprompt.ini

[TELNET]

USERNAME_PROMPT=Username:,username:,login:,TACACS User Name:

PASSWORD_PROMPT=Password:,password:,passwd:,TACACS Password:


It work only on Cisco Router 2800 series.

But failed when fetch config on Cisco Router 2900 series.

The Problem is, why I can't fetch or sync config on 2900 series.

Vinod Arya Tue, 04/10/2012 - 04:02
User Badges:
  • Cisco Employee,

What is the error it fails with? Try to run a Crendential verification job from RME > Device Management  > CDA to see if it can pass telnet credentials successfully.


Can you show the screenshot of the username and owd prompt you get during login for 2900 device?


Mostly if it is possible for you to try SSH use that as this ini file is not used in SSH for login, which should make sync-acrhive successful.


-Thanks

Vinod

budi-afianto Mon, 10/22/2012 - 00:57
User Badges:

Hi Vinod,

I already Upgrade LMS to LMS 4.1, now I can fetch config for 2900 device.

I also configure this on tacacsprompt.ini on LMS 4.1.

[TELNET]

USERNAME_PROMPT=Username:,username:

PASSWORD_PROMPT=Password:,password:


Thanks For Your Answer.

Vinod Arya Mon, 10/22/2012 - 01:07
User Badges:
  • Cisco Employee,

Please that you moved to the more recent version of LMS and the problematic device is working now.


You can close this thread if the issue is resolved.

Actions

This Discussion