C20 Codec entered maintenance shell mode

Unanswered Question
Mar 26th, 2012

Hi,

My C20 entered maintenance shell mode and i am just getting the below options on CLI over SSH or Serial.

'factoryreset’, ‘selectsw’, ‘reboot’, ‘version’, ‘pkgverify’, ‘help’ and ‘log’.

NO GUI ACCESS....

Maintenance shell

If the system detects a situation where it is not possible to run the main application it will reboot, if the

reboot is unsuccessful the system will go into a ‘maintenance mode’. In this mode the following will

apply:

 The system will boot up without starting the main application, hence there will be no video output

or GUI on the screen.

 In this mode it will be possible to connect to the system over a serial connection or SSH (IP) to

access a reduced API, which can be used for faultfinding. In this mode the following commands

are available: ‘factoryreset’, ‘selectsw’, ‘reboot’, ‘version’, ‘pkgverify’, ‘help’ and ‘log’.

Please suggest how to recover this Codec.

Tried factory reset... no use

Pkgverify yield ---- error

Logs here...

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2012.03.26 19:37:20 =~=~=~=~=~=~=~=~=~=~=~=

log

============ /var/log/eventlog/all.log =============

Jan  1 00:00:57 arm2 videogw: Product information

Jan  1 00:00:57 arm2 videogw: Orion

Jan  1 00:00:57 arm2 videogw: Main board: E

Jan  1 00:00:57 arm2 videogw: CPU id: 2

Jan  1 00:00:57 arm2 videogw: 169.254.0.1:7834

Jan  1 00:00:57 arm0 videogw: Product information

Jan  1 00:00:57 arm0 videogw: Orion

Jan  1 00:00:57 arm0 videogw: Main board: E

Jan  1 00:00:57 arm0 videogw: CPU id: 0

Jan  1 00:00:57 arm0 videogw: 169.254.0.1:7834

Mar 26 12:38:39 (none) main: Setting version serial id 0x204

Mar 26 12:38:39 (none) main: TC5.1.0.280662

Mar 26 12:38:39 (none) main: SW Release Date: 2012-02-14

Mar 26 12:38:39 (none) main: Board name: 101551, variant: default

Mar 26 12:38:39 (none) main: Serial number: F1AN42C00269

Mar 26 12:38:39 (none) main: Releasekey verification OK.

Mar 26 12:38:39 (none) main: Product information

Mar 26 12:38:39 (none) main: Orion

Mar 26 12:38:39 (none) main: Main board: E

Mar 26 12:38:39 (none) main: Configure 1 FPGA(s) with /tmp/fpga_config_a

Mar 26 12:38:40 (none) main: File last modified: 2012-01-03 13:39:50, MD5: a1d2fee0cb7fb33538648871132f4f92, SVN compact version number: ['16627'], SVN URL: svn://svn/hw/hdl/trunk, Quartus Version 11.0 Build 208 07/03/2011 Service Pack 1 SJ Full Version, Windows, Windows-2003Server-5.2.3790-SP2, AMD64, 64bit

Mar 26 12:38:41 (none) main: Configure 1 FPGA(s) with /tmp/fpga_config_b

Mar 26 12:38:41 (none) main: File last modified: 2012-01-03 11:40:55, MD5: 24ab18463e572a47ad7d8d9af69c8865, SVN compact version number: ['16627'], SVN URL: svn://svn/hw/hdl/trunk, Quartus Version 11.0 Build 208 07/03/2011 Service Pack 1 SJ Full Version, Windows, Windows-2003Server-5.2.3790-SP2, AMD64, 64bit

Mar 26 12:38:42 (none) main: Configure 0 FPGA(s) with /tmp/fpga_config_c

Mar 26 12:38:42 (none) main: Configure 0 FPGA(s) with /tmp/fpga_config_d

Mar 26 12:38:42 (none) main: FPGA(s) configured OK

Mar 26 12:38:42 (none) main: 169.254.0.1:7834

Mar 26 12:39:23 arm2 videogw: bootmon_init1: Timeout reached, returning!

Mar 26 12:39:23 arm2 videogw: Failed to talk to administrator at 169.254.0.1:7834

Mar 26 12:39:23 arm2 videogw: Failed to initialize administrator client (server: 169.254.0.1:7834)!

Mar 26 12:39:23 arm2 videogw: Received signal SIGABRT (6) in thread 0x40098000, TID 1020

Mar 26 12:39:23 arm2 videogw: Registers:

Mar 26 12:39:23 arm2 videogw: R0:     00000000 R1:   000003fc R2:    00000006 R3:   000003fc

Mar 26 12:39:23 arm2 videogw: R4:     00000006 R5:   40615bdc R6:    40615000 R7:   0000010c

Mar 26 12:39:23 arm2 videogw: R8:     00000bdc R9:   00000000 R10:   40098000 FP:   be9bb97c

Mar 26 12:39:23 arm2 videogw: PC:     4050f6f8 IP:   be9bb980 SP:    be9bb964 LR:   4050f6c4

Mar 26 12:39:23 arm2 videogw: ERR:    00000000 CPSR: 20000010 FAULT: 00000000 TRAP: 00000006

Mar 26 12:39:23 arm2 videogw: OLDMSK: 00000000

Mar 26 12:39:23 arm2 videogw: Backtrace:

Mar 26 12:39:23 arm2 videogw: /apps/videogw() [0x7b674]

Mar 26 12:39:23 arm2 videogw: /lib/libc.so.6(gsignal+0x14) [0x4050f6c4]

Mar 26 12:39:23 arm2 videogw: /lib/libc.so.6(abort+0x1b8) [0x40510da4]

Mar 26 12:39:23 arm2 videogw: /apps/videogw(applstrtTaskEntry+0x25c) [0x210a8]

Mar 26 12:39:23 arm2 videogw: /lib/libc.so.6(__libc_start_main+0x120) [0x404f95e0]

Mar 26 12:39:23 arm2 videogw: /apps/videogw() [0x20a9c]

Mar 26 12:39:23 arm2 videogw: End of backtrace:

Mar 26 12:39:23 arm2 videogw: Task                Type Pri  TID  STACK PTR  %CPU %PROC TIME+     STACK

Mar 26 12:39:23 arm2 videogw: applstart            OT   0   1020 (nil)  0.4 99.9  0:00.449     0/0

Mar 26 12:39:23 arm2 videogw: reaperT              OT   0   1048 0x83c000  0.0  0.1  0:00.000  5280/16384

Mar 26 12:39:23 arm2 videogw: --------------------------------------------------------------------------------

Mar 26 12:39:23 arm2 videogw: Module number too high, something is amiss.

Mar 26 12:39:23 arm2 videogw: Active FSM: ***(0)

Mar 26 12:39:24 arm0 videogw: bootmon_init1: Timeout reached, returning!

Mar 26 12:39:24 arm0 videogw: Failed to talk to administrator at 169.254.0.1:7834

Mar 26 12:39:24 arm0 videogw: Failed to initialize administrator client (server: 169.254.0.1:7834)!

Mar 26 12:39:24 arm0 videogw: Received signal SIGABRT (6) in thread 0x40096000, TID 1017

Mar 26 12:39:24 arm0 videogw: Registers:

Mar 26 12:39:24 arm0 videogw: R0:     00000000 R1:   000003f9 R2:    00000006 R3:   000003f9

Mar 26 12:39:24 arm0 videogw: R4:     00000006 R5:   405dcbdc R6:    405dc000 R7:   0000010c

Mar 26 12:39:24 arm0 videogw: R8:     00000bdc R9:   00000000 R10:   40096000 FP:   beb1c97c

Mar 26 12:39:24 arm0 videogw: PC:     404d66f8 IP:   beb1c980 SP:    beb1c964 LR:   404d66c4

Mar 26 12:39:24 arm0 videogw: ERR:    00000000 CPSR: 20000010 FAULT: 00000000 TRAP: 00000006

Mar 26 12:39:24 arm0 videogw: OLDMSK: 00000000

Mar 26 12:39:24 arm0 videogw: Backtrace:

Mar 26 12:39:24 arm0 videogw: /apps/videogw() [0x7b674]

Mar 26 12:39:24 arm0 videogw: /lib/libc.so.6(gsignal+0x14) [0x404d66c4]

Mar 26 12:39:24 arm0 videogw: /lib/libc.so.6(abort+0x1b8) [0x404d7da4]

Mar 26 12:39:24 arm0 videogw: /apps/videogw(applstrtTaskEntry+0x25c) [0x210a8]

Mar 26 12:39:24 arm0 videogw: /lib/libc.so.6(__libc_start_main+0x120) [0x404c05e0]

Mar 26 12:39:24 arm0 videogw: /apps/videogw() [0x20a9c]

Mar 26 12:39:24 arm0 videogw: End of backtrace:

Mar 26 12:39:24 arm0 videogw: Task                Type Pri  TID  STACK PTR  %CPU %PROC TIME+     STACK

Mar 26 12:39:24 arm0 videogw: applstart            OT   0   1017 (nil)  0.4 99.9  0:00.449     0/0

Mar 26 12:39:24 arm0 videogw: reaperT              OT   0   1053 0x2e4000  0.0  0.1  0:00.000  5280/16384

Mar 26 12:39:24 arm0 videogw: --------------------------------------------------------------------------------

Mar 26 12:39:24 arm0 videogw: Module number too high, something is amiss.

Mar 26 12:39:24 arm0 videogw: Active FSM: ***(0)

Mar 26 12:39:42 (none) main: bootmon_init1: Timeout reached, returning!

Mar 26 12:39:42 (none) main: Failed to talk to administrator at 169.254.0.1:7834

Mar 26 12:39:42 (none) main: Failed to initialize administrator client (server: 169.254.0.1:7834)!

Mar 26 12:39:42 (none) main: Backtrace:

Mar 26 12:39:42 (none) main: /apps/main(obtain_backtrace+0x1c) [0x110335bc]

Mar 26 12:39:42 (none) main: /apps/main(dump_backtrace_current_task+0x28) [0x1103360c]

Mar 26 12:39:42 (none) main: /apps/main() [0x11032d3c]

Mar 26 12:39:42 (none) main: /lib/libc.so.6(+0x3afe4) [0xf1d0fe4]

Mar 26 12:39:42 (none) main: /lib/libc.so.6(on_exit+0) [0xf1d1098]

Mar 26 12:39:42 (none) main: /apps/main(applstrtTaskEntry+0x42c) [0x10437c94]

Mar 26 12:39:42 (none) main: /apps/main(main+0x1c) [0x10418fec]

Mar 26 12:39:42 (none) main: /lib/libc.so.6(+0x21c14) [0xf1b7c14]

Mar 26 12:39:42 (none) main: /lib/libc.so.6(+0x21db0) [0xf1b7db0]

Mar 26 12:39:42 (none) main: End of backtrace:

============ /var/log/eventlog/main.log =============

Mar 26 12:38:39 (none) main: Setting version serial id 0x204

Mar 26 12:38:39 (none) main: TC5.1.0.280662

Mar 26 12:38:39 (none) main: SW Release Date: 2012-02-14

Mar 26 12:38:39 (none) main: Board name: 101551, variant: default

Mar 26 12:38:39 (none) main: Serial number: F1AN42C00269

Mar 26 12:38:39 (none) main: Releasekey verification OK.

Mar 26 12:38:39 (none) main: Product information

Mar 26 12:38:39 (none) main: Orion

Mar 26 12:38:39 (none) main: Main board: E

Mar 26 12:38:39 (none) main: Configure 1 FPGA(s) with /tmp/fpga_config_a

Mar 26 12:38:40 (none) main: File last modified: 2012-01-03 13:39:50, MD5: a1d2fee0cb7fb33538648871132f4f92, SVN compact version number: ['16627'], SVN URL: svn://svn/hw/hdl/trunk, Quartus Version 11.0 Build 208 07/03/2011 Service Pack 1 SJ Full Version, Windows, Windows-2003Server-5.2.3790-SP2, AMD64, 64bit

Mar 26 12:38:41 (none) main: Configure 1 FPGA(s) with /tmp/fpga_config_b

Mar 26 12:38:41 (none) main: File last modified: 2012-01-03 11:40:55, MD5: 24ab18463e572a47ad7d8d9af69c8865, SVN compact version number: ['16627'], SVN URL: svn://svn/hw/hdl/trunk, Quartus Version 11.0 Build 208 07/03/2011 Service Pack 1 SJ Full Version, Windows, Windows-2003Server-5.2.3790-SP2, AMD64, 64bit

Mar 26 12:38:42 (none) main: Configure 0 FPGA(s) with /tmp/fpga_config_c

Mar 26 12:38:42 (none) main: Configure 0 FPGA(s) with /tmp/fpga_config_d

Mar 26 12:38:42 (none) main: FPGA(s) configured OK

Mar 26 12:38:42 (none) main: 169.254.0.1:7834

Mar 26 12:39:42 (none) main: bootmon_init1: Timeout reached, returning!

Mar 26 12:39:42 (none) main: Failed to talk to administrator at 169.254.0.1:7834

Mar 26 12:39:42 (none) main: Failed to initialize administrator client (server: 169.254.0.1:7834)!

Mar 26 12:39:42 (none) main: Backtrace:

Mar 26 12:39:42 (none) main: /apps/main(obtain_backtrace+0x1c) [0x110335bc]

Mar 26 12:39:42 (none) main: /apps/main(dump_backtrace_current_task+0x28) [0x1103360c]

Mar 26 12:39:42 (none) main: /apps/main() [0x11032d3c]

Mar 26 12:39:42 (none) main: /lib/libc.so.6(+0x3afe4) [0xf1d0fe4]

Mar 26 12:39:42 (none) main: /lib/libc.so.6(on_exit+0) [0xf1d1098]

Mar 26 12:39:42 (none) main: /apps/main(applstrtTaskEntry+0x42c) [0x10437c94]

Mar 26 12:39:42 (none) main: /apps/main(main+0x1c) [0x10418fec]

Mar 26 12:39:42 (none) main: /lib/libc.so.6(+0x21c14) [0xf1b7c14]

Mar 26 12:39:42 (none) main: /lib/libc.so.6(+0x21db0) [0xf1b7db0]

Mar 26 12:39:42 (none) main: End of backtrace:

============ /var/log/eventlog/videogw0.log =============

Jan  1 00:00:57 arm0 videogw: Product information

Jan  1 00:00:57 arm0 videogw: Orion

Jan  1 00:00:57 arm0 videogw: Main board: E

Jan  1 00:00:57 arm0 videogw: CPU id: 0

Jan  1 00:00:57 arm0 videogw: 169.254.0.1:7834

Mar 26 12:39:24 arm0 videogw: bootmon_init1: Timeout reached, returning!

Mar 26 12:39:24 arm0 videogw: Failed to talk to administrator at 169.254.0.1:7834

Mar 26 12:39:24 arm0 videogw: Failed to initialize administrator client (server: 169.254.0.1:7834)!

Mar 26 12:39:24 arm0 videogw: Received signal SIGABRT (6) in thread 0x40096000, TID 1017

Mar 26 12:39:24 arm0 videogw: Registers:

Mar 26 12:39:24 arm0 videogw: R0:     00000000 R1:   000003f9 R2:    00000006 R3:   000003f9

Mar 26 12:39:24 arm0 videogw: R4:     00000006 R5:   405dcbdc R6:    405dc000 R7:   0000010c

Mar 26 12:39:24 arm0 videogw: R8:     00000bdc R9:   00000000 R10:   40096000 FP:   beb1c97c

Mar 26 12:39:24 arm0 videogw: PC:     404d66f8 IP:   beb1c980 SP:    beb1c964 LR:   404d66c4

Mar 26 12:39:24 arm0 videogw: ERR:    00000000 CPSR: 20000010 FAULT: 00000000 TRAP: 00000006

Mar 26 12:39:24 arm0 videogw: OLDMSK: 00000000

Mar 26 12:39:24 arm0 videogw: Backtrace:

Mar 26 12:39:24 arm0 videogw: /apps/videogw() [0x7b674]

Mar 26 12:39:24 arm0 videogw: /lib/libc.so.6(gsignal+0x14) [0x404d66c4]

Mar 26 12:39:24 arm0 videogw: /lib/libc.so.6(abort+0x1b8) [0x404d7da4]

Mar 26 12:39:24 arm0 videogw: /apps/videogw(applstrtTaskEntry+0x25c) [0x210a8]

Mar 26 12:39:24 arm0 videogw: /lib/libc.so.6(__libc_start_main+0x120) [0x404c05e0]

Mar 26 12:39:24 arm0 videogw: /apps/videogw() [0x20a9c]

Mar 26 12:39:24 arm0 videogw: End of backtrace:

Mar 26 12:39:24 arm0 videogw: Task                Type Pri  TID  STACK PTR  %CPU %PROC TIME+     STACK

Mar 26 12:39:24 arm0 videogw: applstart            OT   0   1017 (nil)  0.4 99.9  0:00.449     0/0

Mar 26 12:39:24 arm0 videogw: reaperT              OT   0   1053 0x2e4000  0.0  0.1  0:00.000  5280/16384

Mar 26 12:39:24 arm0 videogw: --------------------------------------------------------------------------------

Mar 26 12:39:24 arm0 videogw: Module number too high, something is amiss.

Mar 26 12:39:24 arm0 videogw: Active FSM: ***(0)

============ /var/log/eventlog/videogw2.log =============

Jan  1 00:00:57 arm2 videogw: Product information

Jan  1 00:00:57 arm2 videogw: Orion

Jan  1 00:00:57 arm2 videogw: Main board: E

Jan  1 00:00:57 arm2 videogw: CPU id: 2

Jan  1 00:00:57 arm2 videogw: 169.254.0.1:7834

Mar 26 12:39:23 arm2 videogw: bootmon_init1: Timeout reached, returning!

Mar 26 12:39:23 arm2 videogw: Failed to talk to administrator at 169.254.0.1:7834

Mar 26 12:39:23 arm2 videogw: Failed to initialize administrator clien

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 4.5 (2 ratings)
Magnus Ohm Mon, 03/26/2012 - 08:03

Hi

Have youtried factory resetting the systme using this procedure:

1) When powered down, pressing the power switch for fifteen seconds (until the green LED in the front of the system turns red.)

2) Now confirm the reset by two short presses within the next five seconds.

Hope this helps bringing the unit up again. Let us know.

Sent from Cisco Technical Support iPhone App

rameez.rhm Mon, 03/26/2012 - 08:50

$hi magnus,

I tried that. But still it gets in to maintenance shell.

Since this was factory shipped with TC 5.x, I am unable to use selectsw to load a different image.

Is there a way I can load a image from m.shell using tftp or xmodem.

Martin Koch Mon, 03/26/2012 - 09:06

Hello Rameez!

Just out of curiosity, did you do something "special" with the codec?

As you paste contents of the log files, it looks you can still log in the system as root?

Then you could try to delete the config.db file and powercycle the endpoint afterwards and see if that helped

(login as root and execute): rm -v /mnt/base/active/config.db


If that did not help, see here (tftp restore):

https://supportforums.cisco.com/docs/DOC-23161

Please rate the Answers using the stars underneath and set the thread answered if it is.

rameez.rhm Mon, 03/26/2012 - 09:29

No, I just typed logs in m.shell....... And got those outputs.

I saw in release of tc5 n,otes that m.shell is a new mode available for troubleshoot

But the options over there is very less.

I will try to delete config.db and see how it goes.

Thank u.

vivsing2 Mon, 03/26/2012 - 15:08

Hi Rameez,

Please let me know after completing above step, if it fail then we have method to upload fresh software image on codec using TFTP, DHCP server using console connection with C20.

Regards,

Vivek

thobonho Mon, 03/26/2012 - 12:46

Hi Rameez,

Your best chance is to use the selectsw command to boot the alternate partition.

First issue "selectsw" to know which partition is currently in use, then type "selectsw image1" for example to select the other partition.

Finally, use the command "reboot" to restart your codec and hope for the best!

--

Thomas

mubakhta Mon, 03/26/2012 - 15:14

Hi Rameez,

Basically the Maintenance Mode had been introduced so that we can troubleshoot and recover the codecs in case of any corruption of the software image.

Doing a factory reset would not help to resolve the issue, as I think in this case the issue seems to be that your software image is corrupted. The software image corruption could be caused by any failure, it maybe an unsuccessful attempt to upgrade the codec or some files getting corrupted in the root folder of the codec.

The best way to recover this codec is to either revert it to the working image which was previously being used. However, it depends if the image is present or not. First thing you should check on the codec is run the command :

selectsw

It would list the images on the codec, if you see two images, it would show one as active. Now type this command to jump to the previous inactive image :

selectsw (name of the image wihch is inactive, ie image1 or image2)

Once, you do that, the codec should reboot. Once the codec has rebooted, it should come back normally.

If the case is that you only see one image in the selectsw command, then you would need to install a fresh image. We have a documentation available which would help you to install a fresh image. Refer to the following link which would give you the procedure to do that :

https://supportforums.cisco.com/docs/DOC-23161

Hope this helps.

Regards,

Mubashshir Akhtar

Danny De Ridder Sat, 04/21/2012 - 10:41

The main processor failed to talk to the ARM processors in due time during boot, so main program exits and after some time we drop into the maintenance shell. There are not that many options in maintenance shell, so it would be better to gain access to the box using root account. Factory default root password should be TANDBERG, no? If not, do you have console access to this device? The pkgverify returning error does not look good either.

Actions

Login or Register to take actions

This Discussion

Posted March 26, 2012 at 7:19 AM
Stats:
Replies:8 Avg. Rating:4.5
Views:1051 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard