UCSM 2.0(1t) doesn't like Java 1.7

Answered Question
Mar 26th, 2012


I have no luck whatsoever with starting UCSM 2.0(1t) on a Windows 2003 R2 (32-bit) machine: it says "Java 1.7 detected, Java 1.6 (or higher) required".

Release notes say: "The Cisco UCS Manager GUI is a Java-based application that requires Sun JRE 1.6 or higher"

So what's the bottom line - shall I expect UCSM 2.0 to work with Java 1.7, or not?



I have this problem too.
0 votes
Correct Answer by Robert Burns about 3 years 3 months ago

Javea 1.7 is supported on 2.0(3) releases and newer.  2.0(3) is currently avaialble for download from CCO.



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.2 (6 ratings)
Radek Kubka Mon, 03/26/2012 - 08:56

Tried this, so the UCSM application got downloaded & installed from scratch, yet the problem remains:

abbharga Mon, 03/26/2012 - 10:02


What is the OS on the client you are trying to access the UCSM from?

Is the java a 32-bit or 64-bit?

What browser are you trying to launch the UCSM from?


Radek Kubka Mon, 03/26/2012 - 10:12

Hi Abhinav,

It's Windows 2003 R2 SE SP2 32-bit.

The browser is IE6, but the UCSM application seems to be downloading & installing fine (there is a nice shortcut to UCSM on the desktop) - it just doesn't want to start.



Radek Kubka Tue, 03/27/2012 - 03:41

Anyone with any hints (other than downgading JRE, which I'd like to avoid)?

padramas Tue, 03/27/2012 - 07:42


How about upgrading UCSM to 2.01w :-)

There is a known internal defect which causes UCSM to fail with JRE 1.7 and is fixed in 2.0.1w and above version.

To isolate the cause, can you try launching UCSM from a system running JRE 1.6 and verify the behavior ?


ajeckerle Tue, 05/08/2012 - 06:45

I'm running 2.01(w) and just updated my Win7 x64 machine to Java 1.7 from 1.6 and now UCSM is broken with the same error posted above.  I've cleaned the Java cache, uninstalled/reinstalled JRE with no success. It seems Oracle has removed downloads for JRE 1.6 so downgrading isn't an option anymore.  Is 1.7 really supposed to work with UCSM 2.01(w)?

Win7 SP1 x64 launching from IE9

Robert Burns Mon, 06/25/2012 - 15:00

Thanks for the direct like Kris - much easier!

1.7 support will be in Del Mar (2.1) and beyond.


Zaira Vega Thu, 06/28/2012 - 10:07

Did you remove Java 1.7 before/after installing Jave 1.6?

Java 1.7 should be completely removed

Felipe de Mello Fri, 03/08/2013 - 09:00

In Control Panel > Java, do you have the keep temporary files setting enabled in Temporary Internet Files? I was able to replicate the error you're seeing by disabling temporary files in java 1.6.

mick-kehoe Fri, 08/24/2012 - 04:42

Hi Radek,

I assume you and I are in the same boat.... Cisco UCSM needs 1.6 and Netapp tools require 1.7.... Bloody annoying....

Still no fix...??


Correct Answer
Robert Burns Fri, 08/24/2012 - 05:47

Javea 1.7 is supported on 2.0(3) releases and newer.  2.0(3) is currently avaialble for download from CCO.



mick-kehoe Mon, 08/27/2012 - 05:12

Hi robert,

Thanks for that its now resolved and working

Michael .

Radek Kubka Fri, 08/24/2012 - 09:12

Hi Michael,

I've lost access to my UCS toys since, as they got 'repurposed' - but I would trust Robert on this one: if he says it's fixed, it probably means it really is!



mick-kehoe Mon, 08/27/2012 - 05:05

Hi Radek,

Ive  got a full fleaxPod in my Demolab so I am now upgreading to 2.0(3) now.  Ill let you know when its done... Im sure it will work and will be  better then running a VM for an older version..

You comming to Dublin in November??


ikent Wed, 09/26/2012 - 16:06

As an alternative, you can always launch java webstart manually - from the dos command line.  This gives you the flexibility to use the JVM of choice with the jnlp application.  (for example, you could use java 1.6 for UCS emulator without downgrading your workstation from 1.7).

It is quite simple:

1) Launch JRE console from your java installation (something like C:\Program Files\Java\jre 6\bin\javacl.exe).  Under Java/View panel - only select Java 1.6. 

2) Launch the jnlp manually.  For example:

C:\Program Files\Java\jre6\bin\javaws.exe "ucsm.jnlp"



sudeep.shetty@a... Sun, 02/02/2014 - 07:13

We have faced this issue in release 2.11b and now after upgrading firmware 2.1.3b it's got resolved.


This Discussion

Related Content