×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Load Balancing on MPLS\BGP Cloud

Unanswered Question
Mar 27th, 2012
User Badges:

Refer Topology


Right now, both inbound and outbound traffic is using only WAN link 1. WAN link 2 is hired from the same SP but the last mile and AS is different.


Requirement:


1st WAN Link – IP Telephony Traffic

2nd WAN Link – Video Traffic

And all remaining traffic needs to be load balanced between and 1st and 2nd WAN Links.


I need some brain storming here to find out how best we can achieve this using BGP, PfR, PBR,IP SLA etc. Please feel free to ask more questions.


Note: Eventually we will be moving the WAN link-2 to separate router. Then, possibly run iBGP between the two (If at all required).

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (2 ratings)
Loading.
sean_evershed Tue, 03/27/2012 - 05:03
User Badges:
  • Gold, 750 points or more

Hi,


As per the link below using BGP load balancing is not an option in a multihomed environment, you can only do load sharing.

http://www.cisco.com/en/US/tech/tk365/technologies_configuration_example09186a00800945bf.shtml


One option is to manipulate the BGP community values. See below an example config.

http://www.cisco.com/en/US/tech/tk365/technologies_configuration_example09186a00801475b2.shtml

Vinayaka Raman Tue, 03/27/2012 - 06:38
User Badges:

Inbound traffic policy:


  • Using outbound route-map, advertise Site’s Voice and Video prefix with larger as path length via one link.
  • Eventually other link will be preferred by rest of the sites.


Outbound Traffic Policy:


  • Using inbound route-map, set higher weight for the Voice and Video destination prefixes learnt from one of neighbor.
Vinayaka Raman Tue, 03/27/2012 - 06:40
User Badges:

the example listed in the second URL (community-list) is involves route-map at service provider level..I do not think it is feasible...

Joseph W. Doherty Tue, 03/27/2012 - 09:45
User Badges:
  • Super Bronze, 10000 points or more

Disclaimer


The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.


Posting


Assuming number of AS hops to destination would be the save via either link, there's a hidden command (bgp bestpath as-path multipath-relax) that will permit usage of both paths.  Otherwise OER/PfR can utilize both paths (at least outbound).

Marwan ALshawi Tue, 03/27/2012 - 15:01
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

hi Vinayaka,

the features you mentioned al could work such as bgp, PfR or PBR with IP SLA

however in you case you need to think about a scalable, flexible and simple method to achieve your goal

and i would say the simplist is using BGP policies

and the other option using PfR ( but this need a fair amount of testing as you will need to tune some of the timers and polices to meet your needs )


if you go with BGP what you can do ( this apply on using one or two separate routers !)


create ip prefix list to match IP telephone aubnet

and another one to match video subet


outbound on link-1

use a out bound route-map and prepend ASNs to video prefix-list


outbound link-2

use a out bound route-map and prepend ASNs to ip telephony prefix-list


in the inbound direction for remote sites use the same concept but use local prefernce

increase the local preference for remote sites ip telephone inbound from link-1

and inbound from link-2 for video


use the command suggested by joseph above to make sure you can loadbalnce the traffic for a BGP path with differnt ASNs put same number of ASNs in the path


when you going to use iBGP you will need to make sure the loadbalnce will be based on the device before those routers maybe a L3 switch exchanging IGP or iBGP with those edge routers


and again keep it simple always !

see the below figure:


hope this help





Vinayaka Raman Wed, 03/28/2012 - 03:04
User Badges:

"in the inbound direction for remote sites use the same concept but use local prefernce

increase the local preference for remote sites ip telephone inbound from link-1

and inbound from link-2 for video "


All the remote sites prefixes are aggregate subnets (  including voice video and data ) So this implementation isn't feasible, Please advise.

Vinayaka Raman Wed, 03/28/2012 - 04:43
User Badges:

In short, I have a problem with defining prefixes for ibound route-map...

Vinayaka Raman Wed, 03/28/2012 - 08:45
User Badges:

Here is my config. MC\BR on same router. Please help me by reviewing it..thanks


key chain key1
key 1
key-string oer
oer master
logging
mode route control
border 10.200.3.41 key-chain key1
interface Gi0/0.1 internal
interface Serial0/0.457 external
link-group MPLS1
interface Serial2/0.457 external
link-group MPLS2
oer border
logging
local Gi0/0.1
master 10.200.3.41 key-chain key1
learn
list seq 10 refname LEARN_LIST_BRANCH_VIDEO
traffic-class access-list DSCP_VIDEO filter Video_Subnet
aggregation-type prefix-length 32
throughput
!
ip access-list extended DSCP_VIDEO
permit ip any any dscp af41
ip prefix-list Video_Subnet seq 5 permit X.X.X.X
!
list seq 20 refname LEARN_LIST_BRANCH_VOICE
traffic-class access-list DSCP_VOICE filter Voice_Subnet
aggregation-type prefix-length 32
throughput
!
ip access-list extended DSCP_VOICE
permit ip any any dscp EF
ip prefix-list Voice_Subnet seq 5 permit Y.Y.Y.Y
!
list seq 30 refname LEARN_LIST_BRANCH_DATA
traffic-class prefix-list BRANCH_DATA
aggregation-type prefix-length 32
throughput
!
ip prefix-list BRANCH_DATA seq 5 permit 10.32.240.136/29
oer-map MAP-TEST2 10
match oer learn list LEARN_LIST_BRANCH_VIDEO
set periodic 90
set delay threshold 300
set loss threshold 50000
set jitter threshold 30
set mode monitor fast
set resolve loss priority 2 variance 5
set resolve jitter priority 3 variance 5
set resolve delay priority 4 variance 5
no set resolve range
no set resolve utilization
set link-group MPLS1 fallback MPLS2
set probe frequency 4
set active-probe jitter 10.200.1.1 target-port 2002 codec g729a
set active-probe jitter 10.200.1.2 target-port 2001 codec g729a
oer-map MAP-TEST2 20
set periodic 90
set delay threshold 300
set loss threshold 50000
set jitter threshold 30
set mode monitor fast
set resolve loss priority 2 variance 5
set resolve jitter priority 3 variance 5
set resolve delay priority 4 variance 5
no set resolve range
no set resolve utilization
set link-group MPLS2 fallback MPLS1
set probe frequency 4
set active-probe jitter 10.200.1.1 target-port 2002 codec g729a
set active-probe jitter 10.200.1.2 target-port 2001 codec g729a
Vasileios Boulo... Wed, 03/28/2012 - 15:20
User Badges:
  • Silver, 250 points or more

Hi Vinayaka,


I understand your problem to seperate the traffic with the aggregate subnets. So, why dont you match the Voice or Video Traffic according to the DSCP marking.

I assume that the ISP does not remark the TOS byte.

You can use to the route map to modify the BGP attribute (local preferecne) by matching instead of a prefix list the dscp value .

I see from your config that you use

dscp af41 for video

dscp EF for voice


Hope that helps

Vasilis

Vasileios Boulo... Wed, 03/28/2012 - 23:17
User Badges:
  • Silver, 250 points or more

Hi again,

I was thinking about an question for BGP to tan other post and I wrote sth that is not clear to my previous post...

So I will modify my previous post to make clear what i meant.

After matching via a route map the different DSCP values for the voice and video, then you can assign a differnet next hop ip (policy based routing).

dscp af41 for video

dscp EF for voice


When the route map matches voice traffic will assign as next hop IP the Voice link and if matches Video traffic will set the next hop ip of the video link.


Hope that helps!

Vasilis

Marwan ALshawi Thu, 03/29/2012 - 15:02
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

i would suggest you not to use PfR before you test it in a lab

use standard BGP polices as PfR can lead to link flapping or longer convergence time if its not configured correctly based on your network requirements !


HTH

Actions

This Discussion