VPN setup help 5505

Answered Question
Mar 27th, 2012

I am new to using Cisco devices and I need a little help with some setups on an ASA5505 with 8.4.

I want to connect 2 ASA5505's with a site to site.

Site 1

is where I want to connect to.  Site 1 one has access to 192.168.40.x and 192.168.42.x networks.  This device ip is: 192.168.40.254

Site 2

I want to connect to site 1 and see both the 40.x and 42.x networks.  I am able to connect to the 40.x network and can see the devices on it but I can't get to the 42.x network.  This device ip is: 192.168.50.1

The sites are not at the same location just in case anyone asks about that.

I have this problem too.
0 votes
Correct Answer by Jouni Forss about 2 years 3 weeks ago

Hi,

You will need to have both the NAT0 and the Cryptomap ACL defining the traffic you want to get through the L2L-VPN tunnel

And as you have written, the situation to my understanding is this:

Site 1

Networks:

  • 192.168.40.0 255.255.255.0
  • 192.168.42.0 255.255.255.0

NAT0 access-list is: inside_nat0_outbound

VPN traffic access-list is: outside_cryptomap

So to access network 192.168.50.0 255.255.255.0 from your 2 networks at Site 1 your above access-list will have to have atleast the following lines:

access-list inside_nat0_outbound permit ip 192.168.40.0 255.255.255.0 192.168.50.0 255.255.255.0

access-list inside_nat0_outbound permit ip 192.168.42.0 255.255.255.0 192.168.50.0 255.255.255.0

access-list outside_cryptomap permit ip 192.168.40.0 255.255.255.0 192.168.50.0 255.255.255.0

access-list outside_cryptomap permit ip 192.168.42.0 255.255.255.0 192.168.50.0 255.255.255.0

Site 2

Networks:

  • 192.168.50.0 255.255.255.0

NAT0 access-list is: inside_nat0_outbound

VPN traffic access-list is: outside_cryptomap

So to access networks 192.168.40.0 255.255.255.0 and 192.168.42.0 255.255.255.0 from your 1 network at  Site 2 your above access-list will have to have atleast the following  lines:

access-list inside_nat0_outbound permit ip 192.168.50.0 255.255.255.0 192.168.40.0 255.255.255.0

access-list inside_nat0_outbound permit ip 192.168.50.0 255.255.255.0 192.168.42.0 255.255.255.0

access-list outside_cryptomap permit ip 192.168.50.0 255.255.255.0 192.168.40.0 255.255.255.0

access-list outside_cryptomap permit ip 192.168.50.0 255.255.255.0 192.168.42.0 255.255.255.0

As you can see the configuration above are "mirror images" of eachother. They basicly tell the ASA to pass traffic without nat through the L2L VPN connection.

Your original configurations didn't have all the above configurations.

Can you check those and see if youre still missing some configurations?

- Jouni

Correct Answer by Jouni Forss about 2 years 3 weeks ago

Hi,

Seems to me that you don't have the proper rules configured on Site1 and Site2 ASA regarding the VPN

You would need to add the following configurations

Site1

access-list inside_nat0_outbound extended permit ip 192.168.42.0 255.255.255.0 192.168.50.0 255.255.255.0

access-list outside_cryptomap extended permit ip 192.168.42.0 255.255.255.0 192.168.50.0

- These would add both the traffic between the networks to the VPN configurations and pass the traffic unnated to the remote end

Site2

access-list outside_cryptomap extended permit ip 192.168.50.0 255.255.255.0 192.168.42.0 255.255.255.0

This would add the traffic between the networks to the VPN configurations

Seems you already have the NAT0 configurations in place for the networks but not the above line for the VPN itself.

Please rate if it helped

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (2 ratings)
jeronimo1907 Tue, 03/27/2012 - 12:08

Hi Josh,

Can you post a config from both ASAs? From top of my head i can tell that you can add cryptomap ACLs on both devices for 42.x network.

rhopper2012 Tue, 03/27/2012 - 12:51

What would be the best way to output that in a text file?  Sorry new to Cisco.

Jouni Forss Tue, 03/27/2012 - 12:59

Hi,

Easiest way is probably to just connect to the ASA on the command line interface / CLI and use "show run" command to show the whole configuration. Then you can just copy/paste it to notepad.

If there running configuration shows any sensitive information, be sure to change those parts before you post it here (just to be sure).

Is this a lab setup or something in production use? Though you mention device IP as private IP address so that would lead to believe it is a lab setup

rhopper2012 Tue, 03/27/2012 - 13:20

This is not a lab setup.  I had to take over someones account and this is what they had ordered and partically configured it before leaving.  Mind you site 1 has been up and running with the current config for a year or longer Site 2 in the new device that needs to see the 40.x and 42.x from Site 1.

Site 1

: Saved

: Written by enable_15 at 13:20:53.242 UTC Mon Mar 26 2012

!

ASA Version 8.2(5)

!

hostname InsightASA

domain-name nextgen.local

enable password E/F8tlIU69KHLUiQ encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

switchport access vlan 40

!

interface Ethernet0/2

switchport access vlan 40

!

interface Ethernet0/3

switchport access vlan 40

!

interface Ethernet0/4

switchport access vlan 40

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

!

interface Vlan2

nameif outside

security-level 0

ip address 1.1.1.1 255.255.255.0

!

interface Vlan40

nameif inside

security-level 100

ip address 192.168.40.254 255.255.255.0

!

ftp mode passive

dns server-group DefaultDNS

domain-name nextgen.local

same-security-traffic permit intra-interface

access-list inside_nat0_outbound extended permit ip any 10.10.10.0 255.255.255.128

access-list inside_nat0_outbound extended permit ip 192.168.40.0 255.255.255.0 192.168.42.0 255.255.255.0

access-list inside_nat0_outbound extended permit ip 192.168.42.0 255.255.255.0 192.168.40.0 255.255.255.0

access-list inside_nat0_outbound extended permit ip 192.168.40.0 255.255.255.0 192.168.50.0 255.255.255.0

access-list inside_nat0_outbound extended permit ip 10.10.10.0 255.255.255.128 10.10.10.0 255.255.255.128

access-list inside_nat0_outbound extended permit ip 192.168.40.0 255.255.255.0 192.168.40.176 255.255.255.240

access-list inside_nat0_outbound extended permit ip 192.168.50.0 255.255.255.0 192.168.40.0 255.255.255.0

access-list tcp_bypass extended permit ip 192.168.40.0 255.255.255.0 192.168.42.0 255.255.255.0

access-list tcp_bypass extended permit ip 192.168.42.0 255.255.255.0 192.168.40.0 255.255.255.0

access-list Insight2_splitTunnelAcl standard permit 10.10.10.0 255.255.255.128

access-list insight_splitTunnelAcl standard permit 192.168.40.0 255.255.255.0

access-list outside_cryptomap extended permit ip 192.168.40.0 255.255.255.0 192.168.50.0 255.255.255.0

pager lines 24

logging enable

logging asdm informational

mtu outside 1500

mtu inside 1500

ip local pool VPN_Pool 10.10.10.50-10.10.10.70 mask 255.255.255.0

ip local pool Pool2 192.168.40.180-192.168.40.190 mask 255.255.255.0

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list inside_nat0_outbound

nat (inside) 1 192.168.40.0 255.255.255.0

route outside 0.0.0.0 0.0.0.0 66.17.45.254 1

route inside 192.168.42.0 255.255.255.0 192.168.40.251 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

http server enable

http 192.168.40.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac

crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac

crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac

crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac

crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac

crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac

crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5

crypto map outside_map 2 match address outside_cryptomap

crypto map outside_map 2 set peer 2.2.2.2

crypto map outside_map 2 set transform-set ESP-3DES-SHA

crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP

crypto map outside_map interface outside

crypto ca trustpoint _SmartCallHome_ServerCA

crl configure

crypto ca certificate chain _SmartCallHome_ServerCA

certificate ca 6ecc7aa5a7032009b8cebcf4e952d491

    308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130

    0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117

    30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b

    13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504

    0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72

    20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56

    65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043

    65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31

    30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b

    30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20

    496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65

    74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420

    68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329

    3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365

    63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7

    0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597

    a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10

    9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc

    7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b

    15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845

    63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8

    18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced

    4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f

    81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201

    db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868

    7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101

    ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8

    45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777

    2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a

    1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406

    03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973

    69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403

    02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969

    6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b

    c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973

    69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30

    1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603

    551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355

    1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609

    2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80

    4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e

    b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a

    6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc

    481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16

    b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0

    5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8

    6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28

    6c2527b9 deb78458 c61f381e a4c4cb66

  quit

crypto isakmp enable outside

crypto isakmp policy 10

authentication pre-share

encryption 3des

hash sha

group 2

lifetime 86400

telnet 192.168.40.0 255.255.255.0 inside

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd auto_config outside

!

dhcpd address 192.168.40.150-192.168.40.199 inside

dhcpd dns 192.168.42.10 interface inside

dhcpd wins 8.8.8.8 interface inside

dhcpd enable inside

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

group-policy DfltGrpPolicy attributes

group-policy Insight internal

group-policy Insight attributes

dns-server value 192.168.42.10 192.168.40.254

vpn-tunnel-protocol IPSec

default-domain value nextgen.local

group-policy insight internal

group-policy insight attributes

dns-server value 192.168.42.10

vpn-tunnel-protocol IPSec

split-tunnel-policy tunnelspecified

split-tunnel-network-list value insight_splitTunnelAcl

default-domain value nextgen.local

username apsupport password rCHEvpfNv8YVhHQq encrypted privilege 15

username apsupport attributes

vpn-group-policy Insight

username jwheatley password Lq78009.pjhLzdH0 encrypted privilege 0

username jwheatley attributes

vpn-group-policy Insight

tunnel-group 2.2.2.2 type ipsec-l2l

tunnel-group 2.2.2.2 ipsec-attributes

pre-shared-key *

tunnel-group insight type remote-access

tunnel-group insight general-attributes

address-pool Pool2

default-group-policy insight

tunnel-group insight ipsec-attributes

pre-shared-key *

!

class-map inspection_default

match default-inspection-traffic

class-map tcp_bypass

match access-list tcp_bypass

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect rsh

  inspect rtsp

  inspect esmtp

  inspect sqlnet

  inspect skinny 

  inspect sunrpc

  inspect xdmcp

  inspect sip 

  inspect netbios

  inspect tftp

  inspect ip-options

policy-map tcp_bypass_policy

class tcp_bypass

  set connection advanced-options tcp-state-bypass

!

service-policy global_policy global

service-policy tcp_bypass_policy interface inside

prompt hostname context

call-home reporting anonymous

Cryptochecksum:8b5ee644ff00dee73ca4d4b40ded243b

Site 2

: Saved

:

ASA Version 8.2(1)

!

hostname ciscoasa

enable password 8Ry2YjIyt7RRXU24 encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

!

interface Vlan1

nameif inside

security-level 100

ip address 192.168.50.1 255.255.255.0

!

interface Vlan2

nameif outside

security-level 0

ip address 2.2.2.2 255.255.255.0

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

!

ftp mode passive

same-security-traffic permit inter-interface

same-security-traffic permit intra-interface

access-list outside_cryptomap extended permit ip 192.168.50.0 255.255.255.0 192.168.40.0 255.255.255.0

access-list inside_nat0_outbound extended permit ip 192.168.50.0 255.255.255.0 192.168.40.0 255.255.255.0

access-list inside_nat0_outbound extended permit ip 192.168.40.0 255.255.255.0 192.168.50.0 255.255.255.0

access-list inside_nat0_outbound extended permit ip 192.168.50.0 255.255.255.0 192.168.42.0 255.255.255.0

access-list inside_nat0_outbound extended permit ip 192.168.42.0 255.255.255.0 192.168.50.0 255.255.255.0

access-list inside_nat0_outbound extended permit ip 192.168.50.0 255.255.255.0 192.168.40.176 255.255.255.240

pager lines 24

logging asdm informational

mtu inside 1500

mtu outside 1500

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list inside_nat0_outbound

nat (inside) 1 192.168.50.0 255.255.255.0

route outside 0.0.0.0 0.0.0.0 173.165.145.166 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

dynamic-access-policy-record DfltAccessPolicy

http server enable

http 192.168.1.0 255.255.255.0 inside

http 192.168.50.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

crypto map outside_map0 1 match address outside_cryptomap

crypto map outside_map0 1 set peer 1.1.1.1

crypto map outside_map0 1 set transform-set ESP-3DES-SHA

crypto map outside_map0 interface outside

crypto isakmp enable outside

crypto isakmp policy 5

authentication pre-share

encryption 3des

hash sha

group 2

lifetime 86400

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd auto_config outside

!

dhcpd address 192.168.50.45-192.168.50.85 inside

dhcpd dns 75.75.75.75 75.75.76.76 interface inside

dhcpd wins 8.8.8.8 interface inside

dhcpd enable inside

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

tunnel-group 1.1.1.1 type ipsec-l2l

tunnel-group 1.1.1.1 ipsec-attributes

pre-shared-key *

!

!

prompt hostname context

Cryptochecksum:f7687ba469e0f1c2655ea4d52b75faf9

: end

Correct Answer
Jouni Forss Tue, 03/27/2012 - 22:31

Hi,

Seems to me that you don't have the proper rules configured on Site1 and Site2 ASA regarding the VPN

You would need to add the following configurations

Site1

access-list inside_nat0_outbound extended permit ip 192.168.42.0 255.255.255.0 192.168.50.0 255.255.255.0

access-list outside_cryptomap extended permit ip 192.168.42.0 255.255.255.0 192.168.50.0

- These would add both the traffic between the networks to the VPN configurations and pass the traffic unnated to the remote end

Site2

access-list outside_cryptomap extended permit ip 192.168.50.0 255.255.255.0 192.168.42.0 255.255.255.0

This would add the traffic between the networks to the VPN configurations

Seems you already have the NAT0 configurations in place for the networks but not the above line for the VPN itself.

Please rate if it helped

rhopper2012 Wed, 03/28/2012 - 08:51

Just to be sure I should have added: 255.255.255.0 to the end of this line "

access-list outside_cryptomap extended permit ip 192.168.42.0 255.255.255.0 192.168.50.0 " ???

If so I have made these changes an it is not working still.  I am able to see the the 50.x from the 40.x and I can see the 40.x from the 50.x but I am still not able to see the 42.x from t he 50.x but I can still see the 42.x from the 40.x

Correct Answer
Jouni Forss Wed, 03/28/2012 - 10:12

Hi,

You will need to have both the NAT0 and the Cryptomap ACL defining the traffic you want to get through the L2L-VPN tunnel

And as you have written, the situation to my understanding is this:

Site 1

Networks:

  • 192.168.40.0 255.255.255.0
  • 192.168.42.0 255.255.255.0

NAT0 access-list is: inside_nat0_outbound

VPN traffic access-list is: outside_cryptomap

So to access network 192.168.50.0 255.255.255.0 from your 2 networks at Site 1 your above access-list will have to have atleast the following lines:

access-list inside_nat0_outbound permit ip 192.168.40.0 255.255.255.0 192.168.50.0 255.255.255.0

access-list inside_nat0_outbound permit ip 192.168.42.0 255.255.255.0 192.168.50.0 255.255.255.0

access-list outside_cryptomap permit ip 192.168.40.0 255.255.255.0 192.168.50.0 255.255.255.0

access-list outside_cryptomap permit ip 192.168.42.0 255.255.255.0 192.168.50.0 255.255.255.0

Site 2

Networks:

  • 192.168.50.0 255.255.255.0

NAT0 access-list is: inside_nat0_outbound

VPN traffic access-list is: outside_cryptomap

So to access networks 192.168.40.0 255.255.255.0 and 192.168.42.0 255.255.255.0 from your 1 network at  Site 2 your above access-list will have to have atleast the following  lines:

access-list inside_nat0_outbound permit ip 192.168.50.0 255.255.255.0 192.168.40.0 255.255.255.0

access-list inside_nat0_outbound permit ip 192.168.50.0 255.255.255.0 192.168.42.0 255.255.255.0

access-list outside_cryptomap permit ip 192.168.50.0 255.255.255.0 192.168.40.0 255.255.255.0

access-list outside_cryptomap permit ip 192.168.50.0 255.255.255.0 192.168.42.0 255.255.255.0

As you can see the configuration above are "mirror images" of eachother. They basicly tell the ASA to pass traffic without nat through the L2L VPN connection.

Your original configurations didn't have all the above configurations.

Can you check those and see if youre still missing some configurations?

- Jouni

rhopper2012 Wed, 03/28/2012 - 16:52

As it turns out your imfo was helpful and the vpn was working fine.  The remote 42.x network which is another company in the same building they share a server with we needed to add a route on there equipment to allow the 50.x to pass through.  I found this out after I drove to there site and traced cables.

Actions

Login or Register to take actions

This Discussion

Posted March 27, 2012 at 10:52 AM
Stats:
Replies:8 Avg. Rating:5
Views:463 Votes:0
Shares:0
Categories: ASA
+

Related Content

Discussions Leaderboard