No MIB for Nexus port config characteristics?

Unanswered Question
Mar 29th, 2012

I looked through all the MIBs supported on Nexus 7K and could not find an object that would tell me if an Ethernet interface is configured to allow auto-negotiation or not.

So I did a test: on the NX-OS command line, I did an snmpwalk starting from "iso", saved the result to file-1.

Then I configured one interface, say Eth2/32, from speed "auto" to 10G. Ran the above command again and saved the result to file-2.

After that, I extracted all the lines in the two files about interface 2/32 using its ifIndex, diff'ed the results and found no difference except for in/out traffic counters.

Does this mean that NX-OS has no SNMP support for stuff like that?

Have I missed something in my experiement?

Is this an indication of Cisco's moving from SNMP to XML based device management?

Details: I run SNMP v2c. The Nexus box is:

Software

  BIOS:      version 3.22.0

  kickstart: version 5.1(4)

  system:    version 5.1(4)

  BIOS compile time:       02/20/10

  kickstart image file is: bootflash:///n7000-s1-kickstart.5.1.4.bin

  kickstart compile time:  12/25/2020 12:00:00 [06/28/2011 23:28:40]

  system image file is:    bootflash:///n7000-s1-dk9.5.1.4.bin

  system compile time:     5/31/2011 18:00:00 [06/29/2011 00:19:13]

Thanks and regards,

--

Wei Wang

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
yjdabear Thu, 03/29/2012 - 14:47

You mean it's possible to get auto- vs non-auto from SNMP OIDs for non-Nexus, such as IOS)? I couldn't find any when I tried to come up with a similar report for a bunch of cat6k's.

ww9rivers Wed, 04/04/2012 - 00:11

Cat-6K's support the CISCO-STACK-MIB, which has "CISCO-STACK-MIB::portAdminSpeed".

I haven't looked at VSS -- The Cat-6K MIB page has a note saying "Not supported in VSS mode" next to the CISCO-STACK-MIB. Maybe you will have to look at "MAU-MIB::ifMauAutoNegAdminStatus" there.

yjdabear Wed, 04/04/2012 - 09:58

Yeah, but those didn't give me “a-half” or “a-full” like one would get on the IOS CLI, only “half, full, disagree, or auto”. IIRC, the cat6k's I dealt with didn't support MAU-MIB, nor a third candidate MIB I came across--ETHERLIKE-MIB.

Actions

Login or Register to take actions

This Discussion

Posted March 29, 2012 at 11:22 AM
Stats:
Replies:3 Avg. Rating:
Views:568 Votes:0
Shares:0

Related Content

Discussions Leaderboard

Rank Username Points
1 2,483
2 1,624
3 1,445
4 861
5 578